FTBFS: incorrect use of linux-kernel-headers

Bug #37426 reported by Adam Conrad on 2006-03-31
6
Affects Status Importance Assigned to Milestone
ebtables (Ubuntu)
High
MOTU Reviewers Team

Bug Description

ebtables fails to build on all architectures with the following output:

/usr/include/linux/config.h:1:2: error: #error "Compilation aborted. Please read the FAQ for linux-libc-headers package."
/usr/include/linux/config.h:2:2: error: #error "(can be found at http://ep09.pld-linux.org/~mmazur/linux-libc-headers/doc/)"

Please investigate and resolve this. Build logs can be found here:

https://launchpad.net/distros/ubuntu/+source/ebtables/2.0.6-3

(The "builds of ebtables" portlet links through to build info and build logs for each architecture)

Adam Conrad (adconrad) on 2006-03-31
Changed in ebtables:
assignee: nobody → motu
Jérémie Corbier (jcorbier) wrote :

This is caused by a #include <linux/config.h> in include/linux/netfilter_bridge.h. Removing it fixes the bug. Debdiff follows.

Changed in ebtables:
status: Unconfirmed → Confirmed

Removes #include <linux/config.h> from include/linux/netfilter_bridge.h

Changed in ebtables:
assignee: motu → motureviewers
Daniel Holbach (dholbach) wrote :

 ebtables (2.0.6-3ubuntu1) unstable; urgency=low
 .
   * debian/applied-patches/fix-header.patch:
     Fix FTBFS (Closes: Malone #37426): Removed #include <linux/config.h> in
     include/linux/netfilter_bridge.h.

Changed in ebtables:
status: Confirmed → Fix Released
Jérémie Corbier (jcorbier) wrote :

Well, I'm so silly. The package has surely been rejected by soyuz as the distro in the changelog is unstable...

Changed in ebtables:
status: Fix Released → In Progress

I modified the diff to use a patch system as suggested by Daniel. Waiting for upload ;)

Zak B. Elep (zakame) on 2006-04-03
Changed in ebtables:
status: In Progress → Fix Committed
Jérémie Corbier (jcorbier) wrote :

ebtables (2.0.6-3ubuntu1) dapper; urgency=low

  * Fix FTBFS (Closes: Malone #37426): Patch to remove #include
    <linux/config.h> in include/linux/netfilter_bridge.h.

 -- Jeremie Corbier <email address hidden> Fri, 31 Mar 2006 14:03:31 +0200

Changed in ebtables:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers