ebtables cannot be upgraded from 2.0.10.4-3.5ubuntu2 to 2.0.10.4-3.5ubuntu2.18.04.1 on WSL

Bug #1774120 reported by Hayden on 2018-05-30
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
ebtables (Ubuntu)
Low
Dan Streetman
Trusty
Low
Unassigned
Xenial
Low
Balint Reczey
Artful
Low
Balint Reczey
Bionic
Low
Balint Reczey
Cosmic
Low
Dan Streetman

Bug Description

[impact]

ebtables cannot be upgraded on Ubuntu 18.04 for WSL.

[test case]

on a WSL installation that already has ebtables installed (most installations do), try to upgrade the package with apt or dpkg; its prerm script will fail, and prevent the upgrade.

The easiest way of triggering the problem is reinstalling the package:
$ sudo apt install --reinstall ebtables

[regression potential]

the ebtables init script is changed to never return an error code when called as 'stop', so anything that depends on the script returning an error code when 'stop' fails will no longer work correctly. However, nothing appears to use the 'stop' return value, besides the package's prerm script, which is what is causing the upgrade failure. Additionally, the prerm script is updated to ignore 'failed-upgrade' failures, to allow upgrading over the previous version(s).

Finally note that the rpm-specific ebtables.spec file that is included in the package specifically ignores the 'stop' return value, i.e.:

        /sbin/service ebtables stop &>/dev/null || :

[other info]

note that ebtables is effectively dead upstream, so it's extremely unlikely there will be many more package updates/srus, except to fix minor bugs such as this.

[original description]

ebtables cannot be upgraded on Ubuntu 18.04 for WSL.

apt-get upgrade fails with the following error:

Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages will be upgraded:
  ebtables
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/79.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 47381 files and directories currently installed.)
Preparing to unpack .../ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb ...
invoke-rc.d: could not determine current runlevel
 * Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: warning: old ebtables package pre-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
invoke-rc.d: could not determine current runlevel
 * Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: error processing archive /var/cache/apt/archives/ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb (--unpack):
 new ebtables package pre-removal script subprocess returned error exit status 1
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
invoke-rc.d: could not determine current runlevel
Errors were encountered while processing:
 /var/cache/apt/archives/ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb

See https://github.com/Microsoft/WSL/issues/1761

Hayden (recalcitrantowl) wrote :

$ apt-get -V -s upgrade
NOTE: This is only a simulation!
apt-get needs root privileges for real execution.
Keep also in mind that locking is deactivated,
so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
ebtables (2.0.10.4-3.5ubuntu2 => 2.0.10.4-3.5ubuntu2.18.04.1)
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Inst ebtables [2.0.10.4-3.5ubuntu2] (2.0.10.4-3.5ubuntu2.18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf ebtables (2.0.10.4-3.5ubuntu2.18.04.1 Ubuntu:18.04/bionic-updates [amd64])

summary: - ebtables cannot be upgraded on Ubuntu 18.04 for WSL
+ ebtables cannot be upgraded from 2.0.10.4-3.5ubuntu2 to
+ 2.0.10.4-3.5ubuntu2.18.04.1 on WSL
Hayden (recalcitrantowl) wrote :

According to https://github.com/marchom:

"The problem comes from the install/remove scripts trying to do service ebtables stop and failing. You can see this by trying to stop ebtables manually."
https://github.com/Microsoft/WSL/issues/1761#issuecomment-392575807

The temporary workaround is an edit made to /etc/init.d/ebtables. Id.

Another workaround has also been posted. https://github.com/Microsoft/WSL/issues/1761#issuecomment-392578042.

You can also simply mark ebtables to hold in apt. https://github.com/Microsoft/WSL/issues/1761#issuecomment-392608892

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ebtables (Ubuntu):
status: New → Confirmed
Mauricio Lazo (mauriciolazo) wrote :
Download full text (4.2 KiB)

*I get the same result as @Hayden (https://launchpad.net/~recalcitrantowl):*

m*****o@M*****Z:~$ sudo apt update
Get:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [83.2 kB]
Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Get:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [72.4 kB]
Get:6 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [26.0 kB]
Get:7 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [16.8 kB]Get:8 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [8540 B]
Get:9 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [102 kB]
Get:10 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [38.0 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [63.6 kB]
Get:12 http://archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en [27.9 kB]
Fetched 522 kB in 18s (29.3 kB/s)
Reading package lists... Done
Building dependency tree
Preparing to unpack .../1-ubuntu-release-upgrader-core_1%3a18.04.18_all.deb ...
Unpacking ubuntu-release-upgrader-core (1:18.04.18) over (1:18.04.17) ...
Preparing to unpack .../2-python3-distupgrade_1%3a18.04.18_all.deb ...
Unpacking python3-distupgrade (1:18.04.18) over (1:18.04.17) ...
Preparing to unpack .../3-ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb ...
invoke-rc.d: could not determine current runlevel
 * Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: warning: old ebtables package pre-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
invoke-rc.d: could not determine current runlevel
 * Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: error processing archive /tmp/apt-dpkg-install-2xpgP8/3-ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb (--unpack):
 new ebtables package pre-removal script subprocess returned error exit status 1
dmesg: read kernel buffer failed: Function not implemented
                                                          update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
invoke-rc.d: could not determine current runlevel
Preparing to unpack .../4-software-properties-common_0.96.24.32.3_all.deb ...
Unpacking software-properties-common (0.96.24.32.3) over (0.96.24.32.2) ...
Preparing to unpack .../5-python3-software-properties_0.96.24.32.3_all.deb ...
Unpacking python3-software-properties (0.96.24.32.3) over (0.96.24.32.2) ...
Errors were encountered while processing:
Calculating upgrade... Done
The following packages will be upgraded:
  ebtables
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
5 not fully installed or removed.
Need to get 0 B/79.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 28662 files and dir...

Read more...

tags: added: ebtables
Dan Streetman (ddstreet) wrote :

The problem is that on WSL, it appears creating a raw socket is failing:

                sockfd = socket(AF_INET, SOCK_RAW, PF_INET);
                if (sockfd < 0) {
                        ebt_print_error("Problem getting a socket, "
                                        "you probably don't have the right "
                                        "permissions");
                        ret = -1;

That failure isn't going to happen on any 'actual' Linux system (baremetal, vm, or container) - unless you don't have permissions, as the error says. When upgrading a package using apt/dpkg on 'actual' Linux, you will have root access, and so will have permission to create a raw socket. So this is strictly a WSL problem.

Also, this is not a regression - the ebtables init script has behaved this way since trusty (and before). Since the ebtables project is essentially dead upstream, the package is very rarely updated and so WSL users simply haven't noticed this before because they haven't upgraded ebtables before.

However, as it's a trivial fix to the ebtables init script, and presumably a difficult fix to WSL, please test with the package from this ppa:
https://launchpad.net/~ddstreet/+archive/ubuntu/lp1774120

I think that should fix the problem for you - it will still print out a failure/warning message, but it should not break apt package upgrade. Note that I can't test this myself since I have no access to WSL.

Changed in ebtables (Ubuntu Trusty):
status: New → In Progress
Changed in ebtables (Ubuntu Xenial):
status: New → In Progress
Changed in ebtables (Ubuntu Artful):
status: New → In Progress
Changed in ebtables (Ubuntu Bionic):
status: New → In Progress
Changed in ebtables (Ubuntu Cosmic):
status: Confirmed → In Progress
assignee: nobody → Dan Streetman (ddstreet)
Changed in ebtables (Ubuntu Bionic):
assignee: nobody → Dan Streetman (ddstreet)
Changed in ebtables (Ubuntu Artful):
assignee: nobody → Dan Streetman (ddstreet)
Changed in ebtables (Ubuntu Xenial):
assignee: nobody → Dan Streetman (ddstreet)
Changed in ebtables (Ubuntu Trusty):
assignee: nobody → Dan Streetman (ddstreet)
Changed in ebtables (Ubuntu Cosmic):
importance: Undecided → Low
Changed in ebtables (Ubuntu Bionic):
importance: Undecided → Low
Changed in ebtables (Ubuntu Artful):
importance: Undecided → Low
Changed in ebtables (Ubuntu Xenial):
importance: Undecided → Low
Changed in ebtables (Ubuntu Trusty):
importance: Undecided → Low
Dan Streetman (ddstreet) wrote :
AleFranz (alessio-alefranz) wrote :

I can confirm the fix works on WSL

Preparing to unpack .../ebtables_2.0.10.4-3.5ubuntu2.18.04.1+hf1774120v20180531b3_amd64.deb ...
invoke-rc.d: could not determine current runlevel
 * Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: warning: old ebtables package pre-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: ... it looks like that went OK
Unpacking ebtables (2.0.10.4-3.5ubuntu2.18.04.1+hf1774120v20180531b3) over (2.0.10.4-3.5ubuntu2) ...
Processing triggers for ureadahead (0.100.0-20) ...
Setting up netcat-openbsd (1.187-1ubuntu0.1) ...
Setting up python3-problem-report (2.20.9-0ubuntu7.1) ...
Processing triggers for systemd (237-3ubuntu10) ...
Setting up ebtables (2.0.10.4-3.5ubuntu2.18.04.1+hf1774120v20180531b3) ...
Installing new version of config file /etc/init.d/ebtables ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
invoke-rc.d: could not determine current runlevel

Eric Desrochers (slashd) wrote :

Dan, I sponsored the change in devel release (cosmic).

You can go ahead with the SRU upload as soon as ebtables goes into -releases.

Thanks !

Changed in ebtables (Ubuntu Cosmic):
status: In Progress → Fix Committed
Hayden (recalcitrantowl) wrote :

Dan and Eric,

Thank you for addressing this bug, I sincerely appreciate it.

tags: added: patch
Dan Streetman (ddstreet) on 2018-05-31
description: updated
Balint Reczey (rbalint) wrote :

Please note that WSL properly returns EPROTONOSUPPORT to socket() call and ebtables binary translates this to a possible permission issue thus WSL does not have to be fixed because it is not broken.

https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2018-May/018072.html

The ebtables.init and prerm fix together let installation proceed without error and thus is an effective way of dealing with the failure while it does not fix the root cause of misinterpreting the error code.
This is just for the record, I'm happy that ebtables upgrade does not fail now on WSL and thanks for fixing it!

Hayden (recalcitrantowl) wrote :

Balint,

I have opened a bug report upstream with netfilter team, who inherited ebtables, regarding this.

https://bugzilla.netfilter.org/show_bug.cgi?id=1259

Hayden

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ebtables - 2.0.10.4-3.5ubuntu4

---------------
ebtables (2.0.10.4-3.5ubuntu4) cosmic; urgency=medium

  * Never return failure during ebtables.init stop(), it can cause
    errors during package upgrade (LP: #1774120)

 -- Dan Streetman <email address hidden> Thu, 31 May 2018 08:46:43 -0400

Changed in ebtables (Ubuntu Cosmic):
status: Fix Committed → Fix Released
tags: added: id-5b0ff20a61c73d97a81ca9e0
Łukasz Zemczak (sil2100) wrote :

Why is the importance set to low here? Is it because ebtables is dead upstream? Since an upgrade issue for packages that are installed on end-user systems (looks like it's seeded?) seems more serious to me.

Łukasz Zemczak (sil2100) wrote :

I am wondering a bit about the debian/ebtables.prerm change you have proposed in your upload. Your unconditional check for "failed-upgrade" is a bit worrying. It makes sense for the case of upgrade from the previous version, but what if a user has a much older version of the package and the upgrade in prerm really fails? Won't this cause the upgrade to succeed even though it should fail?

Dan Streetman (ddstreet) wrote :

> Why is the importance set to low here?

I set it to low because this bug will only happen AFAICT on WSL. It will always happen there, but on WSL there is no use for ebtables (since it doesn't work there, IIUC). So the major impact is 'apt upgrade' fails, but users can easily work around that by marking ebtables as held to apt, as comment 2 states.

> what if a user has a much older version of the package and the upgrade in prerm really fails?

Currently (and for all previous pkg versions), the only prerm action is what dh_installinit adds by default, which is a call to stop the ebtables service.

The ebtables.init service script, when called to 'stop', does a save (if EBTABLES_SAVE_ON_STOP) as well as a clear.

If the 'save' and/or 'clear' operations fail, that does not matter w.r.t. upgrading ebtables, because those operations manipulate the in-kernel ebtables entries. The new ebtables package provides only userspace programs to control those tables.

Also note that as I mentioned in the SRU template info, the RPM version of ebtables does exactly what I just mentioned; it totally ignores the return value of the ebtables stop action:

%preun
if [ $1 -eq 0 ]; then
 /sbin/service ebtables stop &>/dev/null || :
 /sbin/chkconfig --del ebtables
fi

Because older versions of ebtables will *always* fail during upgrade (or remove!) on WSL, the new prerm script needs to always ignore 'upgrade-failed' errors, unless we want to add a specific test that it's running on WSL (like checking for -EPROTONOSUPPORT from socket()). However, that seems overly complicated and fragile, and I see no reason that we shouldn't simply ignore the 'upgrade-failed' error based on what we know happens during prerm 'upgrade'.

If you prefer a simpler change, I can re-upload (to cosmic and SRU) with the ebtables.init changes removed, and only a modified ebtables.prerm file to simply ignore both 'upgrade' and 'upgrade-failed' errors (at the appropriate points in the prerm script).

Balint Reczey (rbalint) wrote :

@ddstreen I think @sil2100 is suggesting ignoring failed-upgrade from known-bad versions in .prerm. It is an established practice and would not shadow future different breakages.

Dan Streetman (ddstreet) wrote :
Dan Streetman (ddstreet) wrote :

@sil2100 @rbalint, if the above cosmic debdiff looks like what you're suggesting, please upload it to cosmic, and I'll re-upload to the SRU releases once cosmic is in place. Thanks.

An upload of ebtables to bionic-proposed has been rejected from the upload queue for the following reason: "I'm rejecting this given the concerns that rbalint and sil2100 have, its easy to save a package from the rejection queue if I'm wrong.".

Balint Reczey (rbalint) wrote :

@ddstreet I think this is what @sil2100 suggested, indeed. @sil2100?

Dimitri John Ledkov (xnox) wrote :

IMHO this is a class of issues on WSL. Given that systemd is not services should be attempted to be stopped, nor started.

systectl calls are guarded and check for presense of /run/systemd/system, I'm confused as to why the lsb-hook on ubuntu doesn't have the same guard as well. Given that on ubuntu, we do not support anything by systemd init, and thus should not be attempting to neither start nor stop init.d scripts directly without systemctl/systemd rediction.

If we were to fix lsb-hook, we would fix this class of issues not only for the ebtables package, but for all packages that ship init.d scripts only without systemd units.

about ebtables init.d script, imho it is fine for it to continue to fail as it does now. Given that init.d script should not have been executed in WSL at all during package install/removal/upgrade anyway.

I'd rather fix this class of upgrade issues, rather than hunting down every single package, given that WSL platform is what it is.

Download full text (8.6 KiB)

On Wed, Jun 20, 2018 at 2:11 PM Dimitri John Ledkov 🌈
<email address hidden> wrote:
>
> IMHO this is a class of issues on WSL. Given that systemd is not
> services should be attempted to be stopped, nor started.

I had the same idea for a little, but IMO trying to address the class
of potentially broken init scripts by masking them is not a good idea
in general and also would cause serious regression in Ubuntu on
Windows app's usability.

It is true that packages disable functionality when the functionality
is unlikely to be needed in a given environment like
/etc/kernel/postrm.d/zz-update-grub skips updating grub if
systemd-detect-virt identifies the system as a container environment
but in case of WSL the system features to be supported seems to be
open-ended. For example we now may think that managing services from
maintainer scripts should be skipped by short-cutting helpers, but
services can actually be run on WSL. Just try:
$ sudo apt install apache2
$ sudo service apache2 start

It runs, and it is even stopped when apache2 is reinstalled:

ubuntu@rbalint1:~$ sudo apt-get install --reinstall apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 95.1 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64
apache2 amd64 2.4.29-1ubuntu4.1 [95.1 kB]
Fetched 95.1 kB in 0s (1075 kB/s)
(Reading database ... 35177 files and directories currently installed.)
Preparing to unpack .../apache2_2.4.29-1ubuntu4.1_amd64.deb ...
invoke-rc.d: could not determine current runlevel
 * Stopping Apache httpd web server apache2
                                                  *
Unpacking apache2 (2.4.29-1ubuntu4.1) over (2.4.29-1ubuntu4.1) ...
Processing triggers for ufw (0.35-5) ...
Setting up apache2 (2.4.29-1ubuntu4.1) ...
invoke-rc.d: could not determine current runlevel
invoke-rc.d: could not determine current runlevel
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for systemd (237-3ubuntu10) ...
Processing triggers for man-db (2.8.3-2) ...
ubuntu@rbalint1:~$

It is not started again, though, but we are close to it. Rather than
disabling services I'd propose going forward with fixing starting and
stopping services and disabling the ones in the image which are
installed by default but which collide with Windows ones.

>
> systectl calls are guarded and check for presense of
> /run/systemd/system, I'm confused as to why the lsb-hook on ubuntu
> doesn't have the same guard as well. Given that on ubuntu, we do not
> support anything by systemd init, and thus should not be attempting to
> neither start nor stop init.d scripts directly without systemctl/systemd
> rediction.
>
> If we were to fix lsb-hook, we would fix this class of issues not only
> for the ebtables package, but for all packages that ship init.d scripts
> only without systemd units.

Please note that despite Ubuntu does not officially support running
other init systems the byproduct of still having init.d script is a
lot of very happy users running...

Read more...

Balint Reczey (rbalint) wrote :

@ddstreet I uploaded a backported patch to Bionic to make it to the .1 point release.

Changed in ebtables (Ubuntu Trusty):
status: In Progress → Won't Fix
Balint Reczey (rbalint) wrote :

I also marked Trusty as wontfix since Trusty is not provided for WSL.

Hayden (recalcitrantowl) wrote :

Thank you Balint.

Balint Reczey (rbalint) on 2018-06-28
Changed in ebtables (Ubuntu Xenial):
assignee: Dan Streetman (ddstreet) → Balint Reczey (rbalint)
Changed in ebtables (Ubuntu Artful):
assignee: Dan Streetman (ddstreet) → Balint Reczey (rbalint)
Changed in ebtables (Ubuntu Bionic):
assignee: Dan Streetman (ddstreet) → Balint Reczey (rbalint)
description: updated

Hello Hayden, or anyone else affected,

Accepted ebtables into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ebtables/2.0.10.4-3.5ubuntu2.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ebtables (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Hayden, or anyone else affected,

Accepted ebtables into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ebtables/2.0.10.4-3.5ubuntu2.17.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ebtables (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed-artful
Łukasz Zemczak (sil2100) wrote :

Ok, actually I accepted the artful package too early. The artful and xenial packages need a re-upload since the dpkg --compare-versions has the version from bionic. Those need to be fixed to use version numbers for their respective series.

So please re-upload xenial and artful. I'll reject xenial now.

Hayden (recalcitrantowl) wrote :

I did some testing with bionic-proposed, it must not have come through yet.

https://gist.github.com/sirredbeard/7afc9a95cb040a7d0886301cb26ccaae

Brian Murray (brian-murray) wrote :

Hello Hayden, or anyone else affected,

Accepted ebtables into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ebtables/2.0.10.4-3.5ubuntu2.18.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Hayden, or anyone else affected,

Accepted ebtables into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ebtables/2.0.10.4-3.5ubuntu2.17.10.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ebtables (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Hayden, or anyone else affected,

Accepted ebtables into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ebtables/2.0.10.4-3.4ubuntu2.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dan Streetman (ddstreet) wrote :

Thanks @rbalint, I just got back from vac.

Changed in ebtables (Ubuntu Trusty):
assignee: Dan Streetman (ddstreet) → nobody
Balint Reczey (rbalint) wrote :

@recalcitrantowl Thanks looking into verification. It usually takes a little time to get the packages on the mirrors, it should be fine now for all the releases.

Hayden (recalcitrantowl) wrote :

@rbalint

I can confirm working in bionic-proposed on WSL.

https://gist.github.com/sirredbeard/6c5f4a6501233c7887234e3b7ca64bc8

Balint Reczey (rbalint) on 2018-07-05
tags: added: verification-done-bionic
removed: verification-needed-bionic
Balint Reczey (rbalint) on 2018-07-05
tags: added: verification-done verification-done-artful verification-done-xenial
removed: verification-needed verification-needed-artful verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

I'll be releasing this since the test case obviously only requires the package to be installable, but for the future please be more verbose with testing (i.e. xenial and artful). Even for simple test cases like these please include what operations have been performed as part of testing, noting down the package versions (in this case, to which package version the upgrade has been performed for each series. The SRU team needs to know if the correct packages have been used.

Balint Reczey (rbalint) wrote :

Tested version on Xenial: 2.0.10.4-3.4ubuntu2.16.04.2

Log:
...
ubuntu@rbalint11:~$ sudo apt install --reinstall ebtables=2.0.10.4-3.4ubuntu2.16.04.2
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libfreetype6
Use 'sudo apt autoremove' to remove it.
The following packages will be upgraded:
  ebtables
1 upgraded, 0 newly installed, 0 to remove and 22 not upgraded.
Need to get 79.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 ebtables amd64 2.0.10.4-3.4ubuntu2.16.04.2 [79.9 kB
]
Fetched 79.9 kB in 0s (1,101 kB/s)
(Reading database ... 25691 files and directories currently installed.)
Preparing to unpack .../ebtables_2.0.10.4-3.4ubuntu2.16.04.2_amd64.deb ...
invoke-rc.d: could not determine current runlevel
 * Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: ... it looks like that went OK
Unpacking ebtables (2.0.10.4-3.4ubuntu2.16.04.2) over (2.0.10.4-3.4ubuntu2.16.04.1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for systemd (229-4ubuntu21.2) ...
Processing triggers for ureadahead (0.100.0-19) ...
Setting up ebtables (2.0.10.4-3.4ubuntu2.16.04.2) ...
Installing new version of config file /etc/init.d/ebtables ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
invoke-rc.d: could not determine current runlevel
Processing triggers for systemd (229-4ubuntu21.2) ...
Processing triggers for ureadahead (0.100.0-19) ...
ubuntu@rbalint11:~$

Balint Reczey (rbalint) wrote :

Tested version on Artful: 2.0.10.4-3.5ubuntu2.17.10.3

Log:
...
ubuntu@rbalint11:~$ sudo apt install --reinstall ebtables=2.0.10.4-3.5ubuntu2.17.10.3
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libfreetype6 libgolang-github-gorilla-context1 libgolang-github-gorilla-mux1 libgolang-github-mattn-go-sqlite3-1
  libgolang-github-pborman-uuid1 libgolang-gocapability1 libgolang-golang-x-net1 libgolang-golang-x-text1
  libgolang-gopkg-flosch-pongo2.v3-1 libgolang-gopkg-lxc-go-lxc.v2-1 libgolang-gopkg-tomb.v2-1
  libgolang-goprotobuf1 libgolang-petname1 libpython3.5 xdelta3
Use 'sudo apt autoremove' to remove them.
The following packages will be upgraded:
  ebtables
1 upgraded, 0 newly installed, 0 to remove and 15 not upgraded.
Need to get 79.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu artful-proposed/main amd64 ebtables amd64 2.0.10.4-3.5ubuntu2.17.10.3 [79.9 kB
]
Fetched 79.9 kB in 0s (1,040 kB/s)
(Reading database ... 27926 files and directories currently installed.)
Preparing to unpack .../ebtables_2.0.10.4-3.5ubuntu2.17.10.3_amd64.deb ...
invoke-rc.d: could not determine current runlevel
 * Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
dpkg: ... it looks like that went OK
Unpacking ebtables (2.0.10.4-3.5ubuntu2.17.10.3) over (2.0.10.4-3.5ubuntu2.17.10.1) ...
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for systemd (234-2ubuntu12.4) ...
Setting up ebtables (2.0.10.4-3.5ubuntu2.17.10.3) ...
Installing new version of config file /etc/init.d/ebtables ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
invoke-rc.d: could not determine current runlevel
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for systemd (234-2ubuntu12.4) ...
ubuntu@rbalint11:~$

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ebtables - 2.0.10.4-3.5ubuntu2.18.04.3

---------------
ebtables (2.0.10.4-3.5ubuntu2.18.04.3) bionic; urgency=medium

  * Update versions to fix in prerm to Bionic's ebtables versions

ebtables (2.0.10.4-3.5ubuntu2.18.04.2) bionic; urgency=medium

  [ Dan Streetman ]
  * Never return failure during ebtables.init stop(), it can cause
    errors during package upgrade (LP: #1774120)
  * Add version number check to prerm script, to only ignore
    failed upgrade for older versions instead of all versions.

 -- Balint Reczey <email address hidden> Thu, 28 Jun 2018 18:42:04 +0200

Changed in ebtables (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ebtables has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ebtables - 2.0.10.4-3.5ubuntu2.17.10.3

---------------
ebtables (2.0.10.4-3.5ubuntu2.17.10.3) artful; urgency=medium

  * Update versions to fix in prerm to Artful's ebtables versions

ebtables (2.0.10.4-3.5ubuntu2.17.10.2) artful; urgency=medium

  [ Dan Streetman ]
  * Never return failure during ebtables.init stop(), it can cause
    errors during package upgrade (LP: #1774120)
  * Add version number check to prerm script, to only ignore
    failed upgrade for older versions instead of all versions.

 -- Balint Reczey <email address hidden> Thu, 28 Jun 2018 18:24:36 +0200

Changed in ebtables (Ubuntu Artful):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ebtables - 2.0.10.4-3.4ubuntu2.16.04.2

---------------
ebtables (2.0.10.4-3.4ubuntu2.16.04.2) xenial; urgency=medium

  [ Dan Streetman ]
  * Never return failure during ebtables.init stop(), it can cause
    errors during package upgrade (LP: #1774120)
  * Add version number check to prerm script, to only ignore
    failed upgrade for older versions instead of all versions.

  [ Balint Reczey ]
  * Update versions to fix in prerm to Xenial's ebtables versions

 -- Balint Reczey <email address hidden> Thu, 28 Jun 2018 18:04:35 +0200

Changed in ebtables (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.