package ebtables 2.0.10.4-2ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1176436 reported by Anders Kaseorg on 2013-05-04
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ebtables (Debian)
Fix Released
Unknown
ebtables (Ubuntu)
Undecided
Iain Lane

Bug Description

Setting up ebtables (2.0.10.4-2ubuntu1) ...
Installing new version of config file /etc/init.d/ebtables ...
update-rc.d: error: start|stop arguments not terminated by "."
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | SS KK]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
       update-rc.d [-n] <basename> disable|enable [S|2|3|4|5]
  -n: not really
  -f: force

The disable|enable API is not stable and might change in the future.
dpkg: error processing ebtables (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for ureadahead ...
Errors were encountered while processing:
 ebtables

ProblemType: Package
DistroRelease: Ubuntu 13.10
Package: ebtables 2.0.10.4-2ubuntu1
ProcVersionSignature: Ubuntu 3.9.0-0.4-generic 3.9.0
Uname: Linux 3.9.0-0-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.10-0ubuntu1
AptOrdering:
 ebtables: Install
 ebtables: Configure
Architecture: amd64
Date: Sat May 4 17:32:15 2013
EcryptfsInUse: Yes
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2010-12-05 (881 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
MarkForUpload: True
SourcePackage: ebtables
Title: package ebtables 2.0.10.4-2ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to saucy on 2012-11-15 (170 days ago)

Anders Kaseorg (andersk) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ebtables (Ubuntu):
status: New → Confirmed
Iain Lane (laney) on 2013-05-05
Changed in ebtables (Ubuntu):
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ebtables - 2.0.10.4-2ubuntu2

---------------
ebtables (2.0.10.4-2ubuntu2) saucy; urgency=low

  * Add trailing "." to update-rc.d arguments (LP: #1176436)
 -- Iain Lane <email address hidden> Sun, 05 May 2013 20:14:40 +0100

Changed in ebtables (Ubuntu):
status: Confirmed → Fix Released
Changed in ebtables (Debian):
status: Unknown → New
Changed in ebtables (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.