Windows 'jump' up and down when maximized

Bug #208079 reported by Mark Pokorny on 2008-03-28
78
This bug affects 6 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
easytag (Ubuntu)
Undecided
Unassigned
inkscape (Ubuntu)
High
Tabuia

Bug Description

Description: Ubuntu hardy (development branch)
Release: 8.04
Packages:
    easytag 2.1.4-1
    inkscape 0.46-0ubuntu1
    nautilus 1:2.22.1-0ubuntu1

When maximized with a screen resolution of 1024 by 768 pixels, the various application windows are slightly larger than the available viewing space. This makes the window 'jump' up or down so that the top (or bottom) of the window is aligned with the top (or bottom) of the desktop each time the mouse is clicked. The attached picture shows the top gnome panel overlapping the title bar, with the bottom of the window flush with the bottom gnome panel. Upon clicking the mouse, the window will move down by the distance of the overlap.

Mark Pokorny (iridium193) wrote :
description: updated
mexlinux (mcanedo) wrote :

I can confirm this behaivor with Inkscape on Hardy updated, also on my resolution 1280x800
ONLY while using compiz.

Mark Pokorny (iridium193) wrote :

@ mexlinux:
My apologies, I don't know what I was thinking when I added 'nautilus' to the affected packages - obviously this was incorrect. I probably meant 'metacity', but as you've pointed out, it is probably more likely to be 'compiz' that's causing it (seeing as I was running it, rather than 'metacity', at the time).

nglnx (nglnx) wrote :

Confirming this with inkscape and easytag with compiz on under hardy with full updates. Note that changing the window decorations to some themes (like crux, but not clear looks) makes this behavior go away.

Changed in inkscape:
status: New → Confirmed
Changed in easytag:
status: New → Confirmed
nglnx (nglnx) wrote :

As can be seen from the duplicate, this bug happens with several resolutions. What they all seem to have in common is compiz and the use of several themes (human, clearlooks,..)

nglnx (nglnx) wrote :

May I also add that in my case it renders the packages unusable since I am unable to use the menus once maximized.

Patrice Vetsel (vetsel-patrice) wrote :

@nglnx : as said in my comment in #213064 :

« with compiz not activated » ;)

nglnx (nglnx) wrote :

Patrice,

Thank you for bringing you comment to my attention. I am sorry for having missed it. :)

So let me try to rephrase it:

To sum things up we have a bug that affects several screen resolutions, possibly spans graphics cards and, is common to more than one app and only shows itself under specific themes.

nglnx (nglnx) wrote :

Something new I discovered is that setting both the top and bottom gnome panels to auto-hide makes the problem go away in both easytag and inkscape.

Might this bug be related with this one https://bugs.launchpad.net/inkscape/+bug/168648 (Inkscape sets minimial window size too large)

Changed in compiz:
status: New → Invalid
nglnx (nglnx) wrote :

It seems that part of this problem has been aknowledged by inkscape developers and that a fix is on the way:

http://codewideopen.blogspot.com/2008/04/freedom-from-size-tyrany.html

According to the above page, many of the issues with size are due to the use of custom toolbars from before GTK+ had stock ones and the fact that preferences to make toolbar smaller have no effect on Ubuntu.

A specific bug report was opened https://bugs.launchpad.net/inkscape/+bug/221676 and now has in progress status.

Let us hope that this at least mitigates the size issues in inkscape.

Changed in inkscape:
status: Confirmed → In Progress
Bryce Harrington (bryce) on 2008-05-24
Changed in inkscape:
status: In Progress → Triaged
Ralph (christian-asker) wrote :

I can also confirm this bug in Hardy. It also happens with Evolution when opening a second window.

I set to high and milestone -> 8.10 because inkscape is just unusable

Changed in inkscape:
importance: Undecided → High
milestone: none → ubuntu-8.10

https://bugs.launchpad.net/inkscape/+bug/221676 is "fix released" can we backport the patch please ?

I confirm this bug with easytag and compiz activated on Intrepid.
If I disable Compiz (desktop effects), the up&down move disapear... Only a little bottom part of easytag window is hidden.

We can see a bug in compiz (the up and down moves while mouse click) but also a bug in the software (easytag) because devs should keep in mind that some users are still with low (1024x768) resolutions...
Easytag devs should reduce something in the design of the software to display the entire window in a smaller space.

Sergiu Bivol (sergiu-bivol) wrote :

I notice this behavior when using a virtual machine.
It is not a problem with the application itself, but rather the window-manager's fault that it does not know how to handle large windows. There is no way that application developers could know what screen resolution are you going to use.

We are talking about a weird behavior of the window manager.

Bryce Harrington (bryce) wrote :

Dropping the 8.10 milestone since a backported 0.46.x patch is not yet available.

Most likely, in jaunty we'll probably move to 0.47 if it's released, or a git snapshot if not.

Changed in inkscape:
milestone: ubuntu-8.10 → none
mexlinux (mcanedo) wrote :

This is solved for me in Intrepid

laan (kontakt-andreaslang) wrote :

unfortunately I have to say that thisbug still exists under jaunty : fullsized inkscape is still unusable. But the trick with the autohidden panels does work.
even this is not the way I prefer my desktop...

Matthijs (matthijsvanwolferen) wrote :

I've never had this bug, but the problem occurs on i386 Jaunty Jackalope.

I can't pinpoint any exact action that triggers the behaviour, except that it usually happens to Evolution.

Giacomo Mirabassi (giacmir) wrote :

I've the same problem in jaunty.
resolution: 1366x768
theme: human
compiz activated

The solution I use to work with the maximized window is to detach the left toolbar before maximizing.

Bryce Harrington (bryce) wrote :

A pre-release of the upcoming Inkscape 0.47 is now available in Ubuntu
Karmic for testing. Because *so* much stuff has changed compared with
the version you reported your bug against, would you mind re-testing
this new version and see if this bug is now resolved?

Karmic Alpha CD ISO images are available at:

  http://cdimage.ubuntu.com/releases/karmic/

If you're not testing Karmic yet, there are .debs of this new Inkscape
for Jaunty, Hardy, and Intrepid here:

  https://launchpad.net/~inkscape.testers/+archive/ppa

You might find further bugs when testing this alpha release. If that is
the case, please file a NEW bug report here:

   https://edge.launchpad.net/inkscape/+filebug

Thanks ahead of time for your testing efforts, and enjoy the new Inkscape!

Changed in inkscape (Ubuntu):
status: Triaged → New
status: New → Incomplete
Giacomo Mirabassi (giacmir) wrote :

I just installed version 0,47. No jumps anymore.

Bryce Harrington (bryce) wrote :

Thanks for letting us know the issue is resolved.

Changed in inkscape (Ubuntu):
status: Incomplete → Fix Released
Tabuia (tabuiaia) on 2009-09-26
Changed in inkscape (Ubuntu):
assignee: nobody → Tabuia (tabuiaia)
DanielRoesler (diafygi) wrote :

I can confirm that this issue is fixed with inkscape in ubuntu karmic 9.10 beta.

Dimitrios Symeonidis (azimout) wrote :

Does anyone still have this issue with easytag in Karmic?

Changed in easytag (Ubuntu):
status: Confirmed → Incomplete
DanielRoesler (diafygi) wrote :

The issue seems to be fixed for me with Karmic beta.

Dimitrios Symeonidis (azimout) wrote :

closing as fix released, as per your last comment

Changed in easytag (Ubuntu):
status: Incomplete → Fix Released
Changed in easytag (Ubuntu):
assignee: nobody → Pollie Mikhie (trixinboots)
assignee: Pollie Mikhie (trixinboots) → nobody

Bug is still present for EasyTAG in 10.04 LTS and 11.04. That's bad. Things should work with 1024x768.

ThaFox (kehakettu) wrote :

I can confirm EasyTAG bug in 10.04 LTS. I have 1280x800 resolution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers