easytag does not start

Bug #1160729 reported by Stilor on 2013-03-27
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
easytag (Ubuntu)
Undecided
Unassigned

Bug Description

easytag waits forever at startup.

Expected behavior: easytag's window should appear.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: easytag 2.1.7-2
ProcVersionSignature: Ubuntu 3.8.0-14.24-generic 3.8.4
Uname: Linux 3.8.0-14-generic x86_64
ApportVersion: 2.9.2-0ubuntu4
Architecture: amd64
Date: Tue Mar 26 23:41:32 2013
InstallationDate: Installed on 2013-03-16 (10 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130314)
MarkForUpload: True
SourcePackage: easytag
UpgradeStatus: No upgrade log present (probably fresh install)

Stilor (stilor) wrote :
Stilor (stilor) wrote :
Download full text (4.4 KiB)

Stack trace of the hang

avn@mistral:~$ gdb `which easytag`
GNU gdb (GDB) 7.5-ubuntu
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/easytag...(no debugging symbols found)...done.
(gdb) r
Starting program: /usr/bin/easytag
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffed810700 (LWP 3562)]
^C
Program received signal SIGINT, Interrupt.
0x00007ffff4d1a3cd in poll () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) bt
#0 0x00007ffff4d1a3cd in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007ffff6b821dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007ffff6b826ba in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007ffff6bc3e41 in g_spawn_sync () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007ffff6bc42b8 in g_spawn_command_line_sync () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5 0x00007fffede58184 in Oxygen::QtSettings::kdeConfigPathList() const () from /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#6 0x00007fffede5aca7 in Oxygen::QtSettings::initialize(unsigned int) () from /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#7 0x00007fffede6c485 in Oxygen::Style::initialize(unsigned int) () from /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#8 0x00007fffede6c875 in Oxygen::Style::instance() () from /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#9 0x00007fffedeb3f66 in theme_init () from /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#10 0x00007ffff799ab16 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#11 0x00007ffff6e68501 in g_type_module_use () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#12 0x00007ffff799ac25 in gtk_theme_engine_get () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#13 0x00007ffff792363b in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#14 0x00007ffff79243a5 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#15 0x00007ffff7924568 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#16 0x00007ffff79230b2 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#17 0x00007ffff79243a5 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#18 0x00007ffff7924568 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#19 0x00007ffff7924b7f in gtk_rc_reparse_all_for_settings () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#20 0x00007ffff7941b15 in gtk_settings_get_for_screen () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#21 0x00007ffff79567e9 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#22 0x00...

Read more...

Stilor (stilor) wrote :

Another data point: "sudo easytag" works - shows program's window.
Other Gnome apps also work ok (e.g. Evolution)

Any clues?

Jeremy LaCroix (j-jlacroix) wrote :

Same problem here. Easytag doesn't start. Running it as root works, however.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in easytag (Ubuntu):
status: New → Confirmed
Jeremy LaCroix (j-jlacroix) wrote :

I noticed that this bug no longer happens if i go into System Settings and change the GTK theme to anything other than oxygen-gtk.

Stilor (stilor) wrote :

Thanks for work around, it helps, although I'll miss oxygen eye candy.

Klaus Kettner (klaus-kettner) wrote :

Even more strange:

Easytag did not start, strace gave strange information. After reading this thread I tried successfully as root and now Easytag also runs under my normal user-account. Did not change anything.

Klaus Kettner (klaus-kettner) wrote :

OK, forget that. Worked just once ... :(

marco (nazgul17) wrote :

I have the same problem. Here is strace output: http://pastebin.com/2Y6emLb6

Nick B. (futurepilot) wrote :

I ran into this bug too. Definitely looks to be related to the oxygen-gtk theme. Dirty workaround without having to disable oxygen-gtk or run as root:
GTK2_RC_FILES=/usr/share/themes/Clearlooks/gtk-2.0/gtkrc easytag

This will run only easytag with the Clearlooks theme. Doesn't look very nice in KDE but it works.

Daryn (daryn-3) wrote :

Same problem here for me in Kubuntu 13.04, using Oxygen. running as root works but it is ugly.

Andreas Roth (aroth) wrote :

Same problem on my machine (Kubuntu 13.04 with oxygen-gtk as selected GTK style). The workaround from #11 works. Thx

jajaX (jajaplanet) wrote :

Hi !

same problem for me !

Hizoka (hizo) wrote :

Same problem.

Kubuntu 64 v13.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers