Easytag-aac crashes when selecting first letter uppercase of each word

Bug #230938 reported by Nick B. on 2008-05-16
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
easytag-aac (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: easytag-aac

Easytag-aac crashes on Hardy when attempting to capitalize the first letter or each word in file.
Steps to reproduce
1. Open Easytag and select an mp3 file to edit
2. Right click in any one of the fields and select "First letter uppercase of each word"
3. Easytag crashes

What should happed
Easytag should make the first letter of each word upercase

This only happens with Easytag-aac, not the regular Easytag.

easytag-aac:
  Installed: 2.1.5-0.0
  Candidate: 2.1.5-0.0
  Version table:
 *** 2.1.5-0.0 0
        500 http://us.archive.ubuntu.com hardy/multiverse Packages
        100 /var/lib/dpkg/status

Sergio Barjola (sbarjola) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
I can reproduce it too, so setting to confirmed.

Changed in easytag-aac:
status: New → Confirmed
Sergio Barjola (sbarjola) wrote :

added backtrace

Sergio Barjola (sbarjola) wrote :

looking at the code, seems that error is in line (scan.c:1806):
if (!GTK_TOGGLE_BUTTON(ProcessFieldsDetectRomanNumerals)->active)

ProcessFieldsDetectRomanNumerals is a checkbox initialized at NULL. It's created at Scanner->Process Fields dialog, so I think that check its state before create it.

If you open the dialog before call the "First letter uppercase of each word" function it not crash.

Andrea Caminiti (nrayever) wrote :

hi guys:

this bug just happend to me a few minutes ago. i'm using intrepid alpha 4, and is easytag-aac. i tried to use the option "Make first letter upper case" in a genre field.

is this bug only related with ubuntu, if not to notify easytag developers. thanks guys!

Sergio Barjola (sbarjola) wrote :

A long time after, I've tested with ubuntu 12.10 and now it works ok.
Version of easytag: 2.1.7-2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers