Easystroke doesn't recognize button release

Bug #757972 reported by Julian Held on 2011-04-11
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
easystroke (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Medium
Chase Douglas

Bug Description

Binary package hint: easystroke

After todays upgrades easystroke stopped working properly.

When I start a gesture it draws the correct movements on the screen but fails to recognize when I release the mouse button and therefore doesn't execute the command for that gesture. Instead it keeps on drawing the gesture until I hit a button (another or the same) to cancel the gesture.

Exactly 50% of the time the gesture fails to start and instead a right click gets executed, if mapped to the right mouse button. If mapped to any other mouse button, the gesture starts every time, but still fails to stop on button release.

Simple clicking the right mouse button also starts a gesture 50% of the time, no different to holding that button.
Clicking with any other mouse button starts the gesture every time.

Using: Ubuntu natty, up to date
compiz or metacity, makes no difference

Among todays upgrades were xserver-common, xserver-xorg-core and xserver-xorg-input-all

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: easystroke 0.5.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Mon Apr 11 21:34:37 2011
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: easystroke
UpgradeStatus: Upgraded to natty on 2011-03-06 (35 days ago)
---
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,grid,place,snap,regex,mousepoll,shift,resize,gnomecompat,wall,vpswitch,move,imgpng,session,animation,workarounds,expo,ezoom,fade,scale]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DistUpgraded: Log time: 2011-03-06 20:30:36.102184
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
GraphicsCard:
 ATI Technologies Inc Juniper [Radeon HD 5700 Series] [1002:68b8] (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. Device [1462:2140]
MachineType: System manufacturer System Product Name
Package: xorg-server (not installed)
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=4ca0aefc-bbf9-4f69-a8ed-47a6c8ec2756 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
Tags: natty ubuntu compiz-0.9
Uname: Linux 2.6.38-8-generic x86_64
UpgradeStatus: Upgraded to natty on 2011-03-06 (37 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare sudo
dmi.bios.date: 09/09/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0502
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P7P55D LE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0502:bd09/09/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP7P55DLE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4+bzr20110411-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu12
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Related branches

Julian Held (julian-held) wrote :
Tom Jaeger (thjaeger) wrote :

Thanks for your bug report. This looks to be a bug introduced in the latest xserver update: the new server does not seem to handle XI2 SD button grabs correctly anymore. I'll forward the issue upstream.

Tom Jaeger (thjaeger) on 2011-04-12
affects: easystroke → xorg-server
Changed in xorg-server:
importance: Unknown → Medium
status: Unknown → Confirmed
Observer (dbvweb) wrote :

This is also affecting me.

To add on, it affects not just easystroke, but any other app that uses mouse right-click.
Further, this behaviour seem to make the right mouse click is "stuck" once you click on it. In some cases, it seem to extend to left-click as well. So in Google Chrome, the grab to scroll extension is stuck with it as a result.

For me, when it goes into this behaviour, I cannot do left click, until I do a few right clicks and the system snap out of it.

Bryce Harrington (bryce) wrote :

Please run 'apport-collect 757972'

Changed in xorg-server (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected compiz-0.9 ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Timo Aaltonen (tjaalton) wrote :

Chase, can you check if the 1.10.1rc2 update and the multitouch patch don't fully work together anymore?

Changed in xorg-server (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
status: Incomplete → New
status: New → Incomplete
Chase Douglas (chasedouglas) wrote :

I don't see anything odd with the update, and I'm running it here without issues.

Changed in xorg-server (Ubuntu):
assignee: Chase Douglas (chasedouglas) → nobody
Chase Douglas (chasedouglas) wrote :

Reverting 81fbb96c54f78a7cd96433294ee003c7ef6a772a (9d23459415b84606ee4f38bb2d19054c432c8552 on master) fixes the issue.

The change calls the new ReleaseButtonsAndKeys() function in AttachDevice(). This makes sense when you are wanting to float a device. However, activating a passive grab on a slave device also floats the device. In this case, ReleaseButtonsAndKeys() is interfering with the passive grab.

I will coordinate with upstream on how to fix this issue since reverting the change will just cause a different bug to reappear.

Changed in xorg-server (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
Changed in easystroke (Ubuntu):
status: New → Invalid
Changed in xorg-server (Ubuntu):
status: Incomplete → In Progress
importance: Undecided → Medium
Chase Douglas (chasedouglas) wrote :

Upstream has reverted the patch that causes this bug. We should do the same.

Observer (dbvweb) wrote :

Tried doing the apport-collect but launchpad wants me to create a new bug report.

@Chase, so what do we do now?

Chase Douglas (chasedouglas) wrote :

This bug should be fixed in the next version of xorg-server released to Natty. The new package has been uploaded to the Natty queue and will be reviewed shortly before it is accepted.

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.10.1-1ubuntu1

---------------
xorg-server (2:1.10.1-1ubuntu1) natty; urgency=low

  * Merge from Debian experimental (LP: #757972)
 -- Timo Aaltonen <email address hidden> Tue, 19 Apr 2011 16:12:14 +0300

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
Observer (dbvweb) wrote :

The latest update seem to have fixed it or restored the earlier code.

Observer (dbvweb) wrote :

I spoke too soon. Easystroke is working now. But it just crashed. I suspect the crash is a feature of natty and not easystroke, as practically all the apps that has anything to do with the indicator or systray has crashed at least once ... or ten times.

Also, now wicd refuses to connect to the internet. Using secondary netbook to file this. grrr.

teixeiras (teixeiras) wrote :

Hello everyone:
My problem is more hw specific ones. My notepad ( acer 1425 pt ) have hid-multitouch device, more concretely an hid-cando touchscreen monitor. On 10.10 was working just fine.
It works well on the the rest of application, but don't trigger anything on easytroke. The external mouse and pad works just fine.

I think what you're experiencing is bug #788980.

On 06/03/2011 03:50 AM, teixeiras wrote:
> Hello everyone:
> My problem is more hw specific ones. My notepad ( acer 1425 pt ) have hid-multitouch device, more concretely an hid-cando touchscreen monitor. On 10.10 was working just fine.
> It works well on the the rest of application, but don't trigger anything on easytroke. The external mouse and pad works just fine.
>

teixeiras (teixeiras) wrote :

No, the problem is different.
I reinstalled the machine today, before update easystroke was working for touchscreen, after update stop working. Same config same easystroke config.

Small Note:
  The own Touchcreen stop working after update, I have to use now a script to load cando driver passing model reference from my touchscreen.

Changed in xorg-server:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.