Please merge e2fsprogs 1.41.14-1 (main) from Debian experimental (main)

Bug #681418 reported by Lorenzo De Liso on 2010-11-25
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
e2fsprogs (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: e2fsprogs

e2fsprogs (1.41.12-2) unstable; urgency=high

   * Allow tune2fs to set uninit_bg without requiring an fsck
   * Fix test in e2fsck to correctly check for EOFBLOCKS files
   * Fix dependencies for libuuid and libblkid (Closes: #583551)

 -- Theodore Y. Ts'o <email address hidden> Thu, 03 Jun 2010 09:30:36 -0400

Related branches

Lorenzo De Liso (blackz) on 2010-11-25
Changed in e2fsprogs (Ubuntu):
importance: Undecided → Wishlist
Theodore Ts'o (tytso) wrote :

n.b. 1.41.13 will be out soon (as in by early December), and an 1.42 snapshot release of e2fsprogs (with support for 64-bit block numbers) for testing purposes before the end of the year.

The debian import freeze for Natty is December 30th, and Feature Freeze is February 24th. So we have plenty of time.

(Or were you asking for a newer maintenance release for Ubuntu 10.04; the original bug report wasn't terribly specific?)

Alessio Treglia (quadrispro) wrote :

How did you achieve this?

+ - Do now allow pkg-create-dbgsym to operate on this package.

I cannot find the above change in the debdiff. Unsubscribing sponsors for now.

Changed in e2fsprogs (Ubuntu):
assignee: nobody → Lorenzo De Liso (blackz)
status: New → Incomplete
Lorenzo De Liso (blackz) wrote :

Hello Alessio,

it's there:

diff -u e2fsprogs-1.41.12/debian/rules e2fsprogs-1.41.12/debian/rules
--- e2fsprogs-1.41.12/debian/rules
+++ e2fsprogs-1.41.12/debian/rules
@@ -9,13 +9,10 @@

[...]
+# no chance that pkg-create-dbgsym can cope with this package's manual construction of -dbg
+export NO_PKG_MANGLE=1
[...]

Changed in e2fsprogs (Ubuntu):
status: Incomplete → New
assignee: Lorenzo De Liso (blackz) → nobody
Lorenzo De Liso (blackz) wrote :

Hello Theodore,

This is a merge, please see https://wiki.ubuntu.com/UbuntuDevelopment/Merging .

Alessio Treglia (quadrispro) wrote :

Lorenzo, catched it, thanks.

And what about resize2fss's -p option? (bug #505719)
Seems we still need it, is it so? Would you mind to submit this to Debian in order to ask the maintainer what he thinks about it?

Thanks in advance.

Changed in e2fsprogs (Ubuntu):
status: New → Incomplete
Theodore Ts'o (tytso) wrote :

No one bothered to submit to me the resize2fs patch for bug #505719. It's a one word addition, and I have it now.... it wlil be in 1.41.13.

Note that some of the changes to "always build with external libblkid and libuuid" to the rules file aren't technically necessary, since the rules file will automatically do the right thing. Ironically, the main reason why I've left that machinary in the debian rules files was for people who wanted to build a new version of e2fsprogs for older versions of Ubuntu LTS. But I've never bothered complaining since it's just more work for Ubuntu maintainers, who can do whatever they want... (their freedom, their choice, their pain :-)

- Ted (the upstream maintainer)

Lorenzo De Liso (blackz) wrote :

Hello Theodore,

> No one bothered to submit to me the resize2fs patch for bug #505719. It's a one word addition, and I have it now.... it wlil be in > 1.41.13.

I was about to do that. Thank you for applying this change!

Lorenzo De Liso (blackz) wrote :

Setting back to 'New' as the bug can be reproduced in the latest version available in Debian unstable (see comment #7).

Changed in e2fsprogs (Ubuntu):
status: Incomplete → New
Daniel Holbach (dholbach) wrote :

Lorenzo, I'm not sure I understand your last comment. Does the patch in comment 1 need reiview/upload? Or are you going to update it to include the newest version in Debian?

Lorenzo De Liso (blackz) wrote :

Hello Daniel,

> Lorenzo, I'm not sure I understand your last comment. Does the patch in comment 1 need reiview/upload? Or are you going to > update it to include the newest version in Debian?

As you can read in comment #7, Theodore applied this change in the latest version he will release (he's the Debian maintainer), so this got applied in the Debian package, this means we can drop this change on the next version that will be merged. Hence, this debdiff just needs to get reviewed and uploaded (if it looks fine). Thanks.

Alessio Treglia (quadrispro) wrote :

Lorenzo,

Theodore said that the changes related to the following point:

> "always build with external libblkid and libuuid"

are no longer necessary. WDYT?

Changed in e2fsprogs (Ubuntu):
status: New → Incomplete
Lorenzo De Liso (blackz) wrote :

Hello Alessio,

> Lorenzo,
>
> Theodore said that the changes related to the following point:
>
> > "always build with external libblkid and libuuid"
>
> are no longer necessary. WDYT?

Here's a debdiff without that change applied. I tested the package personally and it's not required, I also checked the build log to make sure it builds properly (e.g if the binaries links against the correct libraries).

Changed in e2fsprogs (Ubuntu):
status: Incomplete → New
Dave Walker (davewalker) wrote :

debdiff applies cleanly to Debian package (1.41.12-2), and builds on Natty. The concern I have is that this package is traditionally maintained in Ubuntu Git (see the VCS header), this change would be out of tree.

Subscribing Keybuk for comment, as the Git tree maintainer.

Thanks.

Kees Cook (kees) wrote :

Hi! Thanks very much for putting this debdiff together. There are a few things I find strange that maybe should be fixed first:

 - export NO_PKG_MANGLE=1 is missing from the rules file
 - a TODO file is being added?
 - the changelog file doesn't mention which files are being changed for which elements of the debdiff. I would prefer to see changelog entries like this "debian/rules: Do now allow pkg-create-dbgsym to operate on this package."
 - I would remove mention of old LP bug #s so that they do not generate "fixes" headers on upload
 - I would drop the mention of the git tree, as Ubuntu packages are migrating towards being exclusively tracked in bzr.

Thanks!

Changed in e2fsprogs (Ubuntu):
status: New → Incomplete
Lorenzo De Liso (blackz) wrote :

Here's another debdiff with the issue that Kees Cook pointed out fixed.

Changed in e2fsprogs (Ubuntu):
status: Incomplete → New
Theodore Ts'o (tytso) wrote :

There are a bunch of things in the diff file, such as the TODO file, which were "added" because at one point someone at Ubuntu choose to start by grabbing an snapshot of the e2fsprogs git tree and used that as a starting point. The TODO file is in the git tree, but it is stripped out of the release tarballs because it is just notes to myself that will likely become obsolete after the release cut.

Feel free to drop the TODO file. All of the Makefile.pq files should also be dropped. Those were used for building a special Windows version of the e2fsprogs library and core utilities for PowerQuest, the makers of Partition Magic. They have no use whatsoever on any Linux build of e2fsprogs, and were included in the Ubuntu debdiff for the same reason; they were in the git tree, and are stripped as part of the release tar.gz build, and the Canonical packager just included random stuff without understanding what they did.

Theodore Ts'o (tytso) wrote :

Also, please drop README.subset from the debdiff. Same story as TODO and the Makefile.pq files.....

In general, it would be nice if whoever is assembling the debdiff file could be able to explain the reason for every line in the debdiff file. The fact that junk has been propagating for years in the debdiff is a sign that people aren't being all that careful when they put together the debdiff file for each successive e2fsprogs release in Ubuntu. :-(

Didier Roche (didrocks) wrote :

Thanks for your work there, can you address Thoedore's remark and submit a new patch please?

Thanks a lot for your hard work :)

Changed in e2fsprogs (Ubuntu):
status: New → Incomplete
Lorenzo De Liso (blackz) wrote :

The attached debdiff should fix the issues pointed out by Theodore Ts'o.

Changed in e2fsprogs (Ubuntu):
status: Incomplete → New
Stefan Bader (smb) wrote :

There is only one flaw I could see: The vcs-git line is removed in control, but not in control.in. Otherwise the latest debdiff seems to carry all the suggestions mentioned.

Stefan Bader (smb) wrote :

Hm, actually there seems to have happened one other upload to natty in between.

Theodore Ts'o (tytso) wrote :

FYI I've just released e2fsprogs 1.41.13. A debian package will be uploaded in a few days to experimental (I'm not in a rush and it won't go into unstable since Debian is currently in a deep freeze for the Squeeze release). I anticipate the .diff file from:

http://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/e2fsprogs-1.41.13.tar.gz

... to be zero.

Daniel Holbach (dholbach) wrote :

Lorenzo: would you be willing to test the e2fsprogs upload to experimental once it happens and check the diff? Until then I'll unsubscribe the sponsors.

Thanks a lot everyone for your efforts!

tags: added: patch
Theodore Ts'o (tytso) wrote :

Note that I've released e2fsprogs 1.41.14, which has fix for a big-endian FTBFS problem, and a few other late-breaking bug fixes.

There is also a e2fsprogs 1.41.14-1 which I've uploaded to Debian experimental.

Last I checked there were still some unnecessary differences between Ubuntu and Debian in the rules file, but that just means more work for Canonical, so it's no skin off my back.

Artur Rona (ari-tczew) wrote :

+1 for merge 1.41.14-1 from experimental.

summary: - Please merge e2fsprogs 1.41.12-2 (main) from debian unstable (main)
+ Please merge e2fsprogs 1.41.12-2 (main) from Debian unstable (main)
Lorenzo De Liso (blackz) wrote :

Here's a patch for the merge from the latest version in Debian experimental. I tested it and seems it works good.

summary: - Please merge e2fsprogs 1.41.12-2 (main) from Debian unstable (main)
+ Please merge e2fsprogs 1.41.14-1 (main) from Debian experimental (main)
Daniel Holbach (dholbach) wrote :

I removed the dietlibc-dev Build-Depends in debian/control.in for you.

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package e2fsprogs - 1.41.14-1ubuntu1

---------------
e2fsprogs (1.41.14-1ubuntu1) natty; urgency=low

  * Merge from debian experimental (LP: #681418), remaining changes:
    - debian/control: Do not build-depend on dietlibc-dev, which is universe.
    - debian/rules:
      + Do now allow pkg-create-dbgsym to operate on this package.
      + Build with -O2 on powerpc to avoid a suspected toolchain bug.
    - debian/e2fsprogs.preinst: Do not include /etc/e2fsck.conf and remove on
      upgrade.

e2fsprogs (1.41.14-1) experimental; urgency=low

  * New upstream release
  * Fixed a FTBFS on big-endian architectures
  * Fixed spurious warning in mke2fs
  * resize2fs now works correctly on devices exactly 16TB
  * resize2fs will no longer clear the resize_inode feature when the
    number of reserved GDT blocks reaches 0. This allows a file
    system with the flex_bg feature to be subsequently shrunk.
  * e2fsck will no longer use the extended rec_len encoding for file
    systems whose blocksize is less than 64k, to catch fs inconsistencies
    which the kernel will complain about.

e2fsprogs (1.41.13-1) unstable; urgency=low

  * New upstream release
  * E2fsck can now do journal-only replays via "e2fsck -E journal_only"
  * E2fsck now understands UUID= and LABEL= specifiers for the -j option
    (Closes: #559315)
  * E2fsck.conf now supports a new config option, which forces the
    problem not to be fixed: problems/<problem code/force_no
  * Dumpe2fs now prints friendlier offsets for flex_bg file systems
  * Mke2fs will now fail if the user uses an file system type not
    defined in mke2fs.conf (Closes: #594609)
  * Resize now prints a clarified error message explaining that on-line
    shrinking is not supported at all. (Closes: #599786)
  * Fixed a build error caused by bad static and profiled dependencies
    for the blkid library (Closes: #604629)
  * Fixed an e2fsck PROGRAMMING BUG error (Closes: #555456)
  * Fixed outdated mention of fsck in the e2fsprogs package (Closes: #588726)
  * Removed obsolete initrd script (Closes: #585041)
  * Fixed bad dependency on libblkid1 due to shlibs.local (Closes: #583551)
  * E2fsck now opens the external journal in exclusive mode to prevent
    clearing the journal of a mounted, snapshotted volume if the user
    accidentally tries to run e2fsck on the snapshot volume (Closes: #587531)
  * Fix a big in e2fsck so it correct test for whether the EOFBLOCKS_FL
    flag should be set or not.
  * Tune2fs can now set uninit_bg without requiring an fsck afterwards
  * Add support for the new ext4 default mount options added in 2.6.35
  * Add support for the ext4 error tracking superblock fields added in 2.6.36
  * Debugfs now uses a more concise format for listing extents in its
    stat command
  * Debugfs can now use direct I/O to access the file system with the -D option
  * Mke2fs will skip initializing the inode table if a device supports
    discard and the discard operation results in zero'ed blocks
  * Mke2fs's handling of logical and physical sector sizes has been
    significantly improved.
  * Debugfs will correctly show the progress bar even when UTF-8
    characters...

Read more...

Changed in e2fsprogs (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers