-p argument to resize2fs doesn't actually do anything

Bug #505719 reported by Jeffrey Baker
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
e2fsprogs (Ubuntu)
Low
Surbhi Palande

Bug Description

Binary package hint: e2fsprogs

In e2fsprogs 1.41.9-1ubuntu3 (Karmic) the -p switch to resize2fs does nothing. According to the manual, -p:

Prints out a percentage completion bars for each resize2fs operation, so that the user can
keep track of what the program is doing.

However when I used the switch I saw no such progress indication:

# resize2fs -p /dev/homedirs/homedirs_lv
resize2fs 1.41.9 (22-Aug-2009)
Filesystem at /dev/homedirs/homedirs_lv is mounted on /users; on-line resizing required
old desc_blocks = 7, new_desc_blocks = 32
Performing an on-line resize of /dev/homedirs/homedirs_lv to 131066880 (4k) blocks.
The filesystem on /dev/homedirs/homedirs_lv is now 131066880 blocks long.

The switch should either have some effect or should be removed from the documentation.

Related branches

Revision history for this message
Jeffrey Baker (jwbaker) wrote : apport-collect data

Architecture: i386
DistroRelease: Ubuntu 9.10
Ec2AMI: ami-1515f67c
Ec2AMIManifest: ubuntu-images-us/ubuntu-karmic-9.10-i386-server-20091027.1.manifest.xml
Ec2AvailabilityZone: us-east-1c
Ec2InstanceType: m1.small
Ec2Kernel: aki-5f15f636
Ec2Ramdisk: ari-0915f660
Package: e2fsprogs 1.41.9-1ubuntu3
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-302.7-ec2
Tags: ec2-images
Uname: Linux 2.6.31-302-ec2 i686
UserGroups:

Revision history for this message
Jeffrey Baker (jwbaker) wrote : Dependencies.txt
tags: added: apport-collected
Revision history for this message
Dave Walker (dogatemycomputer) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in e2fsprogs (Ubuntu):
status: New → Confirmed
Changed in e2fsprogs (Ubuntu):
importance: Undecided → Low
Surbhi Palande (csurbhi)
Changed in e2fsprogs (Ubuntu):
assignee: nobody → Surbhi Palande (csurbhi)
Revision history for this message
Surbhi Palande (csurbhi) wrote :

@Jeffrey Baker, the -p switch works as expected for an offline resize which is done completely at the user space level. On the other hand, an online resize is done by the kernel. I agree that the documentation should be updated for the same. Shall work on that. Thanks!

Surbhi Palande (csurbhi)
Changed in e2fsprogs (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Colin Watson (cjwatson) wrote :

Looks fine, and I'll merge this, but could you please also send this patch upstream?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package e2fsprogs - 1.41.12-1ubuntu2

---------------
e2fsprogs (1.41.12-1ubuntu2) maverick; urgency=low

  * The -p switch for resize2fs is meant for an offline resize operation which
    is done completely at the userspace. Changed the documentation to suggest
    an "offline" operation. (LP: #505719)
 -- Surbhi Palande <email address hidden> Wed, 18 Aug 2010 15:48:21 +0100

Changed in e2fsprogs (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers