package libcomerr2 1.43.8-2 failed to install/upgrade: libcomerr2:all 1.43.9-1 (Multi-Arch: no) is not co-installable with libcomerr2 which has multiple installed instances

Bug #1749036 reported by Brian Murray on 2018-02-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
e2fsprogs (Ubuntu)
Undecided
Unassigned

Bug Description

This happened during a partial upgrade of Bionic.

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: libcomerr2 1.43.8-2
ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
Uname: Linux 4.13.0-32-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.8-0ubuntu8
Architecture: amd64
Date: Mon Feb 12 15:51:57 2018
Dependencies:
 gcc-7-base 7.2.0-18ubuntu2
 libc6 2.26-0ubuntu2
 libgcc1 1:7.2.0-18ubuntu2
DpkgTerminalLog:
 Preparing to unpack .../comerr-dev_2.1-1.43.9-1_amd64.deb ...
 Unpacking comerr-dev:amd64 (2.1-1.43.9-1) over (2.1-1.43.8-2) ...
 dpkg: error processing archive /var/cache/apt/archives/libcomerr2_1.43.9-1_all.deb (--unpack):
  libcomerr2:all 1.43.9-1 (Multi-Arch: no) is not co-installable with libcomerr2 which has multiple installed instances
DuplicateSignature:
 package:libcomerr2:1.43.8-2
 Unpacking comerr-dev:amd64 (2.1-1.43.9-1) over (2.1-1.43.8-2) ...
 dpkg: error processing archive /var/cache/apt/archives/libcomerr2_1.43.9-1_all.deb (--unpack):
  libcomerr2:all 1.43.9-1 (Multi-Arch: no) is not co-installable with libcomerr2 which has multiple installed instances
ErrorMessage: libcomerr2:all 1.43.9-1 (Multi-Arch: no) is not co-installable with libcomerr2 which has multiple installed instances
InstallationDate: Installed on 2013-01-16 (1853 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130116)
Python3Details: /usr/bin/python3.6, Python 3.6.4, python3-minimal, 3.6.4-1
PythonDetails: /usr/bin/python2.7, Python 2.7.14+, python-minimal, 2.7.14-4
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu1
 apt 1.6~alpha7ubuntu1
SourcePackage: e2fsprogs
Title: package libcomerr2 1.43.8-2 failed to install/upgrade: libcomerr2:all 1.43.9-1 (Multi-Arch: no) is not co-installable with libcomerr2 which has multiple installed instances
UpgradeStatus: No upgrade log present (probably fresh install)

Brian Murray (brian-murray) wrote :
tags: removed: need-duplicate-check
Theodore Ts'o (tytso) wrote :

Note that libcomerr2 has been renamed to libcom-err2 to conform with Debian's packaging naming guidelines. So libcomerr2 is now a transitional package (arch=all) where previously it was a binary package.

Why this is failing on Ubuntu is a complete mystery to me. On Debian Unstable, using "apt-get update --with-new-pkgs" it Just Works For Me.....

Ken Wahl (ken.wahl) wrote :

I'm receiving the same error upgrading Debian Testing. Upon searching the web for solutions I was led to this bug report. Here is what I'm getting in Testing:

dpkg: error processing archive /var/cache/apt/archives/libcomerr2_1.43.9-1_all.deb (--unpack):
 libcomerr2:all 1.43.9-1 (Multi-Arch: no) is not co-installable with libcomerr2 which has multiple installed instances
Selecting previously unselected package libcom-err2:amd64.
dpkg: considering deconfiguration of libcomerr2:amd64, which would be broken by installation of libcom-err2:amd64 ...
dpkg: yes, will deconfigure libcomerr2:amd64 (broken by libcom-err2:amd64)
(Reading database ... 318353 files and directories currently installed.)
Preparing to unpack .../libcom-err2_1.43.9-1_amd64.deb ...
De-configuring libcomerr2:amd64 (1.43.8-2) ...
Unpacking libcom-err2:amd64 (1.43.9-1) ...
Replacing files in old package libcomerr2:amd64 (1.43.8-2) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libcomerr2_1.43.9-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

'apt --fix-broken install' returns the following:

The following additional packages will be installed:
  libcomerr2
The following packages will be upgraded:
  libcomerr2
1 upgraded, 0 newly installed, 0 to remove and 230 not upgraded.
2 not fully installed or removed.
Need to get 0 B/62.2 kB of archives.
After this operation, 18.4 kB disk space will be freed.
Do you want to continue? [Y/n]
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Reading changelogs... Done
dpkg: error processing archive /var/cache/apt/archives/libcomerr2_1.43.9-1_all.deb (--unpack):
 libcomerr2:all 1.43.9-1 (Multi-Arch: no) is not co-installable with libcomerr2 which has multiple installed instances
Errors were encountered while processing:
 /var/cache/apt/archives/libcomerr2_1.43.9-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in e2fsprogs (Ubuntu):
status: New → Confirmed
tags: added: rls-bb-incoming
Adam Conrad (adconrad) wrote :

e2fsprogs (1.43.9-1ubuntu1) bionic; urgency=medium

  * Make transitional library packages be Arch: any and Multi-Arch: same
    so that upgrades actually function correctly when two or more exist.

 -- Adam Conrad <email address hidden> Mon, 19 Feb 2018 06:05:49 -0700

Changed in e2fsprogs (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers