e2fsprogs: ext(2,3,4) manpage typo

Bug #1693915 reported by Quanah on 2017-05-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
e2fsprogs (Debian)
Fix Released
Unknown
e2fsprogs (Ubuntu)
Undecided
Unassigned

Bug Description

When running: man ext4

There is an obvious typo at the top:

NAME
       ext2 - the second extended file system
       ext2 - the third extended file system
       ext4 - the fourth extended file system

Clearly, the "third" extended filesystem should be "ext3" not "ext2"

Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I can confirm this typo is present e2fsprogs 1.42.13-1ubuntu1 on Ubuntu 16.04 (http://manpages.ubuntu.com/manpages/xenial/en/man5/ext4.5.html). However, it has been corrected to "ext3" on Ubuntu 16.10 and newer. I did some research and found a corresponding bug report in Debian, see the attached bug watch.

Since the typo is fixed in newer releases, I'm marking this as Fix Released. If you need a fix for the bug in previous versions of Ubuntu, you may look into the the SRU Procedure [1]. (Though I am not sure whether this particular issue would qualify as an SRU)

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

tags: added: bitesize manpage string-fix trusty xenial
Changed in e2fsprogs (Ubuntu):
status: New → Fix Released
Changed in e2fsprogs (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.