resize2fs crashed with SIGSEGV in ext2fs_extent_translate()

Bug #1627608 reported by Victor gonzalez on 2016-09-26
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
e2fsprogs (Ubuntu)
Medium
Unassigned

Bug Description

I was trying to install yakkety from a bootable USB with latest the image, but when trying to resize partition an error window appeared. All the information about it is here>

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1627603

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: e2fsprogs 1.43.1-1
ProcVersionSignature: Ubuntu 4.8.0-14.15-generic 4.8.0-rc7
Uname: Linux 4.8.0-14-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CasperVersion: 1.378
Date: Mon Sep 26 06:41:43 2016
ExecutablePath: /sbin/resize2fs
LiveMediaBuild: Ubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160922)
ProcCmdline: resize2fs /dev/sda5 139789789K
SegvAnalysis:
 Segfault happened at: 0x5635641f751c: cmpq $0x0,0x20(%rdi)
 PC (0x5635641f751c) ok
 source "$0x0" ok
 destination "0x20(%rdi)" (0x00000020) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: e2fsprogs
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 __libc_start_main (main=0x5635641f6080, argc=3, argv=0x7ffef0c06668, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffef0c06658) at ../csu/libc-start.c:291
 ?? ()
Title: resize2fs crashed with SIGSEGV in __libc_start_main()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

information type: Private → Public

StacktraceTop:
 ext2fs_extent_translate (extent=0x0, old_loc=15737489) at /build/e2fsprogs-2hYzvG/e2fsprogs-1.43.1/resize/extent.c:149
 extent_translate (fs=0x563564a66060, old_loc=15737489, extent=<optimized out>) at /build/e2fsprogs-2hYzvG/e2fsprogs-1.43.1/resize/resize2fs.c:1805
 migrate_ea_block (changed=0x7ffef0c06294, inode=0x563564aa5a70, ino=3937597, rfs=0x563564a7f8b0) at /build/e2fsprogs-2hYzvG/e2fsprogs-1.43.1/resize/resize2fs.c:1900
 inode_scan_and_fix (rfs=0x563564a7f8b0) at /build/e2fsprogs-2hYzvG/e2fsprogs-1.43.1/resize/resize2fs.c:2052
 resize_fs (fs=<optimized out>, new_size=<optimized out>, flags=<optimized out>, progress=<optimized out>) at /build/e2fsprogs-2hYzvG/e2fsprogs-1.43.1/resize/resize2fs.c:192

Changed in e2fsprogs (Ubuntu):
importance: Undecided → Medium
summary: - resize2fs crashed with SIGSEGV in __libc_start_main()
+ resize2fs crashed with SIGSEGV in ext2fs_extent_translate()
tags: removed: need-amd64-retrace
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1627608

tags: added: iso-testing
tags: added: rls-y-incoming
Theodore Ts'o (tytso) wrote :

Known problem, fixed in e2fsprogs 1.42.2 or 1.42.3 in commit:

commit 3d6fc974831a360aee460e54c442538445f3017c
Author: Theodore Ts'o <email address hidden>
Date: Wed Aug 10 15:49:35 2016 -0400

    resize2fs: fix crash when there is an ea block and no blocks to migrate

    This fixes a bug introduced in 1.43 by commit fb47b94fffc: "resize2fs:
    rewrite extent/dir/ea block checksums when migrating". If there is an
    extended attribute block and there are no blocks that need to migrate,
    we will crash.

    The bug was caused by a botched De Morgan's transformation.

    Signed-off-by: Theodore Ts'o <email address hidden>

Note that e2fsprogs 1.43.3-1 is in Debian unstable, and the only reason why it's blocked from entering testing for the last three weeks is because of the glibc 2.24 transition.

Changed in e2fsprogs (Ubuntu):
status: New → Triaged

This bug was fixed in the package e2fsprogs - 1.43.3-1

---------------
e2fsprogs (1.43.3-1) unstable; urgency=medium

  * Fix e2fsck's handling of timestamps on 32-bit system (Closes: #836559)
  * E2fsck will sanity check and repair the extra isize fields in inodes
    and the superblock.
  * Fix sparc64 crashes when dereferencing unaligned integers in journal
    blocks when metdata checksums are enabled.

 -- Theodore Y. Ts'o <email address hidden> Sun, 04 Sep 2016 20:41:21 -0400

e2fsprogs (1.43.2-2) unstable; urgency=medium

  * Fix build reproducibility problems
  * Don't hide the linker flags for e2fsck.static

 -- Theodore Y. Ts'o <email address hidden> Thu, 01 Sep 2016 23:30:55 -0400

e2fsprogs (1.43.2-1) unstable; urgency=medium

  * Change the default journal size to be larger for file systems larger
    than 128 GB to improve performance on metadata-heavy workloads
  * Clarify tune2fs's message when the user needs to run e2fsck
    (Closes: #828022)
  * Fix an alignment bug in e2fsck which caused sparc64 architectures to
    crash when replaying the journal on file systems with a 64-bit block
    number
  * Fix a typo in debugfs when printing out the dtime field on file
    systems with an extended timestamp
  * Fix the logic in e2fsck which decides when to repair legacy negative
    timestamp encodings.
  * Add a command to debugfs to copy the inode structure from one inode
    to another
  * Fix resize2fs so it will not crash if there is an extended
    attribute block but it doesn't need to migate any blocks during
    an off-line resize
  * Fix a crash when mke2fs or debugfs tries to copy in a directory
    hierarchy containing an empty directory
  * Fix a bug in e2fsck caused by a power failure during e2fsck's journal
    replay could leave the file system in a state where if the file
    system is mounted without doing a full e2fsck scan, the file system
    could get corrupted
  * Fix big endian bugs in the e2undo program
  * Fix debugfs's logdump so command so it can correctly handle journals
    which are larger than 2GB
  * Add new translations: Hugarian and Serbian
  * Update the Catalan, Chinese, Danish, Dutch, French, German, Polish,
    Swedish, Ukrainian translations

 -- Theodore Y. Ts'o <email address hidden> Thu, 01 Sep 2016 00:55:13 -0400

Changed in e2fsprogs (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers