package dynare-matlab 4.4.3-2ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127

Bug #1580761 reported by daniele on 2016-05-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dynare (Ubuntu)
Undecided
Unassigned

Bug Description

I don't know what happened, I was installing dynare with synaptic and this bag just popped up.

If you have any suggestion it would be grate

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: dynare-matlab 4.4.3-2ubuntu4
ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
Date: Wed May 11 21:57:08 2016
ErrorMessage: subprocess installed post-installation script returned error exit status 127
InstallationDate: Installed on 2015-10-23 (201 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1
 apt 1.2.10ubuntu1
SourcePackage: dynare
Title: package dynare-matlab 4.4.3-2ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127
UpgradeStatus: Upgraded to xenial on 2016-05-04 (7 days ago)

daniele (barrodaniele8) wrote :
daniele (barrodaniele8) wrote :

 the code below is part of the error message

 This may take some time... done.
Setting up texlive-extra-utils (2015.20160320-1) ...
Setting up texlive-latex-recommended (2015.20160320-1) ...
Setting up texlive-pictures (2015.20160320-1) ...
Processing triggers for tex-common (6.04) ...
Running updmap-sys. This may take some time... done.
Running mktexlsr /var/lib/texmf ... done.
Setting up texlive-pstricks (2015.20160320-1) ...
Setting up prosper (1.00.4+cvs.2007.05.01-4) ...
Regenerating '/var/lib/texmf/fmtutil.cnf-DEBIAN'... done.
Regenerating '/var/lib/texmf/fmtutil.cnf-TEXLIVEDIST'... done.
update-fmtutil has updated the following file(s):
 /var/lib/texmf/fmtutil.cnf-DEBIAN
 /var/lib/texmf/fmtutil.cnf-TEXLIVEDIST
If you want to activate the changes in the above file(s),
you should run fmtutil-sys or fmtutil.
Running mktexlsr. This may take some time... done.
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Errors were encountered while processing:
 dynare-matlab
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up dynare-matlab (4.4.3-2ubuntu4) ...
/var/lib/dpkg/info/dynare-matlab.postinst: 6: /var/lib/dpkg/info/dynare-matlab.postinst: debian-matlab-mexhelper: not found
dpkg: error processing package dynare-matlab (--configure):

daniele (barrodaniele8) on 2016-12-13
Changed in dynare (Ubuntu):
status: New → Fix Released
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dynare (Ubuntu):
status: New → Confirmed
Lucho Nacho (livalenz) wrote :

I got around this by building Dynare (4.5) from source, using these instructions: https://github.com/DynareTeam/dynare/blob/master/README.md

Lucho Nacho (livalenz) wrote :

(maybe this is solved in 4.5, to be released soon. Check here: https://github.com/DynareTeam/dynare/issues/1455)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.