Firewire broken

Bug #779680 reported by Daniel Monedero on 2011-05-09
98
This bug affects 21 people
Affects Status Importance Assigned to Milestone
dvgrab (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: dvgrab

Looks like the old firewire stack wasn't included in Natty.
As a result, dvgrab, kino, and dv4l don't work anymore because the module raw1394 is no longer included:
$sudo modprobe raw1394
FATAL: Module raw1394 not found.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: dvgrab 3.5-1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Sun May 8 17:23:51 2011
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Release i386 (20110427)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: dvgrab
UpgradeStatus: No upgrade log present (probably fresh install)

Regarding kino and dvgrab, it seems like they are looking for the device at the wrong place. So "sudo ln /dev/fw0 /dev/raw1394" solves the problem for them.
But dv4l still isn't working because the vloopback module cannot be compiled:

sudo apt-get install vloopback-source
cd /usr/src/
sudo bunzip2 vloopback.tar.bz2
sudo tar xvf vloopback.tar
cd modules/vloopback/
sudo make
Building vloopback driver...
make[1]: Entering directory `/usr/src/linux-headers-2.6.38-8-generic'
  CC [M] /usr/src/modules/vloopback/vloopback.o
/usr/src/modules/vloopback/vloopback.c:186:2: error: #error "need CONFIG_VIDEO_V4L1_COMPAT"
/usr/src/modules/vloopback/vloopback.c:210:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[2]: *** [/usr/src/modules/vloopback/vloopback.o] Error 1
make[1]: *** [_module_/usr/src/modules/vloopback] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
make: *** [vloopback] Error 2

Bastien Miras (bmiras) wrote :

Same problem!
The vloopback module doesn't compile:
vloopback-source 1.3-2
with
linux-headers-2.6.38-8-generic 2.6.38-8.42
(ubuntu natty)

I still haven't found a working solution, but there seems to be an alternative.

sudo aptitude install v4l2loopback-source module-assistant
sudo module-assistant auto-install v4l2loopback-source
sudo modprobe -r ohci1394
sudo modprobe firewire-ohci
sudo modprobe v4l2loopback
sudo gst-launch videotestsrc ! v4l2sink device=/dev/video0

That creates a virtual v4l2 video device that can be watched using
sudo xawtv -c /dev/video0

Theoretically, we could do the same with a camcorder using
sudo gst-launch dv1394src ! dvdemux ! dvdec ! v4l2sink device=/dev/video0

But that is missing something...

Matt Joyce (matt-nycresistor) wrote :

Confirming this issue still exists and there is no supported work around at the moment.

Changed in dvgrab (Ubuntu):
status: New → Confirmed
René Fritz (rhne) wrote :

I have the same problem. It seems it's a kernel problem because (as I understand) dvgrab should work with the new firewire stack too. But that new stack seems to be broken at least for some people. You can find several forums post in the net about it.

dmesg shows this:

[ 430.890270] firewire_ohci: Added fw-ohci device 0000:03:0e.0, OHCI v1.10, 4 IR + 8 IT contexts, quirks 0x2
[ 431.390397] firewire_core: created device fw0: GUID 00df399600001d7d, S400
[ 1055.715686] firewire_core: phy config: card 0, new root=ffc1, gap_count=5
[ 1055.715928] firewire_core: skipped bus generations, destroying all nodes
[ 1056.210074] firewire_core: giving up on config rom for node id ffc0
[ 1056.210137] firewire_core: rediscovered device fw0

That means that /dev/fw1 is not created when I plug in my camera. Therefore dvgrab can't find it.

I tried oneiric kernel 3.0.0 and Ihave the same problem (with natty)

john (no2498) wrote :

see if doing this helps
in a terminal

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so dvgrab

Thank you, but it didn't work, the command "LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so dvgrab" returns:
Found AV/C device with GUID 0x008088030730d524
Waiting for DV...

And nothing happens, when killing the process it outputs:
0.00 MiB 0 frames
Capture Stopped
Error: no DV

dmesg upon executing the process results in:
[113438.496050] firewire_core: giving up on config rom for node id ffc0
[113438.896121] firewire_core: rediscovered device fw0
[113438.956356] firewire_core: created device fw1: GUID 008088030730d524, S100

jlms (jjllmmss) wrote :

There clearly is some kind of permissions problem.

I ran as root and I can capture video (after linking /dev/raw1394 to /dev/fw0 )

DrKay (dr-jameskay) wrote :

I'm not clear if this is the same bug that I am experiencing, but I am having a similar problem that just began last weekend after I ran an Ubuntu update on Ubuntu 12.04 64-bit. Previously, I was able to capture from my Canon HDV Vixia HV30, than one day, the message in the command window said:

Waiting for HDV...

but never was able to capture. I've tried runing the dvgrab command under sudo without success.

Florian M. (flomar) wrote :

I think this is still an issue in Trusty!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers