burning fails to reload tray

Bug #615382 reported by ilf
This bug affects 9 people
Affects Status Importance Assigned to Milestone
dvd+rw-tools (Ubuntu)

Bug Description

Binary package hint: dvd+rw-tools

On an up-to-date Lucid, genisoimage 9:1.1.10-1ubuntu1 with dvd+rw-tools 7.1-6 burns DVD-Rs fine, but exits with 1, because it cannot reload the tray:

growisofs -quiet -dvd-compat -Z /dev/cdrw -dvd-video video/
Executing 'genisoimage -quiet -dvd-video video/ | builtin_dd of=/dev/cdrw obs=32k seek=0'
/dev/cdrw: "Current Write Speed" is 20.5x1352KBps.
builtin_dd: 2110912*2KB out @ average 13.0x1352KBps
/dev/cdrw: flushing cache
/dev/cdrw: updating RMA
/dev/cdrw: closing disc
:-( unable to reload tray: No such file or directory

This hasn't always been this way.
What causes this? How to fix it?

Revision history for this message
dazza5000 (darran-kelinske) wrote :

Dear ilf,

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).


Revision history for this message
ilf (ilf) wrote :

I gave you the command I executed:

$ growisofs -quiet -dvd-compat -Z /dev/cdrw -dvd-video video/

The output should have been an exit code of 0.
It was an exit code of 1 with the above mentioned error.

What more do you need?

Revision history for this message
George Poulson (george-poulson) wrote :

I'm setting up mythtv on mythbuntu and have just come across exactly the same error.

If I can provide more information to help to track down and fix this please let me know.

Command was:

growisofs -dvd-compat -Z /dev/dvd -dvd-video -V "Amish Worlds Squarest Teenagers " /var/lib/mytharchive/temp/work/dvd
Running growisofs to burn DVD

Result was:

 99.49% done, estimate finish Wed Aug 18 18:40:39 2010
Total translation table size: 0
Total rockridge attributes bytes: 0
Total directory bytes: 4248
Path table size(bytes): 42
Max brk space used 16000
864461 extents written (1688 MB)
/dev/dvd: flushing cache
/dev/dvd: closing track
/dev/dvd: closing disc
:-( unable to reload tray: No such file or directory
ERROR: Failed while running growisofs.
Result 1, Command was: growisofs -dvd-compat -Z /dev/dvd -dvd-video -V "Amish Worlds Squarest Teenagers " /var/lib/mytharchive/temp/work/dvd
Please check the troubleshooting section of the README for ways to fix this error


ilf (ilf)
Changed in dvd+rw-tools (Ubuntu):
status: New → Confirmed
Revision history for this message
ilf (ilf) wrote :

Euh, yeah. Now it works again. I have no idea, what changed.
The program versions are still the same and I didn't touch their config.

Revision history for this message
ilf (ilf) wrote :

And bad again. Didn't reboot, didn't update, didn't change settings.
This is driving me nuts.

Revision history for this message
ilf (ilf) wrote :

This is probably related:

Sometimes, when ejecting the tray of my CD/DVD-R drive, it opens a little, but immediately closes again. WTF.

Revision history for this message
Bruno Diaz (brunodiaz-cpan) wrote :

Problem located in line 2911 of growisofs.c, code around:

    if (*argv[0] == '-')
    { int fd;
      struct stat fdst;
      unsigned int cap2k=0;

 chdir ("/");
 if (argc < 3) exit (EINVAL);
 fd=atoi (argv[1]);
 if (!strcmp(argv[0],"-umount"))
 { if (fumount (fd)) exit (errno);
     exit (0);
 else if ( (!strcmp(argv[0],"-reload") && (no_reload=0,1)) ||
    (!strcmp(argv[0],"-eject") && (no_reload=-1,1)) )
 { if (fstat (fd,&fdst) < 0)
  perror (":-( unable to fstat"), exit (1);

     if (argc > 3) cap2k = (unsigned int)strtoul (argv[3],NULL,0);

     close (fd);

     if (media_reload (argv[2],&fdst,cap2k))
  perror (":-( unable to reload tray"), exit (1);
     exit (0);
¿Any ideas for a patch?
This is nasty, all my backups are broken until this bug is solved...

Revision history for this message
Rashkae (rashkae) wrote :

As a work around to this problem, invoke growisofs with the notray option.


growisofs -use-the-force-luke=notray -Z /dev/dvd=myiso.iso

Someone might want to patch growisofs so this is default, as the old re-load media behavior does not seem to be needed with current kernels or udev, or whatever. Something is pro-actively resetting the DVD drive as soon as the burn is complete.

Revision history for this message
Bruno Diaz (brunodiaz-cpan) wrote :

Confirmed Remi, works like a charm, thanks a lot. I agree with you, the standard behavior should be not breaking backwards compatibility.
I guess lots of scripts are using growisofs exit code just to know if it has successfully burned media, I don't understand the point on exiting with an error if everything worked fine...

Revision history for this message
josephbus1 (josephbus1) wrote :

Confirmed for me too Remi (this is 2012! hope you're still around)...
BUT I'm unable to boot the LinuxMint 13 DVD 32-bit iso...Md5Sum checked OK...Bios Boot Sequence priority is OK (CD/DVD reader before HDs)...The bootup selects the CD/DVD first, but does not boot from the DVD...Appreciate any ideas...JosephBus1

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.