DVD burning is extremely slow

Bug #52666 reported by Rengarajan on 2006-07-11
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
dvd+rw-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.15

I have a Plextor PX-750UF USB/IEEE 1394 drive. It can burn DVD+Rs at 16x speed. When I tried to burn a 16x RITEK DVD it took about 45 minutes (the size of the ISO is about 4 GB). The same ISO burns under 6 minutes on Microsoft Windows with Nero 6.

I tried both GnomeBaker and nautilus-cd-burner. The same behavior is exhibited by both USB and IEEE 1394. Also I noticed that after the burning started my system is left with only 49 MB of free memory (reported by top command) out of the 2 GB my system has. I don't know if this has anything to with it but wanted to report it anyway.

I am running Ubuntu Dapper 6.06 LTS on a Dell D610 2.1GHz processor 2G RAM and 80GB harddisk.

Let me know if you need further information.

Thanks,
Rajan

Are you sure that the DVD media you are burning to supports 16x?

Rengarajan (rengarajan-iyengar) wrote :

Yes it does. As you can see from my bug description that I can burn the same ISO in the same media within 6 minutes in Windows (which is the expected time for a 16x DVD+R).

Rengarajan (rengarajan-iyengar) wrote :

Forgot to mention that CD-ROM burning works fine. (it burns at 40x which is the maximum speed Plextor PX-750UF can burn at). This makes me think that this could be a bug in growisofs (dvd+rw-tools).

Martey Dodoo (martey) wrote :

Changed package. See #52917.

Hassnain (hassnain-chagani) wrote :

I can also confirm this. I have the same problem with a Plextor PX-760A. If anyone requires more information, please let me know.

Changed in dvd+rw-tools:
status: Unconfirmed → Confirmed
The GuiGuy (linux-finalfiler) wrote :

In support of the original poster I want to confirm the same problem with a range of brandname DVD burners (Liteon, Pioneer, Samsung etc). After trying every tweak I could identify, typically I cannot burn much faster than 2X on 16X hardware.

Given the impact of multimedia this issue ought to be given a high priority.

Hassnain (hassnain-chagani) wrote :

My problem have been resolved!! All I had to do was flash the drive with the firmware provided by a site (details below) and presto, I can burn at respectable speeds again (K3b/dvd+rw tools/growisofs/nero, etc.). (Plextor 755/760 users don't forget to clear your AutoStrategy database before upgrading the firmware!)

Quote from the site:
"It is necessary to use a modified firmware to get full access to your PX-760A since Plextor does not allow free software to use all capabilities of YOUR drive. The modified firmware was an original Plextor firmware, where the q-check commands are available now."

Download the firmware, flasher and QPxTool from:
http://qpxtool.siteboard.de/

On a side note, I have noticed that whenever there is network activity, the burning slows down... I read somewhere that it might be linked to my network card sharing the same IRQ as the burner. I'll have to dig that article up and fix that.

As for owners of other writers, check if your firmware allows linux burning software to use the q-check commands... And I recommend that EVERYONE download the QPXTool its great for running tests and changing various options on your burner, etc. all in linux. It also supports burners other than Plextor.

Hassnain

Hassnain (hassnain-chagani) wrote :

The QPxTool can be found on this site:
http://qpxtool.sourceforge.net/

Hassnain

David Agudo (dagudoj) wrote :

I have the same problem with my DVD burner (model LG GSA-4163B), that burns at 16x with WIndows XP.

With Ubuntu Feisty 7.04, having tuned properly the drives with hdparm, the speed never goes further than 6x. I burn DVDs with Gnomebaker and Nautilus.

After some investigation, I rebuilt growiso increasing the buffer size to 128 MB, modifing growiso.c:

#define DEFAULT_BUF_SIZE_MB 128

After that, the burning speed has doubled (it is around 12x now).

I think growiso should have a config file in /etc to allow the user tunning the buffer size, since Gnomebake nor Nautilus allows to do so.

thgreasi (thgreasi) wrote :

Can confirm slow burning speeds (since ubuntu 8.04 to 9.10), both on my old pc:
Pentium 4 2gb ram with an IDE plextor drive
and my new:
i7 4gb ram with sata drive SONY OPTIARC AD-5240S.
Both have SWAP disabled.
In more detail, last night tried to burn an iso to a DL-DVD at x8 using nerolinux.
The read buffer was all the time full, but the dvd recorder`s buffer dropped all the time (to 4%).
So it seems it is not a low memory or slow file-system problem
Have also tried brasero and k3b in the past, getting the same results.

Using windows, I have been able to write dvd`s at x24 even on the Pentium 4 machine.

hdparm -i /dev/dvd

/dev/dvd:
 HDIO_DRIVE_CMD(identify) failed: Bad address

 Model=Optiarc, FwRev=1.02, SerialNo=
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes: pio0 pio1 pio2 pio3 pio4
 DMA modes: mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
 AdvancedPM=no
 Drive conforms to: Unspecified: ATA/ATAPI-3,4,5,6,7

 * signifies the current active mode

I just want to summarize, which burners are still affected? Please tell me, thank you!

Changed in dvd+rw-tools (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for dvd+rw-tools (Ubuntu) because there has been no activity for 60 days.]

Changed in dvd+rw-tools (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers