growisofs unable to burn dual layer DVD-R

Bug #311297 reported by Juan-Carlos Amengual on 2008-12-25
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
dvd+rw-tools (Debian)
New
Unknown
dvd+rw-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Using kubuntu hardy heron (LTS) up to date.

I have tried to burn a Verbatim 4x DVD-R DL in my LG GSA-H10N dvd writer with k3b... and no way! The problem is related to growisofs. I have no problem burning CD-R, CR-RW and DVD-R (the only media I used). Of course, the writer supports dual layer DVD-R and firmware is updated to the last version. You can see the output from k3b in the attached file. I have also tried from the shell:

jcamen@vicma:~$ growisofs -dvd-compat -speed=2 -Z /dev/dvd1=Almacen/ssbb.iso
Executing 'builtin_dd if=Almacen/ssbb.iso of=/dev/dvd1 obs=32k seek=0'
:-[ READ DVD STRUCTURE #10h failed with SK=8h/ASC=ABh/ACQ=80h]: Input/output error

It seems that growisofs don't like DVD-R DL media. I have made tons of google searches and it looks like there is a serious problem with growisofs and DVD-R DL. See for instance the thread at http://bugs.kde.org/show_bug.cgi?id=138641 . Words from Sebastian Trueg, developer of the wonderful k3b:

"I am closing this as invalid then because it is not a k3b bug and I will introduce cdrecord DVD writing support post-1.0 which will hopefully fix this problem. "

Any ideas to fix this? Even Windows XP is capable of burning DVD-R DL with this writer! :-)

Juan-Carlos Amengual (jcamen) wrote :
Juan-Carlos Amengual (jcamen) wrote :

More info: I could succesfully burn a DVD+R dual layer of the same brand (Verbatim) from a 6,1 GB iso image, which makes me think that the bug is only related to DVD-R DL. I attach the k3b log file.

altima (timashkov) wrote :

There's the same problem in ubuntu 8.10 (gnome).

the DVD-R DL is recognized by the system as a blank disk, but when I am trying to burn data onto DVD-R DL, brasero does not see it and has no options except recording an image. and when I am trying to burn the data onto the disc using the standard "Create CD/DVD" it requires a DVD+R DL.

DaveAbrahams (boostpro) wrote :

Ditto. Intrepid 8.10; brasero only offers to write an .iso

Jorge Juan (jjchico) wrote :

Hi!

@Juan-Carlos: did you got it working? I mean DL recording and ssbb.iso in particular.

Thanks.

2010/2/6 Jorge Juan <email address hidden>

> Hi!
>
> @Juan-Carlos: did you got it working? I mean DL recording and ssbb.iso
> in particular.
>
> Thanks.
>
> --
> growisofs unable to burn dual layer DVD-R
> https://bugs.launchpad.net/bugs/311297
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Yes, I got! I burnt it with IMGBURN for Windows (it's free). In order for
Wii to read the DVD it is necessary to fix the layer break point.

Layer Break: 2084960
Burning speed: 2x (minimum)
DVD: Verbatim DVD+R DL

Hope it helps!

Regards,

Zhang Weiwu (zhangweiwu) wrote :

A bit of information to save your time googling, but check timestampe of this comment to decide if you should google again.

a. this problem seems to be the same as #439281. Please QA people take a look and close one of them in case of dups.

b. this post " Layer break for DVD+R DL with growisofs / dvd+rw-tools" seems to suggest to me that the problem is related to incorrect layer-break position, but the article did not offer ways to find out what is the right value for layer-break point.

 http://stephane.emisfr.info/en/2009/09/11/layer-break-for-dvdr-dl-with-growisofs-dvdrw-tools/

c. the incompatibility between growisofs and DVD-R DL is reported in multiple bug trackers, but strangely, not in Debian bug tracker, it is strange, because, growisofs is now (IMHO) a debian project. Interestingly the problem seems to be reported in 2007 to Debian cdwrite mailing list: http://lists.debian.org/cdwrite/2007/03/msg00022.html without getting any attention.

d. K3B bug report about this issue mentioned this problem might will be gone when K3B switch to cdrecord. It is not clear to me if K3B is to swicth from growisofs to cdrecord or from the GPL "wodim" to non-GPL "cdrecord".

e. the explicite mention of 'growisofs compatibility with DVD-R DL' seems to hint this issue doesn't exist with wodim/cdrecord. In my test case, the DVD-R DL which could not start burning due to the very problem of this issue, can be burnt, but with fixate error, with wodim. The following snip of wodim output showed the error message. However, the disco burnt with this very error message can be read successfully.

Track 01: Total bytes read/written: 7991693312/7991693312 (3902194 sectors).
Writing time: 2896.302s
Average write speed 2.0x.
Min drive buffer fill was 91%
Fixating...
Errno: 5 (Input/output error), flush cache scsi sendcmd: no error
CDB: 35 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 72 0B 00 00 00 00 00 0E 09 0C 00 00 00 00 00 00
Sense Key: 0x0 No Additional Sense, Segment 11
Sense Code: 0x00 Qual 0x00 (no additional sense information) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 131.203s timeout 120s
Trouble flushing the cache
wodim: Cannot fixate disk.
Fixating time: 131.209s
wodim: fifo had 125878 puts and 125878 gets.
wodim: fifo was 0 times empty and 87500 times full, min fill was 90%.

Changed in dvd+rw-tools (Debian):
status: Unknown → New
gray (info-graydesigns) wrote :
Download full text (13.4 KiB)

Hi

I am running Debian Squeeze i386, fully updated as of 11 am this morning. In the last few days there has ben a k3b update, since which I have not been able to burn data dvds correctly - I have tried various suggestions located on the net, mostly involving checking permissions, adding myself to the burning group, cdrom group etc, none of which have been of any use.

ISO dvds seem to work here and there, but all data dvds (using verbatim dvd-r dvds) fail with the "Unable to fixate the disk - The disk might still be readable" error. I have done 7 dvds in a row, all with the same result.

Debian Squeeze is installed on a latop and the dvd-burner is an internal. The system was bought around 18 months ago with Ubuntu 8.04 installed from a South African company called Sahara.

lspci:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
01:00.0 Network controller: Intel Corporation WiFi Link 5100
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

Please see below for debug info from k3b:

Devices
-----------------------
Optiarc DVD RW AD-7580S FA01 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-R...

Zhang Weiwu (zhangweiwu) wrote :
Download full text (5.9 KiB)

Dear Gray

Did you post the following message to the bug tracker and sent me a
copy, or did you only post to me? I ask this because there are little I
can help on technical issues, you will have more luck on forums or bug
trackers. I am always confused about burning stuff and my only way to
help the community is to complain to them:)

please do try to post this message on debian cdwriter mailing list.

http://lists.debian.org/cdwrite/

As that is the single most helpful mailing list on DVD/CD burning issue
there. Someone there answers question in surprising accuracy, once you
do you know what I mean:)

Best.
Zhang Weiwu

On 01/12/2011 05:33 PM, gray wrote:
> Hi
>
> I am running Debian Squeeze i386, fully updated as of 11 am this
> morning. In the last few days there has ben a k3b update, since which I
> have not been able to burn data dvds correctly - I have tried various
> suggestions located on the net, mostly involving checking permissions,
> adding myself to the burning group, cdrom group etc, none of which have
> been of any use.
>
> ISO dvds seem to work here and there, but all data dvds (using verbatim
> dvd-r dvds) fail with the "Unable to fixate the disk - The disk might
> still be readable" error. I have done 7 dvds in a row, all with the same
> result.
>
> Debian Squeeze is installed on a latop and the dvd-burner is an
> internal. The system was bought around 18 months ago with Ubuntu 8.04
> installed from a South African company called Sahara.
>
> lspci:
>
> 00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
> 00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
> 00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
> 00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
> 00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
> 00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
> 00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
> 00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
> 00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
> 00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
> 00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
> 00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
> 00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
> 00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
> 00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
> 00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
> 00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dvd+rw-tools (Ubuntu):
status: New → Confirmed
Gordon Fitch (gcf) wrote :

I have experienced this problem with Ubuntu 14.04. Until a few months ago the problem did not occur, but then I started to observe inevitable failures when the target was a DL DVD-R. I have a machine still running 12.04 which does not exhibit the problem; it has no trouble writing the DVDs. I conclude the change made to 14.04 is the current problem.
The error messages I get are similar to those already posted here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.