DVDRAM GSA-T50L will not write DVD's or CD's

Bug #307477 reported by jdawgaz on 2008-12-12
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
dvd+rw-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: dvd+rw-tools

I am using ubuntu Intrepid.

uname -a :
Linux frodo 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux

/proc/version_signature:
Ubuntu 2.6.27-9.19-generic

I have the following device:

[ 4.709544] ata2.00: ATAPI: HL-DT-ST DVDRAM GSA-T50L, SR04, max UDMA/133, ATAPI AN
[ 5.071328] scsi 1:0:0:0: CD-ROM HL-DT-ST DVDRAM GSA-T50L SR04 PQ: 0 ANSI: 5
[ 5.188423] sr0: scsi3-mmc drive: 62x/62x writer dvd-ram cd/rw xa/form2 cdda tray

It will not write either a DVD or a CD.

Using k3b as the writer, the Drive fails with an I/O error, and the eject command will not eject the device.

here is the log output from k3b.

System
-----------------------
K3b Version: 1.0.5

KDE Version: 3.5.10
QT Version: 3.3.8b
Kernel: 2.6.27-7-generic
Devices
-----------------------
HL-DT-ST DVDRAM GSA-T50L SR04 (/dev/scd0, ) [CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL] [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump]

Burned media
-----------------------
DVD-R Sequential

K3bIsoImager
-----------------------
mkisofs print size result: 237 (485376 bytes)
Pipe throughput: 485376 bytes read, 485376 bytes written.

Used versions
-----------------------
mkisofs: 1.1.8
growisofs: 7.1

growisofs
-----------------------
Executing 'builtin_dd if=/dev/fd/0 of=/dev/scd0 obs=32k seek=0'
/dev/scd0: "Current Write Speed" is 8.2x1352KBps.
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
          0/485376 ( 0.0%) @0x, remaining ??:?? RBU 1.5% UBU 0.0%
:-[ WRITE@LBA=0h failed with SK=0h/ASC=00h/ACQ=03h]: Input/output error
:-( write failed: Input/output error

growisofs command:
-----------------------
/usr/bin/growisofs -Z /dev/scd0=/dev/fd/0 -use-the-force-luke=notray -use-the-force-luke=tty -use-the-force-luke=tracksize:237 -speed=8 -use-the-force-luke=bufsize:32m

mkisofs
-----------------------
237
I: -input-charset not specified, using utf-8 (detected in locale settings)
Total translation table size: 0
Total rockridge attributes bytes: 703
Total directory bytes: 1090
Path table size(bytes): 10
Max brk space used 0
237 extents written (0 MB)

mkisofs calculate size command:
-----------------------
/usr/bin/genisoimage -gui -graft-points -print-size -quiet -volid cox -volset -appid K3B THE CD KREATOR (C) 1998-2006 SEBASTIAN TRUEG AND THE K3B TEAM -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-jerry/k3bn2DeVa.tmp -rational-rock -hide-list /tmp/kde-jerry/k3bexHfaa.tmp -joliet -joliet-long -hide-joliet-list /tmp/kde-jerry/k3bKWW1ic.tmp -no-cache-inodes -full-iso9660-filenames -iso-level 2 -path-list /tmp/kde-jerry/k3bUlZCPa.tmp

mkisofs command:
-----------------------
/usr/bin/genisoimage -gui -graft-points -volid cox -volset -appid K3B THE CD KREATOR (C) 1998-2006 SEBASTIAN TRUEG AND THE K3B TEAM -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-jerry/k3bIbdxic.tmp -rational-rock -hide-list /tmp/kde-jerry/k3bM2DdZb.tmp -joliet -joliet-long -hide-joliet-list /tmp/kde-jerry/k3bzOHNBa.tmp -no-cache-inodes -full-iso9660-filenames -iso-level 2 -path-list /tmp/kde-jerry/k3bvof1Gb.tmp

jdawgaz (jdawgaz) wrote :

ok, this may NOT be a problem with just writing.
I put a cd in expecting to play it.

RythmBox came up, and said there were 8 tracks on the CD.
BUT when I tried to play one of them, it made lots of noise for a little while and then it just hung.
When I did a ls of /media/cdrom/ it showed nothing at all.

So I think this is more a driver problem than anything else.
I know that the hardware works, because:

1) I was able to install kubuntu from a CD
2) I fired up Winblows and it works just fine.

So where do we go from here?

jdawgaz (jdawgaz) wrote :

Do you want anything else from me, to get this off the dime?

jdawgaz (jdawgaz) wrote :

I put a CD in, and I was able to read the directory, and see one of the files for a minute,

Here is what happened.
1. put a cd in the drive
2. hear the cd spin up.
3. cdrom appears on the gnome desktop
4. click on icon
5. see directory -- woohoo
6. navigate to dir, and click on file
7. drive speeds up, will NOT stop
8. can't see contents
9. can't stop drive from the speed up.
10. try to 'eject', and will not
11. dmesg > file (which I have attached)
12. because eject won't work, and I fear that my drive whirling at a very fast pace, will do some damage, I hurredly shutdown the laptop.

attached is the dmesg I took before laptop was shutdown.

JUST WHAT ELSE DO I HAVE TO DO TO GET YOU TO NOTICE THIS?????

Bump. Same DVD model, same thing.

caibbor (caibbor) wrote :

I've got the same problem, same model. this is either a driver problem or a defect of the cd drive. I don't think I've had any problems like this in windows, so I'm guessing it's a driver thing. which means this is a KERNEL issue.

I also occasionally get repetitive errors in dmesg about a USB ...current ..something. I'll post that when I see it again.

are you guys by chance using an ASUS laptop? particularly this one: http://www.bestbuy.com/site/olspage.jsp?skuId=9050279&st=Asus+G50Vt+Laptop&lp=1&type=product&cp=1&id=1218012519873

jdawgaz (jdawgaz) wrote :

almost. asus laptop with with core 2 duo t5800

Serven (ffffqwe) wrote :

Happens here as well, Arch Linux though, on a G50V (not Vt), same drive model.

jdawgaz (jdawgaz) wrote :

is there some other group we can assign this to?
this has had "NEW" status since Dec 12, 2008.
that was 5 months ago.
hardly "NEW" wouldn't you think?

Serven (ffffqwe) wrote :

Found a few things, not sure it it's helpful or not.

First, hal fails after the drive locks spinning (won't stop or start correctly).
Second, seems to lock at POST.
Third, tried Archlinux's CDs (the two last versions), locks after a little while using them too.

caibbor (caibbor) wrote :

somewhat of an update,
I've determined that my "USB over-current charge" thing has nothing to do with this cd drive issue.

caibbor (caibbor) wrote :

Do any of you guys have this problem in windows? I'd like to make sure this isn't just hardware failure.

Serven (ffffqwe) wrote :

The drive works fine on Windows Vista Ultimate x64 here, both burning, reading, and rebooting with some media inside.
On Arch it seemed to work fine on a little test I did a little while ago with polling disabled. Only tested reading though (both of CDs and DVDs). And it still doesn't work with polling enabled.

jdawgaz (jdawgaz) wrote :

works fine in vista intel x64 core duo 2

I finally gave up on this though, I went to fry's electronics and bought a usb dvd drive which works fine for both myself (ubuntu dual boot) and my wife who has an old mac powerbook running os x.

I hope this gets fixed though for others who might unwittingly be stuck with this particular drive.

caibbor (caibbor) wrote :

I had a cd burn fail in Windows and the drive locked up. this only happened once, so I'm not sure it's the same deal but its probably just a terrible drive.

WIGGMPk (wiggmpk) wrote :

I am having the same issue in Jaunty (2.6.28-11 & 2.6.28-13).

Put a blank CD/DVD into the drive, it automatically gets mounted.
Try to burn an image with any program (Brasero, growisofs, k3b, etc)
Fails to burn the image, drive locks and can NOT be eject with any software/hardware methods.
After emergency ejection with paper clip, CD/DVD's will no longer automatically mount.
The CD/DVD drive is no longer accessible to the system.

wiggmpk@LUGGS-MBL:~$ dmesg | egrep sr0
[ 3.582557] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[ 3.582631] sr 1:0:0:0: Attached scsi CD-ROM sr0
[ 291.239619] end_request: I/O error, dev sr0, sector 0
[ 291.239629] Buffer I/O error on device sr0, logical block 0
[ 291.242699] end_request: I/O error, dev sr0, sector 0
[ 291.242707] Buffer I/O error on device sr0, logical block 0

wiggmpk@LUGGS-MBL:~$ sudo hdparm -i /dev/cdrom

/dev/cdrom:
 HDIO_GET_IDENTITY failed: No message of desired type

WIGGMPk (wiggmpk) wrote :

Sorry for the second post, but its worth mentioning...

My first CD/DVD burner (internal SATA GSA-T50L) was working fine in Windows XP, Vista, RC7

Was working relatively fine in Interpid with nautilus-cd-create (or whatever that package is called)

Broke in Jaunty & the drive was physically replaced by ASUS with a brand spanking new model.

The new drive burnt 1 DVD image and then stopped working.

emilythekat (phipps-emily) wrote :

I have the same problem.

When the drive stops working it won't work again until the computer has been shut down. Even restarting doesn't work. If i try to restart it won't go past the first startup screen until it has been shut down.

WIGGMPk (wiggmpk) wrote :

I dont understand what the problem is with this..

It was reported in December of 2008, its still flagged as new and the importance is still undecided.. Whats the hold up with getting this resolved??

Its been confirmed by more than one person and personally, not being able to burn a CD/DVD is a pretty big deal since it is one of the most basic operations these days.

jdawgaz (jdawgaz) wrote :

yeah, I don't know what the problem with this is either. It's like this bug fell off the face of the earth. At least, if no one is doing any investigation, or flat won't work on it, they should at least acknowledge that there IS a bug here.

I always thought FOSS was better than this, but this reminds me of calling support on other non-FOSS products. Either no answer, or they can't help you -- one way or the other.

As I said in my previous post, I went out and bought a usb dvd burner for $75.00 USD.

I am very disappointed that after over 6 months -- no answer at all. nada. Not what I would expect from FOSS community.

caibbor (caibbor) wrote :

I should also mention that I'm not an Ubuntu user, I'm on Gentoo. this is just the best place I've found for this particular hardware issue. It's not distro-spcific. probably a kernel issue.

Linux Distribution
------------------
Gentoo Base System release 1.12.11.1

DMI Information
---------------
Manufacturer: ASUSTeK Computer Inc.
Product Name: G50VT

Kernel Information
------------------
Kernel release: 2.6.30-gentoo-r2 (this was also happening in 2.6.27 and others)
Operating System: GNU/Linux
Architecture: i686
Processor: Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz
SMP Enabled: Yes

caibbor (caibbor) wrote :

Apparently CD Crives have Firmware. who knew?

this HP laptop offers a firmware update, but it's not my brand. should stil work I'd imagine since it's the same model drive:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=321957&prodSeriesId=3781677&prodNameId=3781682&swEnvOID=2103&swLang=13&mode=2&taskId=135&swItem=ob-70726-1

caibbor (caibbor) wrote :

except that you'll need windows or wine to install it. (hopefully this is actually firmware and not just drivers)

caibbor (caibbor) wrote :

for my system there is a BIOS update that fixes "Solve ODD can''t be detected under DOS." (ODD means Optical Disc Drive). perhaps this is a BIOS issue. I'm gunna try this and report back here.

http://support.asus.com/download/download.aspx?SLanguage=en-us

caibbor (caibbor) wrote :

I just flashed my bios on this ASUS G50vt-x1 from version 205 to 213 as I mentioned previously. I just ripped a CD and a 7gb DVD (ghostbusters), set a bash loop to mount and unmount the cd over and over, and after all that it worked just like normal.

however, then I went to burn a CD (arcanum play disc iso) and K3B did what it always does: sits there doing nothing. also a mount command is completely stuck, and I can't even `killall -9` it. it just won't die. and my cd wont eject.

bah.

akashayi (akashayi) wrote :

I've run into this exact bug with the DVDRAM GSA-T50L on an Asus x83vm, running 64bit jaunty.

I get Buffer I/O errors as well as the output from sudo hdparm -i /dev/cdrom, HDIO_GET_IDENTITY failed: No message of desired type.

This seems to be a fairly widespread error, as the I know two other people with this device encountering this bug, on asus x83vb model laptops.

I thought I would have to find a driver or firmware fix, but I've just figured out something that works. From within the bios, I switched the IDE mode from enhanced to compatibility and can now write to the device just fine. I have only tested this burning an audio cd so far.

Hope that helps, this is a seriously frustrating bug.

level0 (skinbad) wrote :

I have an Asus M51va that gave the same problem since I bought it (almost 1 year ago)
on vista it stopped playing dvds after a while and device disappeared from control panel, so I had to restart the pc to get it back on work
on ubuntu it was impossible to eject the dvd...
sent laptop to support, they changed the dvd drive but problem still the same
firmware was SR04
tried firmware from HP but cannot install (it cannot find any device to apply patch)
when I was already exhausted and trying to get my money back from the seller, I found a firmware (SR07) for my dvd drive
installed it from windows and now just running ubuntu without any problem with sara ahci enabled in bios

this firmware looks like a preview of what hitachi/lg will deliver one day

asus support lost the chance to gain new future customer...

more details on procedure/links on solarisnevada.blogspot.com

just one note: I haven't found the procedure to rollback in case firmware upgrade fails...be careful before going on

JohnnyGrey (johnnygrey) wrote :

Signed up to report that I have been experiencing the same problem in Windows 7 RC (build 7100) for the last few months. Have not used an OS other than Winblows, so this is definitely a firmware/hardware issue, or a BIOS/Chipset problem. I have an ASUS x83vm laptop as well. (The one with the P8400, 320gb HDD, and the Geforce 9600m video card.)

The DVD drive will lock up when doing random things, such as installing a game, attempting to watch a DVD, etc. The DVD drive will not stop spinning, cannot be ejected, and disappears in My computer, Device Manager, as well as the Disk Management console. Restarting the computer causes the BIOS to hang during POST, when trying to detect the second SATA drive. The only option is to do a shutdown, and then a cold boot.

However, I did try some experimentation to see if Windows 7 can re-recognize the drive if it was removed. I removed the retaining screw from the bottom of the laptop to allow it to slide in and out, and when the drive failed, I removed it, and then immediately plugged it back in. Windows 7 recognized it and it worked fine, at least until the next failure.

level0, if you are still watching this topic, I would really like to know where you got a hold of that firmware, SR07. The HP flash utility is reporting the same error you get, Drive not found.

I am going to bookmark this topic, and proceed to update my BIOS. However, I don't remember if I already have or not.

If this is indeed just a faulty drive, that is some relief, because the drive can be replaced (Blu-Ray here we come!) Laptop is out of warranty anyways. But if the BIOS or the chipset itself is faulty, then we are screwed.

level0 (skinbad) wrote :

Hey Johnny, as I said previously I detailed everything on http://solarisnevada.blogspot.com, anyway I tried to get the firmware from the link reported and upload the file here, so also future readers will got what they look for

forget about the patch from hp...works only on their hardware
and forget about Asus...their support was really frustrating to me..
hope the upload works (I've never used it)

bye!

alonehacker (alonehacker) wrote :

Hey, just an FYI, ASUS has released an updated firmware for the GSA-T50L. You will need windows to update the firmware however. I haven't tested it in wine.

Link here:

http://support.asus.com/download/download.aspx?product=3&model=Optical%20Disk%20Drive%20Firmware&SLanguage=en-us&os=8

The current firmware revision is the SR09.

It seems to fix timeouts upon insertion of disks. My dvd drive finally works properly in linux! :)

As a reference, hdparm -i /dev/sr0 gives this:

/dev/sr0:

 Model=HL-DT-ST, FwRev=SR09, SerialNo=K0088F85148
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=unknown, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes: pio0 pio3 pio4
 DMA modes: mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
 AdvancedPM=no
 Drive conforms to: Unspecified: ATA/ATAPI-4,5,6,7

hope this helps all of you!

It may fix the timeout upon inserting disks, but the drive still fails to burn a CD-R.
Even with the latest BIOS and cd drive firmware...

alonehacker (alonehacker) wrote :

You're right..it does fix the timeout issue upon inserting disks, but every burn does indeed fail. Erasing a CD-RW does work however.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Bug attachments