Cannot write DVD's with K3B or Nautilus

Bug #136678 reported by Wilbur Harvey on 2007-09-01
12
Affects Status Importance Assigned to Milestone
dvd+rw-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libnautilus-burn-dev

I get an Input/Output error whenever I try to burn a dvd, using K3B or the Nautilus CD Burner.
I have the latest Gutsy updates as of this morning, 2007-Sep-01.
The machine burned DVD's without problems before I upgraded from Feisty to Gutsy.

Here is the error output from K3B, the nautilus burner just said there was an Input/Output error.

System
-----------------------
K3b Version: 1.0.3

KDE Version: 3.5.7
QT Version: 3.3.7
Kernel: 2.6.22-10-generic
Devices
-----------------------
TSSTcorp CD/DVDW SH-W162Z TS00 (/dev/hda, ) [CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD+R, DVD+RW, DVD+R DL] [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite]

Burned media
-----------------------
DVD+R

Used versions
-----------------------
growisofs: 7.0.1

growisofs
-----------------------
Executing 'builtin_dd if=/dev/fd/0 of=/dev/hda obs=32k seek=0'
/dev/hda: "Current Write Speed" is 4.1x1352KBps.
          0/4496293888 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU 0.0%
          0/4496293888 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU 0.0%
          0/4496293888 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU 0.0%
          0/4496293888 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU 0.0%
          0/4496293888 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU 0.0%
:-[ WRITE@LBA=0h failed with SK=3h/ASC=73h/ACQ=03h]: Input/output error
:-( write failed: Input/output error

growisofs command:
-----------------------
/usr/bin/growisofs -Z /dev/hda=/dev/fd/0 -use-the-force-luke=notray -use-the-force-luke=tty -use-the-force-luke=tracksize:2195456 -dvd-compat -speed=4 -overburn -use-the-force-luke=bufsize:32m

I tried it again after the updates from Sept 03, and I was able to burn CD's. I didn't try a DVD.

Milan Bouchet-Valat (nalimilan) wrote :

Looks very similar to Bug 37876 (except it is in Feisty), you should look at that one, and maybe set this as duplicate. I'd like to add I'm experiencing the same error message as here, but writing DVD+RW.
This is generally a DVD-only bug (growisofs), not affecting CDs.

Brian O'Keefe (okeefe) wrote :

I posted on bug#15424 and Schily wrote he was moving the bug to dvd+rw so here I am. I upgraded my drive from a Matshita DVD-R to a DVD+/-RW DL. I was burning DVDs (only DVD-R) fine in K3b but not GnomeBaker. I cannot burn now with the "input/output" and "device busy" errors.
I have read these posts and others and decided to try Graveman-no luck. I tried command line:

sudo growisofs -Z /dev/hdc -R -J /home/brianokeefe
and got:
mkisofs: Joliet tree sort failed. The -joliet-long switch may help you.
:-( write failed: Input/output error"

If I add the switch I get the same error. Here's an example of what's choking mkisofs, apparently:

mkisofs: Error: /home/brianokeefe/.nautilus/metafiles/file:%2F%2F%2Fhome%2Fbrianokeefe%2Fgtk-gnutella-downloads%2Fcomplete%2FMusic.xml and /home/brianokeefe/.nautilus/metafiles/file:%2F%2F%2Fhome%2Fbrianokeefe%2Fgtk-gnutella-downloads%2Fcomplete.xml have the same Joliet name

Could this be the source of the K3b error and GnomeBaker and Graveman failing too?

Brian O'Keefe (okeefe) wrote :

Progress!
I ran the same command "sudo growisofs -Z /dev/hdc -R -J /home/brianokeefe" without the -J option and successfully burned a DVD+RW. How do I disable this in K3b,etc? If that's the problem.

Brian O'Keefe (okeefe) wrote :

I figured that out in K3b, disabling Joliet, and tried to burn. The DVD burned and has good data but k3b gave an error again, "device or resource busy", so this is not a mkisiofs problem as far as I can tell. I'm stumbling through trying to get a cdrtools installed for Dapper by backporting with Prevu. Will post results.

I have the same error message of the author with an Asus A6U series (Mashita): I cannot burn DVD+R...

The progress of growisofs on my system before it errors is:

  0.33% done, estimate finish Sat Jul 19 14:37:07 2008
  0.65% done, estimate finish Sat Jul 19 14:37:07 2008
  0.98% done, estimate finish Sat Jul 19 14:38:48 2008
:-[ READ TRACK INFORMATION failed with SK=4h/ASC=08h/ACQ=03h]: Input/output error

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 beta or later?

Changed in dvd+rw-tools:
status: New → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in dvd+rw-tools:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions