TypeError: must be str, not bytes using PCA backend

Bug #1867435 reported by Xavier Poinsard on 2020-03-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned
duplicity (Ubuntu)
Undecided
Unassigned

Bug Description

I am using duplicity 0.8.11.1604 from snap edge channel.
I am trying to use multi backend with one of them being the OVH PCA.
It fails when trying to write to the PCA with the following error :

MultiBackend: _put: write to store #0 (pca://backupPortableX-cold)
Writing cold_duplicity-full.20200314T135032Z.vol1.difftar.gpg
Backtrace of previous error: Traceback (innermost last):
  File "/snap/duplicity/83/lib/python3.6/site-packages/duplicity/backend.py", line 376, in inner_retry
    return fn(self, *args)
  File "/snap/duplicity/83/lib/python3.6/site-packages/duplicity/backend.py", line 547, in put
    self.__do_put(source_path, remote_filename)
  File "/snap/duplicity/83/lib/python3.6/site-packages/duplicity/backend.py", line 533, in __do_put
    self.backend._put(source_path, remote_filename)
  File "/snap/duplicity/83/lib/python3.6/site-packages/duplicity/backends/pcabackend.py", line 153, in _put
    self.conn.put_object(self.container, self.prefix + remote_filename,
 TypeError: must be str, not bytes

Changed in duplicity:
importance: Undecided → Medium
milestone: none → 0.8.12
status: New → Fix Committed
Changed in duplicity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in duplicity (Ubuntu):
status: New → Confirmed
Changed in duplicity (Ubuntu):
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers