[FFe] re-seeding demoted packages with python3 support

Bug #1829862 reported by Dimitri John Ledkov on 2019-05-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
deja-dup (Ubuntu)
Undecided
Unassigned
duplicity (Ubuntu)
Undecided
Unassigned
mailman3 (Ubuntu)
Undecided
Unassigned
swift (Ubuntu)
Undecided
Unassigned

Bug Description

As part of demotion of python2.7 to universe the following packages were demoted as colateral damange:

* swift
* mailman
* duplicity

This is an FFe requesting to allow re-seeding these packages back into main and/or onto desktop image, when python3 variants of them become available. Either prior to release, or as an SRU.

Note that Openstack should have rc milestone available prior to release, with final just-in-time/shortly-after Eoan GA.

summary: - [FFe] re-seeding packages with python3 support
+ [FFe] re-seeding demoted packages with python3 support
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

mailman3 MIR got abandonned.

Changed in swift (Ubuntu):
status: New → Fix Released
Changed in mailman3 (Ubuntu):
status: New → Won't Fix
Changed in duplicity (Ubuntu):
status: New → Fix Released
Changed in deja-dup (Ubuntu):
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 40.1-1ubuntu1

---------------
deja-dup (40.1-1ubuntu1) eoan; urgency=medium

  * duplicity is ported to python3 and shipped in Ubuntu, make it a hard
    depends on any OS. Update suggests to python3. LP: #1829862

 -- Dimitri John Ledkov <email address hidden> Fri, 06 Sep 2019 11:04:44 +0100

Changed in deja-dup (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers