duplicity ftbfs in 18.04 LTS

Bug #1813578 reported by Matthias Klose on 2019-01-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
duplicity (Ubuntu)
High
Unassigned
Bionic
High
Sebastien Bacher

Bug Description

* Impact
the package fails to build, see
http://people.canonical.com/~doko/ftbfs-report/test-rebuild-20181222-bionic.html

* Test case
Check that the package once accepted is building without issue

* Regression potential
The change is to add a gpg option, that's already in cosmic and shouldn't have any side effect, check that deja-dup backups still work as they should though

-------------------

duplicity ftbfs.

======================================================================
ERROR: test_sigchain_fileobj (testing.unit.test_collections.CollectionTest)
Test getting signature chain fileobjs from archive_dir
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/<<PKGBUILDDIR>>/testing/unit/test_collections.py", line 188, in test_sigchain_fileobj
    self.sigchain_fileobj_check_list(self.sigchain_fileobj_get(None))
  File "/<<PKGBUILDDIR>>/testing/unit/test_collections.py", line 180, in sigchain_fileobj_check_list
    test_fileobj(0, "Hello, world!")
  File "/<<PKGBUILDDIR>>/testing/unit/test_collections.py", line 177, in test_fileobj
    fileobjlist[i].close()
  File "/<<PKGBUILDDIR>>/duplicity/dup_temp.py", line 227, in close
    assert not self.fileobj.close()
  File "/<<PKGBUILDDIR>>/duplicity/gpg.py", line 304, in close
    self.gpg_failed()
  File "/<<PKGBUILDDIR>>/duplicity/gpg.py", line 271, in gpg_failed
    raise GPGError(msg)
GPGError: GPG Failed, see log below:
===== Begin GnuPG log =====
gpg: starting migration from earlier GnuPG versions
gpg: porting secret keys from '/<<PKGBUILDDIR>>/testing/gnupg/secring.gpg' to gpg-agent
gpg: key 839E6A2856538CCF: secret key imported
gpg: key BCEF1B4DB5FA894F: secret key imported
gpg: key 453005CE9B736B2A: secret key imported
gpg: migration succeeded
gpg: CAST5 encrypted data
gpg: encrypted with 1 passphrase
gpg: WARNING: message was not integrity protected
gpg: Hint: If this message was created before the year 2003 it is
likely that this message is legitimate. This is because back
then integrity protection was not widely used.
gpg: Use the option '--ignore-mdc-error' to decrypt anyway.
gpg: decryption forced to fail!
gpg: WARNING: unsafe permissions on homedir '/<<PKGBUILDDIR>>/testing/gnupg'
===== End GnuPG log =====

----------------------------------------------------------------------
Ran 418 tests in 881.428s

FAILED (errors=1, skipped=9)
Test failed: <unittest.runner.TextTestResult run=418 errors=1 failures=0>
error: Test failed: <unittest.runner.TextTestResult run=418 errors=1 failures=0>
debian/rules:11: recipe for target 'override_dh_auto_test' failed
make[1]: *** [override_dh_auto_test] Error 1

Matthias Klose (doko) on 2019-01-28
tags: added: ftbfs rls-bb-incoming
Changed in duplicity (Ubuntu):
importance: Undecided → High
Changed in duplicity (Ubuntu Bionic):
importance: Undecided → High
Changed in duplicity (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Sebastien Bacher (seb128)
Changed in duplicity (Ubuntu Bionic):
status: In Progress → Fix Committed
description: updated
Sebastien Bacher (seb128) wrote :

The issue was fixed in cosmic

Changed in duplicity (Ubuntu):
status: New → Fix Released
Jeremy Bicha (jbicha) on 2019-01-29
tags: added: bionic
removed: rls-bb-incoming

Hello Matthias, or anyone else affected,

Accepted duplicity into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/duplicity/0.7.17-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
Sebastien Bacher (seb128) wrote :

0.7.17-0ubuntu1.1 built fine

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package duplicity - 0.7.17-0ubuntu1.1

---------------
duplicity (0.7.17-0ubuntu1.1) bionic; urgency=medium

  * debian/patches/06-gnupg-version.patch:
    - backport an upstream commit to fix the build with
      the new gnupg version (lp: #1813578)

 -- Sebastien Bacher <email address hidden> Tue, 29 Jan 2019 10:28:17 +0100

Changed in duplicity (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for duplicity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers