crash deja-dup backup ascii' codec can't decode byte 0xc3

Bug #1311176 reported by Jaufré Aligé on 2014-04-22
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned
duplicity (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

I didn't change anything, it worked fine. I updated to Ubuntu 14.04 from 13.10 where this backup worked without problem.
I didn't write or erase any data in the backuped folder.

Here is the output :

Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1494, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1488, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1337, in main
    do_backup(action)
  File "/usr/bin/duplicity", line 1469, in do_backup
    check_last_manifest(col_stats) # not needed for full backup
  File "/usr/bin/duplicity", line 1170, in check_last_manifest
    last_backup_set.check_manifests()
  File "/usr/lib/python2.7/dist-packages/duplicity/collections.py", line 190, in check_manifests
    remote_manifest = self.get_remote_manifest()
  File "/usr/lib/python2.7/dist-packages/duplicity/collections.py", line 224, in get_remote_manifest
    manifest_buffer = self.backend.get_data(self.remote_manifest_name)
  File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 646, in get_data
    fin = self.get_fileobj_read(filename, parseresults)
  File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 607, in get_fileobj_read
    self.get(filename, tdp)
  File "/usr/lib/python2.7/dist-packages/duplicity/backends/giobackend.py", line 151, in get
    self.copy_file('get', source_file, target_file)
  File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 321, in iterate
    % (n, e.__class__.__name__, str(e)))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 3: ordinal not in range(128)

I don't understand : I'm saving datas from a ext4 to a ext4. Maybe a problem while crypting it ? Sorry I don't know many things about it.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: duplicity 0.6.23-1ubuntu4
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Apr 22 17:04:10 2014
InstallationDate: Installed on 2014-04-10 (11 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140410)
SourcePackage: duplicity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jaufré Aligé (jaufre) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in duplicity (Ubuntu):
status: New → Confirmed
Tomáš Hetmer (olx) wrote :

Confirmed on a new 14.04 install. I'm trying to backup over SSH with Deja dup.
First backup worked fine (minimum user data), now this problem appeared with more files (some UTF-8 problem?).

  [...]
  File "/usr/lib/python2.7/dist-packages/duplicity/backends/giobackend.py", line 145, in put
    self.copy_file('put', source_file, target_file)
  File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 321, in iterate
    % (n, e.__class__.__name__, str(e)))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 1: ordinal not in range(128)

Tomáš Hetmer (olx) wrote :

In my case it turned to be a permissions problem.
Duplicity crashed because it couldn't read/write the old backup on the remote server. (still a bug)

Changed in duplicity (Ubuntu):
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in duplicity (Ubuntu):
status: New → Confirmed
Changed in duplicity:
importance: Undecided → Medium
milestone: none → 0.6.24
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package duplicity - 0.6.23-1ubuntu5

---------------
duplicity (0.6.23-1ubuntu5) utopic; urgency=medium

  * debian/patches/exception-encode.patch:
    - More encoding issue fixes, this time with filenames in exceptions
      and if the target path has utf8 characters in it. LP: #1289288,
      LP: #1311176, LP: #1313966
 -- Michael Terry <email address hidden> Tue, 29 Apr 2014 20:16:15 -0400

Changed in duplicity (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in duplicity (Ubuntu Trusty):
status: New → Confirmed
Jaufré Aligé (jaufre) wrote :

Maybe there is something else because it stoped when I changed the files owner on the server.

The strange thing is :
ACL are activated on the server's partition.
The original owner of the files and the actual are both authorised to rwx on all the backup files.

Why Duplicity would have write problems if it's loged in as the new user ? I just did "chown seconduser".

Hello Jaufré, or anyone else affected,

Accepted duplicity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/duplicity/0.6.23-1ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in duplicity (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in duplicity:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

The new version seems to work fine, e.u.c doesn't show new issues, tagging as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package duplicity - 0.6.23-1ubuntu4.1

---------------
duplicity (0.6.23-1ubuntu4.1) trusty; urgency=medium

  * debian/patches/exception-encode.patch:
    - Fix exception when backing up to a directory with utf8 characters
      in its path when using the gio backend (as deja-dup does).
      LP: #1313966
    - Fix a couple more encoding issues during exception handling. These
      bits aren't as critical, but are bundled in same patch from upstream
      and are still useful. LP: #1289288, LP: #1311176
 -- Michael Terry <email address hidden> Tue, 29 Apr 2014 20:16:15 -0400

Changed in duplicity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for duplicity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers