duplicity crashed with UnicodeDecodeError in done_with_mount(): 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)

Bug #1289288 reported by David Kiliani on 2014-03-07
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned
duplicity (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Errors Bucket]
https://errors.ubuntu.com/problem/076e3d0ec5a89dbb4d675a10dfb65af345c367fb

$ lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

$ apt-cache policy duplicity
duplicity:
  Installiert: 0.6.23-1ubuntu2
  Installationskandidat: 0.6.23-1ubuntu2
  Versionstabelle:
 *** 0.6.23-1ubuntu2 0
        500 http://ftp-stud.hs-esslingen.de/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Expected behaviour:
Exit gracefully when no network connection to the storage server can be established.

Actual behaviour:
duplicity crashes

ProblemType: CrashDistroRelease: Ubuntu 14.04
Package: duplicity 0.6.23-1ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-14.34-generic 3.13.5
Uname: Linux 3.13.0-14-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Mar 7 07:18:14 2014
ExecutablePath: /usr/bin/duplicity
InstallationDate: Installed on 2011-06-21 (989 days ago)InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/duplicity cleanup --force smb://user@10.3.2.1/data/backup/torfbook2 --gio --no-encryption --verbosity=9 --gpg-options=--no-use-agent --archive-dir=/home/username/.cache/deja-dup --tempdir=/home/username/.cache/deja-dup/tmp --log-fd=13
PythonArgs: ['/usr/bin/duplicity', 'cleanup', '--force', 'smb://user@10.3.2.1/data/backup/torfbook2', '--gio', '--no-encryption', '--verbosity=9', '--gpg-options=--no-use-agent', '--archive-dir=/home/username/.cache/deja-dup', '--tempdir=/home/username/.cache/deja-dup/tmp', '--log-fd=13']SourcePackage: duplicity
Title: duplicity crashed with UnicodeDecodeError in done_with_mount(): 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/duplicity/backends/giobackend.py", line 107, in done_with_mount
     % str(e), log.ErrorCode.connection_failed)
 UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)
UpgradeStatus: Upgraded to trusty on 2014-01-30 (36 days ago)
UserGroups: adm admin audio cdrom dialout dip disk fax fuse libvirtd lpadmin netdev plugdev pulse-access sambashare vboxusers video

Related branches

tags: removed: need-duplicate-check
Changed in duplicity (Ubuntu):
importance: Undecided → Medium
Michael Terry (mterry) on 2014-04-30
information type: Private → Public
Changed in duplicity:
importance: Undecided → Medium
milestone: none → 0.6.24
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package duplicity - 0.6.23-1ubuntu5

---------------
duplicity (0.6.23-1ubuntu5) utopic; urgency=medium

  * debian/patches/exception-encode.patch:
    - More encoding issue fixes, this time with filenames in exceptions
      and if the target path has utf8 characters in it. LP: #1289288,
      LP: #1311176, LP: #1313966
 -- Michael Terry <email address hidden> Tue, 29 Apr 2014 20:16:15 -0400

Changed in duplicity (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in duplicity (Ubuntu Trusty):
status: New → Confirmed
description: updated

Hello David, or anyone else affected,

Accepted duplicity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/duplicity/0.6.23-1ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in duplicity (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in duplicity:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

There is no e.u.c report from the new version, setting as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package duplicity - 0.6.23-1ubuntu4.1

---------------
duplicity (0.6.23-1ubuntu4.1) trusty; urgency=medium

  * debian/patches/exception-encode.patch:
    - Fix exception when backing up to a directory with utf8 characters
      in its path when using the gio backend (as deja-dup does).
      LP: #1313966
    - Fix a couple more encoding issues during exception handling. These
      bits aren't as critical, but are bundled in same patch from upstream
      and are still useful. LP: #1289288, LP: #1311176
 -- Michael Terry <email address hidden> Tue, 29 Apr 2014 20:16:15 -0400

Changed in duplicity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for duplicity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers