arpspoof doesn't work without specifying target

Bug #1176347 reported by Felix Dreissig on 2013-05-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dsniff (Debian)
Fix Released
Unknown
dsniff (Ubuntu)
Undecided
Unassigned

Bug Description

If the '-t' argument is missing, arpspoof should, according to its manpage, posion "all hosts on the LAN".
However, as of dsniff_2.4b1+debian-22 (available in quantal and raring), that does no longer work. arpspoof will start just fine, but never actually send out any ARP replies and also don't log anything to the console.

Everything works alright with dsniff_2.4b1+debian-21.1 (available in precise).

Changed in dsniff (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dsniff (Ubuntu):
status: New → Confirmed

Running Ubuntu Gnome 15.10 with the same problem. I added deb http://us.archive.ubuntu.com/ubuntu/ precise main universe restricted multiverse to my sources and installed dsniff from precise.

Changed in dsniff (Debian):
status: New → Fix Committed
Changed in dsniff (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.