Backport drush 4.4-1 from natty to lucid, maverick

Bug #755169 reported by anarcat on 2011-04-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lucid Backports
Undecided
Unassigned
maverick-backports
Fix Released
Undecided
Unassigned
drush (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: drush

We need some ubuntu wizard to make a backport like this:

https://wiki.ubuntu.com/StableReleaseUpdates - for LTS

I have requested a freeze exception in #755172, but the SRU is beyond my capacity.

That would fix all other bugs opened here.

Maybe we want to go smoother with this: https://help.ubuntu.com/community/UbuntuBackports

summary: - sync drush from Debian into natty and/or lucid
+ backport drush into lucid lynx LTS once in natty
description: updated
summary: - backport drush into lucid lynx LTS once in natty
+ backport drush into lucid LTS (or maverick?) once in natty

anarcat,

Can you please confirm that the drush package fulfills the requirements listed in https://help.ubuntu.com/community/UbuntuBackports#How%20to%20request%20new%20packages ? I'm especially concerned about "Backports should only affect themselves, and not cause any consequences to the rest of the system."

Once you have done so you should use the "Also affects project" link and add a bug task for the correct project; e.g. lucid-backports, maverick-backports.

Changed in drush (Ubuntu):
status: New → Incomplete

You may also wish to consider subscribing to bug reports for drush in Ubuntu from the package overview page: https://edge.launchpad.net/ubuntu/+source/drush ("Subscribe to bug mail" link).

anarcat (anarcat) wrote :

I have reviewed the requirements and I do not believe the drush backport will cause any problem to other packages, being a leaf package (for now). Drush 4.4 is also much more featureful and has bugfixes that are not present in the 3.3 package, which maybe could warrant a SRU instead, but those are fairly minor bugs...

Changed in drush (Ubuntu):
status: Incomplete → In Progress
Evan Broder (broder) wrote :

Before we can process this backport, there's some verification work that needs to be done.

First, in order to ensure that there's a valid upgrade path away from Lucid, drush will definitely also need to be backported to Maverick.

Second, the backports process requires some basic verification that the packages will work once backported. I've uploaded test backports from natty to lucid and maverick to my PPA (https://launchpad.net/~broder/+archive/backports-tests). Please verify that they successfully build, then install them and ensure that they run. This must be done for all releases.

Finally, drush has a single reverse-dependency:
> mingo:~ evan$ schroot -c lucid-amd64 -- apt-cache rdepends drush
> drush
> Reverse Depends:
> aegir-provision
> aegir-provision
> mingo:~ evan$ schroot -c maverick-amd64 -- apt-cache rdepends drush
> drush
> Reverse Depends:
> aegir-provision

Please verify that all reverse-dependencies continue to work with the backported drush package on all releases.

Feel free to change the status of the bug to "Confirmed" once this testing has been completed.

summary: - backport drush into lucid LTS (or maverick?) once in natty
+ Backport drush 4.4-1 from natty to lucid, maverick
Changed in lucid-backports:
status: New → Incomplete
Changed in maverick-backports:
status: New → Incomplete
anarcat (anarcat) wrote :

I agree this should be backported to maverick.

I have the test environment only for Lucid however, so I will do that part.

I am the maintainer of aegir-provision in Debian, and it was removed from unstable and squeeze, because that version is out of date, unstable and unsupported upstream. It should also be removed from Ubuntu. I will open an issue specifically about this.

anarcat (anarcat) wrote :

I have opened a bug report to remove the leaf package from the archive: https://bugs.launchpad.net/ubuntu-sponsoring/+bug/793567

I will test the backport in a few minutes...

Scott Kitterman (kitterman) wrote :

If a package is already broken, it needn't block a backport (the only consideration would be if it were to make it a lot more broken, which doesn't seem likely in this case).

anarcat (anarcat) wrote :

i have finally found time to test the backport in lucid, and I confirm it works. unfortunately, I can't test in maverick, but I don't see why it would fail there.

Changed in lucid-backports:
status: Incomplete → Confirmed
anarcat (anarcat) wrote :

Ping! What's keeping this from being backported now?

4.5 is coming up next week, I hope this will not be an issue...

Like I mentioned earlier, testing backports on all releases we're
backporting to is a requirement of the backports process. We can
approve the backport once it's been tested on maverick.

J Parker (lyh0y55gq) wrote :

This has been successfully tested on Maverick.

Evan Broder (broder) wrote :

Great. In that case, ACK from backporters fro lucid and maverick.

Changed in drush (Ubuntu):
status: In Progress → Invalid
Changed in lucid-backports:
status: Confirmed → In Progress
Changed in maverick-backports:
status: Incomplete → In Progress
Colin Watson (cjwatson) wrote :

I: Extracting drush_4.4-1.dsc ... done.
I: Building backport of drush as 4.4-1~lucid1 ... done.

Changed in lucid-backports:
status: In Progress → Fix Released
Colin Watson (cjwatson) wrote :

I: Extracting drush_4.4-1.dsc ... done.
I: Building backport of drush as 4.4-1~maverick1 ... done.

Changed in maverick-backports:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers