Merge dropbear 2014.65-1 (universe) from Debian unstable (main)

Bug #1355670 reported by Mattia Rizzolo on 2014-08-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dropbear (Ubuntu)
Wishlist
Unassigned

Bug Description

changelog:

dropbear (2014.65-1) unstable; urgency=low

  [ Matt Johnston ]
  * New upstream release (closes: #757780).

  [ Gerrit Pape ]
  * debian/diff/0003-options.h-use-usr-bin-xauth-instead-of...diff:
    remove; applied upstream.
  * debian/control: Standards-Version: 3.9.5.0.

 -- Gerrit Pape <email address hidden> Mon, 11 Aug 2014 20:50:11 +0000

dropbear (2014.64-1) unstable; urgency=low

  [ Matt Johnston ]
  * New upstream release (closes: #748826, #756561)..

  [ Gerrit Pape ]
  * debian/diff/: update.
  * debian/initramfs/premount-devpts: apply patch from
    https://launchpadlibrarian.net/107177971/dropbear_lp933903_precise_1.debdiff:
    duplicate mount /dev/pts in initramfs (thx Mario 'BitKoenig' Holbe,
    Guy Roussin, closes: #632656).
  * debian/dropbear.postinst: apply patch from Karl O. Pinc: dropbear's
    cryptroot setup does not use the system's host keys (closes:
    #714899).
  * debian/initramfs/dropbear-hook: apply patch from Karl O. Pinc:
    There is no warning when the cryptroot host key differs from the
    regular host key (closes: #714900).
  * debian/dropbear.postrm: apply patch from Karl O. Pinc: dropbear does
    not remove initramfs host keys on package purge (closes: #714945).
  * debian/initramfs/premount-dropbear: apply half of patch from
    Robert.Heinzmann: allow option specification for dropbear in
    /etc/initramfs-tools/initramfs.conf (closes: #614981).
  * debian/dropbear.conffiles: add
    /usr/share/initramfs-tools/conf-hooks.d/dropbear (thx Karl O. Pinc,
    closes: #715047).
  * debian/rules: apply patch from Matthias Klose: please allow the
    package to cross build (closes: #729845).

 -- Gerrit Pape <email address hidden> Fri, 01 Aug 2014 12:44:51 +0000

Mattia Rizzolo (mapreri) wrote :

The attachment "debdiff from debian/2014.65-1" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Artur Rona (ari-tczew) wrote :

If you have your complete debdiff attached, please change status to Confirmed.

Changed in dropbear (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Artur Rona (ari-tczew) on 2014-08-17
summary: - Please merge dropbear 2014.65-1 from debian unstable
+ Merge dropbear 2014.65-1 (universe) from Debian unstable (main)
Artur Rona (ari-tczew) wrote :

Thank you for your contribution!

Changed in dropbear (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dropbear - 2014.65-1ubuntu1

---------------
dropbear (2014.65-1ubuntu1) utopic; urgency=low

  * Merge from Debian unstable. (LP: #1355670) Remaining changes:
    + debian/initramfs/premount-devpts, debian/rules: drop the script, this is
      handled by initramfs-tools.
    + debian/initramfs/dropbear-hook: do not install dropbear in the initramfs
      if there's no uncommented line in /etc/crypttab.
    + debian/initramfs/premout-dropbear: fix so that the network configuration
      happens before dropbear takes hold of the network card.
 -- Mattia Rizzolo <email address hidden> Tue, 12 Aug 2014 11:04:21 +0200

Changed in dropbear (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers