Ubuntu

dropbear assumes mountpoint utility is in initramfs when it isn't

Reported by Ayke on 2012-10-24
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
dropbear (Ubuntu)
Undecided
Unassigned

Bug Description

See http://askubuntu.com/questions/203346/error-when-booting-12-10-after-upgrade

Ubuntu version: quantal

It seems like mountpoint -q prints a warning when the destination isn't a mount point, which it shouldn't according to the documentation.

Note: I haven't tested it myself.

Richard Hansen (a7x) wrote :

The warning being printed is not coming from mountpoint; it's coming from the shell (mountpoint can't be found).

The /scripts/init-premount/devpts script comes from dropbear, so I'm changing the affected package to dropbear.

affects: sysvinit (Ubuntu) → dropbear (Ubuntu)
summary: - mountpoint -q prints warning
+ dropbear assumes mountpoint is in initramfs when it isn't

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dropbear (Ubuntu):
status: New → Confirmed
Richard Hansen (a7x) on 2012-11-27
summary: - dropbear assumes mountpoint is in initramfs when it isn't
+ dropbear assumes mountpoint utility is in initramfs when it isn't
Nico R. (n-roeser) wrote :

This bug also appears on Ubuntu raring with dropbear-2012.55-1.3ubuntu1.

I added the following two lines in /usr/share/initramfs-tools/hooks/dropbear:
mkdir -p "${DESTDIR}/bin"
cp /bin/mountpoint "${DESTDIR}/bin/"
where the files are copied for the initramfs.

This results in the mountpoint binary being included in the generated initramfs images.

dropbear should also depend on the intscripts package if it is using the mountpoint binary installed by initscripts, shouldn’t it?

Sven Neuhaus (sven0) wrote :

A better fix would be to add the applet "mountpoint" to busybox.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dropbear - 2013.60-1ubuntu2

---------------
dropbear (2013.60-1ubuntu2) trusty; urgency=medium

  * Fix initramfs hooks so that the network configuration happens before
    dropbear takes hold of the network card. (LP: #363958)
  * Drop premount-devpts script, this is handled by initramfs-tools.
    (LP: #1070992)
  * Do not install dropbear in the initramfs if there's no uncommented line in
    /etc/crypttab.
 -- Margarita Manterola <email address hidden> Wed, 19 Feb 2014 16:26:26 +0000

Changed in dropbear (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers