Ubuntu

Please remove drizzle from maverick (was: fails to build from source on maverick)

Reported by Clint Byrum on 2010-09-21
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
drizzle (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

The current version of drizzle in maverick is failing unit tests on 32-bit architectures, and is very old. Suggest updating to the latest upstream as significant changes and improvements have been made.

== REMOVAL ==

The version of drizzle that is in maverick now is an alpha version. We have looked at importing the latest drizzle version, but it would still be a pre-release, alpha version. As such, after discussing with the drizzle development team, its been decided that it is better to not have a potentially incompatible version of drizzle in the archive, and direct users toward the project's official PPA.

Please remove the source package 'drizzle', from maverick, and these binaries which it builds:

drizzle-client
drizzle-server
drizzle-plugin-dev

None of these have any reverse dependencies.

tags: added: ftbfs maverick
Thierry Carrez (ttx) on 2010-09-21
tags: added: server-mrs
Thierry Carrez (ttx) on 2010-09-22
Changed in drizzle (Ubuntu Maverick):
assignee: nobody → Clint Byrum (clint-fewbar)
importance: Undecided → High
status: New → Triaged
Clint Byrum (clint-fewbar) wrote :

I have been working with Monty Taylor on this bug. The plan is to get it into Debian sid and then merge it in from there. The symbols are different from protobuf in sid and maverick, but this should be a relatively easy merge.

Drizzle releases their first beta on Monday, which resolves the issues seen in the build failures, and we're targetting "shortly after that" for this being uploaded into sid and maverick.

Clint Byrum (clint-fewbar) wrote :

Update on status:

This branch here has the package intended for upload into sid today:

lp:~drizzle-developers/drizzle/debian

Short a few minor cleanups by Monty since then, I've built this branch on both maverick and sid, and it builds and tests correctly.

Clint Byrum (clint-fewbar) wrote :

The upload to sid a few weeks ago was rejected by FTP masters because of copyright problems.

I am working on making sure it doesn't get rejected again. The status of that work is tracked in drizzle, here:

https://bugs.launchpad.net/drizzle/+bug/649281

summary: - fails to build from source on maverick
+ Please remove drizzle from maverick (was: fails to build from source on
+ maverick)
description: updated
Changed in drizzle (Ubuntu Maverick):
status: Triaged → Confirmed
assignee: Clint Byrum (clint-fewbar) → nobody
description: updated
Colin Watson (cjwatson) wrote :

2010-10-01 12:20:33 INFO Creating lockfile: /var/lock/launchpad-lp-remove-package.lock
2010-10-01 12:20:41 INFO Removing candidates:
2010-10-01 12:20:41 INFO drizzle 2010.03.1347-1 in maverick
2010-10-01 12:20:41 INFO drizzle-client 2010.03.1347-1 in maverick amd64
2010-10-01 12:20:41 INFO drizzle-plugin-dev 2010.03.1347-1 in maverick amd64
2010-10-01 12:20:41 INFO drizzle-server 2010.03.1347-1 in maverick amd64
2010-10-01 12:20:41 INFO Removed-by: Colin Watson
2010-10-01 12:20:41 INFO Comment: requested by clint-fewbar; old, fails tests on 32-bit architectures, alpha version so potentially incompatible with future releases, better to use official PPA for now
2010-10-01 12:20:41 INFO 4 packages successfully removed.
Confirm this transaction? [yes, no] yes
2010-10-01 12:20:57 INFO Transaction committed.
2010-10-01 12:20:57 INFO The archive will be updated in the next publishing cycle.

Changed in drizzle (Ubuntu Maverick):
status: Confirmed → Fix Released
Clint Byrum (clint-fewbar) wrote :

Per Daviey's request, some more detailed info about this removal and the future plans:

First, I wrote up these reasons in detail on my blog here:

http://fewbar.com/2010/09/drizzle-maverick-ppas-and-you/

To sum them up:

* We didn't want an alpha version in Maverick, and the beta was running a bit late given the proximity to release.
* Licensing had some ambiguities that need to be cleared up before Debian upload
* By going the PPA route during Drizzle's beta cycle, ustream will be able to handle the bug reports directly and incorporate changes into the final release.

The drizzle team is *targetting* Natty with their planned final release date of the "elliot" milestone in February, and I have every intention of ensuring that drizzle is in both Debian and Natty well before natty's release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers