Unable to login to blogger with google account

Bug #122016 reported by Juan V. Guerrero (Coredumped) on 2007-06-24
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Drivel
Fix Released
Medium
drivel (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: drivel

Just try to login with your regular google account (after migrating your profile to gmail) and see .
Look at gnome bugzilla bug # 419681 and 449198.

Related branches

Changed in drivel:
importance: Undecided → Wishlist
status: New → Confirmed
Robin Sonefors (ozamosi) wrote :

What is needed is to migrate the login code from HTTP Basic to Google ClientLogin, and also migrate from Atom 0.3 to Atom 1.0. That is done in Drivel SVN, however, it is done after a migration to libsoup, so there are quite a lot of changes needed. As if that wasn't enough, the latest SVN Head doesn't work, nor does the other revisions I've tried - either because it doesn't recognize namespaces, because it uses broken progress bar code, or because it just doesn't think the feed is valid. *sigh* I surrender!

Changed in drivel:
status: Unknown → New
Tanath (tanath) wrote :

Logging in with Blogger 1.0 works, but not 2.0. There's no blog title functionality with Blogger 1.0 though, so it would be good to see this fixed.

Neil Williams (codehelp) wrote :

Yes, only Blogger 1.0 is currently supported in drivel, but it does work with the current blogger site albeit with limitations.

Changed in drivel:
status: New → Fix Committed
Will Blaylock (wblalok) wrote :

I just installed drivel and can not it to log in to a blogspot/blogger journal that is only slightly older than that install.

I used the install in the Unbuntu 9.04 repository

Commit Log for Fri Nov 13 00:28:18 2009
Installed the following packages:
drivel (2.0.3-3.1ubuntu1)

and the command line output using blogger 1.0 format:

littlewill:[20091113.0055]will@~ :: drivel
(drivel:18827): Drivel-WARNING **: Throbber rest icon not found
(drivel:18827): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
(drivel:18827): Drivel-WARNING **: blog_blogger_parse_login_request: could not read blogid
(drivel:18827): Drivel-WARNING **: blog_blogger_parse_login_request: could not read blogid
Segmentation fault
littlewill:[20091113.0055]will@~ ::

command line output using atom/blogger 2.0
littlewill:[20091113.0055]will@~ :: drivel
(drivel:18829): Drivel-WARNING **: HTTP/GET request failed (HTTP code 404: No error).
(drivel:18829): Drivel-WARNING **: Throbber rest icon not found
(drivel:18829): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
(drivel:18829): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
(drivel:18829): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
littlewill:[20091113.0057]will@~ ::

Everything else seems to work. but my choices are limited to blogger and livejournal at present.

I have tried two machines so far with same results.

Neil Williams (codehelp) wrote :

Any bugs from versions of drivel other than 3.0.x will not be fixed. This bug has already been fixed in the current version.

Alin Andrei (nilarimogard) wrote :

I'm using the latest version from Lucid and still have this error so this bug has not been fixed for Blogger.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package drivel - 3.0.1-1

---------------
drivel (3.0.1-1) unstable; urgency=low

  * New upstream version (LP: #83788)
    (LP: #442180) (LP: #122016)
  * [l10n:cs] Updated Czech translation of drivel manual.
    (Closes: #552620)
  * Add -Wl,--no-add-needed in extra-compile-warning mode to
    catch missing linkages. Add -ldl to drivel LDFLAGS.
    (Closes: #554308)
  * [I18N:fr] French program translation (Closes: #574489)
 -- Ubuntu Archive Auto-Sync <email address hidden> Thu, 13 May 2010 08:12:40 +0100

Changed in drivel (Ubuntu):
status: Confirmed → Fix Released
Liam (liam-dennehy) wrote :

Sorry for the newbie-ish question, but how do I get the 3.0.1-1 package for Lucid to test?

Liam (liam-dennehy) wrote :

I've found a release package on debian, but it seems to be targeted at Maverick instead of Lucid, is this going to be backported or has this package moved mainstream releases to an alpha OS only?

On Mon, Jun 7, 2010 at 08:57, Liam <email address hidden> wrote:
> I've found a release package on debian, but it seems to be targeted at
> Maverick instead of Lucid, is this going to be backported or has this
> package moved mainstream releases to an alpha OS only?

Its unlikely that drivel will be updated in lucid though not
impossible. drivel is part of the 'universe' set which isn supported
to the same degree as 'main' packages.

https://wiki.ubuntu.com/StableReleaseUpdates and
https://help.ubuntu.com/community/UbuntuBackports talk about how to
get new versions into old releases.

Changed in drivel:
importance: Unknown → Medium
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.