Dragon Player not playing DVD

Bug #1572232 reported by warren on 2016-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dragon (Ubuntu)
Medium
Unassigned

Bug Description

Kubuntu 16.04 Xenial Final ISO version 20160417.1
Dragon Player not playing videos from DVD
MPV plays video from DVD
VLC plays video from DVD
Dragon Player will not stream video

I assume this is a actual bug, but I do not usually use KDE.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: dragonplayer 4:15.12.3-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.373
CurrentDesktop: KDE
Date: Tue Apr 19 16:32:08 2016
LiveMediaBuild: Kubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160417.1)
SourcePackage: dragon
UpgradeStatus: No upgrade log present (probably fresh install)

warren (wkclemmons) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1572232

tags: added: iso-testing
summary: - Dragon Player not playing videos
+ Dragon Player not playing DVD

This really is not a bug. Due to licence -restrictitions in various countries it is not possible to deliver full functionaility right to the stairs. this gets covered with the *-restricted packages [1]

Just open a terminal and check if the package is installed:

dpkg-query -l libdvdread4

[1] http://packages.ubuntu.com/xenial/kubuntu-restricted-addons

Changed in dragon (Ubuntu):
status: New → Invalid
status: Invalid → Incomplete
warren (wkclemmons) wrote :

libdvdread4 installed version 5.0.3-1

Why is Dragon Player installed by default in you have to install the restricted extra packages?
Why is VLC not installed by default since the restricted packages are not required?

Dragon player is a simple solution that is offered by upstream (KDE). It is preferred not to vary to much from the original KDE packaging. Just take it as a basic. FOSS offers choices.

VLC is easy installable via package-management (if someone wants/needs more). I think everybody has his/her own priorities. I've been liking&using VLC for years, especially since I like programs that are extremely configurablé. Even though I've beeen using the SM-Player in parallel, since it offers some advantages

Like you, I 've also installed the MPV-player (no volume-leveller, my bad :-), thus even less than dragon-player). Especially in conjunction with a firefox-addon mpv-youtube-dl-binding it offers unique advantages like no other package has. I don not like high CPU-loads. In german there is a term "eierlegende Wollmilchsau" which is hardly existent. This translates like "egg-/wool-/ -milk supplying animal" Reminds me of early days in distro-hopping. Like with most things in life there are advantages and disadvantages, which you can weigh personally, but it's hard to cover that for a wider audience. A brother of mine is not very much into software and he gets along pretty well with Dragon-player, it fills his basic needs.

> Why is VLC not installed by default since the restricted packages are not required?
Guessing: Licence issues in some countries. (Did say so before.)

Does DVD-playback work for you now?

Do I need to mark this bug as invalid?
I got an audio cd to work on dragon player but no dvd video.
I generally refuse to install the restricted extras.

Thanks
On 04/20/2016 04:49 PM, Flames_in_Paradise wrote:
> Dragon player is a simple solution that is offered by upstream (KDE). It
> is preferred not to vary to much from the original KDE packaging. Just
> take it as a basic. FOSS offers choices.
>
> VLC is easy installable via package-management (if someone wants/needs
> more). I think everybody has his/her own priorities. I've been
> liking&using VLC for years, especially since I like programs that are
> extremely configurablé. Even though I've beeen using the SM-Player in
> parallel, since it offers some advantages
>
> Like you, I 've also installed the MPV-player (no volume-leveller, my
> bad :-), thus even less than dragon-player). Especially in conjunction
> with a firefox-addon mpv-youtube-dl-binding it offers unique
> advantages like no other package has. I don not like high CPU-loads. In
> german there is a term "eierlegende Wollmilchsau" which is hardly
> existent. This translates like "egg-/wool-/ -milk supplying animal"
> Reminds me of early days in distro-hopping. Like with most things in
> life there are advantages and disadvantages, which you can weigh
> personally, but it's hard to cover that for a wider audience. A brother
> of mine is not very much into software and he gets along pretty well
> with Dragon-player, it fills his basic needs.
>
>> Why is VLC not installed by default since the restricted packages are not required?
> Guessing: Licence issues in some countries. (Did say so before.)
>
> Does DVD-playback work for you now?
>

Well yes, I think is is invalid.

Did you already visit the documentation?

-> https://help.ubuntu.com/lts/ubuntu-help/video-dvd-restricted.html

Well, just realized that the documentation is a bit wrong, GStreamer 0.1 was replaced by GStreamer 1.0

You wouldn't need to install the whole package of restricted extras (comment#3 here), but at least it gives you a hint what could be missing - like the appropriate GStreamer-packages.

Neithertheless made a bug-report on the finding, bug #1573661 (not gstreamer.01 but gstreamer1.0)

Hey,

there is a bug #1571208 (Ubuntu 16.04 doesn't contain /usr/share/doc/libdvdread4/install-css.sh) covering this.

Changed in dragon (Ubuntu):
status: Incomplete → Confirmed
Changed in dragon (Ubuntu):
importance: Undecided → High
importance: High → Medium

This bug is on purpose of the original developers.

Nevertheless if you experience it playing a non encrypted DVD, please set status back to "confirmed". Thank you.

Changed in dragon (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers