dput hard-codes path to gpg binary

Bug #1450287 reported by James Wilson on 2015-04-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
dput (Debian)
Fix Released
Unknown
dput (Ubuntu)
Undecided
Unassigned
dput-ng (Debian)
New
Unknown
dput-ng (Ubuntu)
Undecided
Unassigned

Bug Description

dput only uses /usr/bin/gpg to check signatures. If you have gpg2 (modern) installed, dput probably won't work since gpg2 introduces a new key storage location. An easy workaround is to make a copy of dput and edit the path in the script. It would be great if the gpg path could be a setting in dput.cf, much as it's possible to change the gpg path in .devscripts.

Changed in dput (Debian):
status: Unknown → New
Dmitry Lapshin (lapshin-dv) wrote :

Also, if not adding a way to change the whole path, there should be a way to pass option to use gpg2 instead. For example, debuild has -p option.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dput (Ubuntu):
status: New → Confirmed
Changed in dput-ng (Debian):
status: Unknown → New
Changed in dput (Debian):
status: New → Won't Fix
Benjamin Bach (benjaoming) wrote :

A work-around is to convert your gpg2 keyring (pubring.kbx) to a gpg (pubring.gpg) keyring and store it in your gpg home dir (~/.gnupg/). This answer explains how: http://stackoverflow.com/a/34221494/405682

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dput-ng (Ubuntu):
status: New → Confirmed
Changed in dput (Debian):
status: Won't Fix → Fix Released
Dmitry Lapshin (lapshin-dv) wrote :

So, since fix is released in Debian, will it be fixed in Ubuntu?

Mattia Rizzolo (mapreri) wrote :

fixed in debian some time ago, so closing in ubuntu as well

Changed in dput (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.