Ubuntu

Comment 2 for bug 970284

Steve Langasek (vorlon) wrote :

From the log:

> (Noting disappearance of libjpeg8:i386, which has been completely replaced.)
[...]
dpkg: dependency problems prevent configuration of libjasper1:i386:
 libjasper1:i386 depends on libjpeg8 (>= 8c).

This appears to be a duplicate of bug #902603, which is fixed in the version of dpkg in precise - but not yet fixed in the version of dpkg that was used during your upgrade from oneiric.

After encountering this error, can you confirm whether the upgrade was able to complete successfully once the new dpkg was unpacked? This will give us a better idea of whether we need to apply this fix to the dpkg in oneiric for upgrades.