Comment 14 for bug 767634

Chris Sadler (chris-g-sadler) wrote :

Hey Guys,
I've got a solution that's worked for me.. its a bit of hack but it's worked on my system and I don't think it will cause any instability for other packages, please let me know if any concerns. It's a modification of a method I saw on a fedora forum at some point...
The process I went through is as follows:

1) download Canon drivers from usual web site (.deb files)
2) extract tar to get the individual .deb packages (common and printer specific)
3) Rework the deb file so it thinks its a amd64 package
    a) go into the extracted directory, in my case /var/tmp/cnijfilter-mx860series-3.10-1-i386-deb/packages
    b) sudo dpkg-deb --extract cnijfilter-common_3.10-1_i386.deb ./tryit-common
        # this extracts the file system from the deb to the tryit-common folder
    c) change into the tryit-common folder
    d) sudo dpkg-deb --control ../cnijfilter-common_3.10-1_i386.deb
       # this extracts the control structure for the .deb file
    e ) sudo gedit DEBIAN/control
      # change the line that says Architecture : i386 to say Architecture : amd64, then save and exit
    f) cd..
        # change back into the packages directory
   g) sudo dpkg-deb --build tryit-common/
This last command should create a .deb file called try-common.deb - you can use any name for this...
the deb should then install without problems using the standard
sudo dpkg -i tryit-common.deb

Repeat the above process with the printer specific deb file... in my case the mx860 driver...
They both installed on my up to date natty intel 64 Acer aspire 5742g and the printer worked perfectely...
I've attached the drivers I created... i hope they're usefull...
Looking forward to the release of the fix in Natty though, so i don't have to hack around in terminal anymore...

Cheers,
Chris