Ubuntu

dpkg creates files with odd timestamps if statoverride matches

Reported by Marc A. Donges on 2011-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dpkg (Debian)
Fix Released
Undecided
Unassigned
dpkg (Ubuntu)
Medium
Steve Langasek

Bug Description

Binary package hint: dpkg

Package: dpkg
Version: 1.16.0~ubuntu5
Architecture: amd64

dpkg creates files with odd timestamps if a statoverride entry matches that file:

root@isis:~# aptitude reinstall mlocate

root@isis:~# ls -l /usr/bin/mlocate
-rwxr-sr-x 1 root mlocate 39464 8245921732384219680 /usr/bin/mlocate
root@isis:~# ls -l /usr/bin/mlocate
-rwxr-sr-x 1 root mlocate 39464 Mar 21 06:40 /usr/bin/mlocate
root@isis:~# aptitude reinstall mlocate

root@isis:~# ls -l /usr/bin/mlocate
-rwxr-sr-x 1 root mlocate 39464 8245921732384219680 /usr/bin/mlocate

Raphaël Hertzog (hertzog) wrote :

Thanks for the report, I have fixed this in the upstream repository (commit 6a7a20c72325a57762e34f5dbb9f79ba73b5d496). It's Ubuntu-specific at this point because the regression has been introduced in the 1.16 development cycle.

(I mark this bug as fix released and not fix committed because I have no Debian bug to track)

Changed in dpkg (Debian):
status: New → Fix Released
Changed in dpkg (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Steve Langasek (vorlon) on 2011-03-24
Changed in dpkg (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Steve Langasek (vorlon)
milestone: none → ubuntu-11.04-beta-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dpkg - 1.16.0~ubuntu6

---------------
dpkg (1.16.0~ubuntu6) natty; urgency=low

  * Dpkg/Shlibs.pm: we should explicitly prepend the appropriate multiarch
    paths to our library search path. These would be picked up later on
    anyway in the case of a native build, but for, e.g., bootstrapping a
    cross-toolchain the needed multiarch paths aren't going to be found in
    ld.so.conf.
  * Cherry-pick fixes from upstream:

  [ Raphaël Hertzog ]
  * 7ea2064c46b77398a63d7f7a543ebcf08f7c74d2: Fix dpkg-source's regression
    with empty patches (introduced while fixing 613023). Closes: #619541,
    LP: #742124.
  * 6a7a20c72325a57762e34f5dbb9f79ba73b5d496: Use the correct mtime when
    installing a file with statoverrides. LP: #739179.
 -- Steve Langasek <email address hidden> Thu, 24 Mar 2011 17:04:47 -0700

Changed in dpkg (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers