debian/source/include-binaries doesn't allow for inclusion of modified binaries

Bug #633015 reported by Dave Walker on 2010-09-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dpkg
Fix Released
Unknown
dpkg (Ubuntu)
Undecided
Dave Walker
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: dpkg

Overriding an upstream binary, using deb src 3.0 doesn't work as advertised (ie, you can't). For further information, follow the debian bug where it has been tracked.

=== SRU Justification ===
IMPACT: This issue is causing deb src 3.0 packages to not be able to build on the current LTS (Lucid). The Ubuntu buildd's are based on that, and it's reasonable to assume that other developers will be.
FIXED: This has been fixed in upstream git, Debian testing and had getting close to a month exposure in Maverick.
PATCH: Based on Lucid patch (attached)
TEST CASE: With any Deb Src 3.0 package shipping a binary (ie image) - attempt to override it using deb src 3.0 methods and build a source package.
REGRESSION POTENTIAL: This would seem to be low, upstream believe it was doing the wrong thing - and refer to the option this upload fixes as previously useless.

For more info: https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2010-September/012089.html

Dave Walker (davewalker) on 2010-09-08
Changed in dpkg (Ubuntu):
status: New → Confirmed
assignee: nobody → Dave Walker (davewalker)
Dave Walker (davewalker) wrote :
description: updated
Dave Walker (davewalker) wrote :

And now with added flavor. (LP bug number in debian/changelog).

Dave Walker (davewalker) wrote :

Now featuring buy one dsc get a debdiff free.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dpkg - 1.15.8.4ubuntu3

---------------
dpkg (1.15.8.4ubuntu3) maverick; urgency=low

  * scripts/Dpkg/Source/Archive.pm: Drop -k parameter from the tar call used
    by dpkg-source to extract tarballs. Upstream binary files modified by the
    packager were not properly installed due to this. Patch courtesy of
    Raphaël Hertzog (upstream, debian git). (LP: #633015)
 -- Dave Walker (Daviey) <email address hidden> Wed, 08 Sep 2010 10:17:20 +0100

Changed in dpkg (Ubuntu):
status: Confirmed → Fix Released
Dave Walker (davewalker) on 2010-10-01
description: updated
Dave Walker (davewalker) on 2010-10-01
description: updated

Accepted dpkg into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in dpkg (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Changed in dpkg:
status: Unknown → Fix Released
Dave Walker (davewalker) wrote :

RE: SRU

I can confirm the -proposed packages resolves this issue in Lucid.

It might be a good idea for someone else to separately verify this -proposed package before changing the tag. The process to test is to grab a package that has a binary file (foo) in the orig tarball... dpkg-source -x it, overwrite the upstream binary in the extracted location; and echo "foo" > debian/source/include-binaries.

I have a sample package this can be proved against if needed.

The LP generated diff concerns me somewhat, but seems to be a LP bug.... see below:

<Daviey> lifeless / maxb: https://launchpad.net/ubuntu/lucid/+source/dpkg/1.15.5.6ubuntu4.4
<Daviey> The diff LP has generated is: http://launchpadlibrarian.net/57004735/dpkg_1.15.5.6ubuntu4.2_1.15.5.6ubuntu4.4.diff.gz
<Daviey> which is against *4.2
<Daviey> https://launchpad.net/ubuntu/+source/dpkg/1.15.5.6ubuntu4.2/+publishinghistory <--- is odd
<Daviey> *.1 is marked Superseded by 4.3 !
<Daviey> *.2 isn't marked superseeded, just deleted with the comment "moved to -updates"
<Daviey> The debian/changelog for 4.3 doesn't mention 4.1 (oddly)
<Daviey> In any case, LP is giving an incorrect diff to me.... :/
<Daviey> (if you debdiff 4.3 and 4.4, you get the diff i expected.
<Daviey> ^^ Downloading the .dsc's from launchpad.
<maxb> Daviey: 4.3 was a security update
<maxb> Therefore, at the time 4.4 was uploaded to proposed, it's possibly that 4.2 was still the latest in the updates pocket?
* maxb curses at the difficulty of finding a link to https://launchpad.net/ubuntu/+source/dpkg/+publishinghistory, and manually composes the URL
<maxb> hmm, apparently not, 4.3 was copied to updates long before 4.4 hit proposed
<maxb> oh, gah, I bet LP saw that there was an earlier dpkg in lucid-proposed, and didn't check other pockets

Martin Pitt (pitti) on 2010-11-25
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dpkg - 1.15.5.6ubuntu4.4

---------------
dpkg (1.15.5.6ubuntu4.4) lucid-proposed; urgency=low

  * scripts/Dpkg/Source/Archive.pm: Drop -k parameter from the tar call used
    by dpkg-source to extract tarballs. Upstream binary files modified by the
    packager were not properly installed due to this. Patch based on that of
    Raphaël Hertzog (upstream, debian git). (LP: #633015)
 -- Dave Walker (Daviey) <email address hidden> Sat, 02 Oct 2010 00:30:53 +0100

Changed in dpkg (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.