Ubuntu

dpkg parse error caused by virtual box entry

Reported by Conor Curran on 2010-08-03
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
dpkg (Debian)
Fix Released
Unknown
dpkg (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: dpkg

When doing a dist-upgrade this morning I encountered a dpkg parse error due to the virtual box entry.

the trace from sudo apt-get dist-upgrade was

Preconfiguring packages ...
dpkg: parse error, in file '/var/lib/dpkg/status' near line 52358 package 'virtualbox-3.1':
 error in Version string `3.1.2-56127_Ubuntu_karmic': invalid character in revision number

To work around this I had to edit /var/lib/dpkg/status and /var/lib/dpkg/available and replace "3.1.2-56127_Ubuntu_karmic" with "3.1.2-56127ubuntukarmic"

Sebastien Bacher (seb128) wrote :

Thanks Conor, I'm subscribing Colin to the bug since the worked on the recent update

berg (berg-foss) on 2010-08-03
Changed in dpkg (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

This was introduced by the following change in dpkg 1.15.8
 * Check version syntax when parsing it from libdpkg based programs.
    Closes: #574704

git commit: http://git.debian.org/?p=dpkg/dpkg.git;a=commitdiff;h=662d979

setting to triaged / high

Changed in dpkg (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in dpkg (Debian):
status: Unknown → New
Colin Watson (cjwatson) wrote :

Fixed in dpkg 1.15.8.4ubuntu1, just uploaded.

dpkg (1.15.8.4) unstable; urgency=low

  [ Guillem Jover ]
  [...]
  * On database parsing only warn on bogus versions previously accepted,
    the other instances will keep producing errors, to avoid newly
    introduced bogosity. Closes: #590885, #590896, #591692, #591885

Changed in dpkg (Ubuntu):
status: Triaged → Fix Released
Changed in dpkg (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.