problem installing large deb packages

Bug #370910 reported by J.D. on 2009-05-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dpkg (Ubuntu)
Undecided
Unassigned

Bug Description

I tired rolling my own linux kernel image using the "old" Ubuntu process to roll an image. Anyways, the first time I compiled the kernel, I did it with kernel debugging features turned on. The resulting deb package for linux-image was 255Mb. When I went to install it with dpkg, I got an error that the compressed package was corrupted or something like that. I don't remember what the exact error was. I deleted the deb package, ran 'make-kpkg clean', and recompiled thinking that something went wrong during the package creation. But the same error happened again.

Then, just taking a wild guess that the deb package size was the problem, I recompiled the kernel with the debugging stuff turned off in the Kernel Hacking menu area. The resulting deb package this time was obviously much, much smaller - 25Mb. And it installed just fine with dpkg.

Can anyone else confirm this problem? Here are possible factors on my system,

1) I'm running a stock 9.04 Ubuntu WITH an ext4 file system. I thought one of the strengths of ext4 was the ability to handle large files. I didn't think 255Mb was all that large.
2) Could this be a problem with tar or whatever is handling the compression of the internals of the package? I doubt it since tar and the other supporting tools are older than dirt.
3) Possible problem with dpkg and large deb packages?

I don't think this is a hardware problem with my system. I forced a disk check and also ran memtest and my system checked out fine.

I will happily recompile the kernel with the debug symbols in to get the exact error message if its required. I would like to see if someone else can reproduce this error on an ext4 system.

System:
Linux ascension 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
Ubuntu 2.6.28-11.42-generic

Revision history for this message
J.D. (yamokosk) wrote :
Revision history for this message
Rickard Närström (riccetn) wrote :

This report is almost a year old, the original reporter may no longer monitor this report for changes.

affects: ubuntu → dpkg (Ubuntu)
Revision history for this message
Raphaël Hertzog (hertzog) wrote :

Can you try again with a more recent dpkg version like the one in oneiric?

We had bugs with packages bigger than 2Gb but they have been fixed upstream recently. Marking is a fix released in the mean time but if you can still reproduce the problem, feel free to reopen it (or to file a new one).

Changed in dpkg (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments