7.10 to 8.04 upgrade fails

Bug #233975 reported by janwill on 2008-05-22
4
Affects Status Importance Assigned to Milestone
dpkg (Ubuntu)
Undecided
Ralph Janke
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

When upgrading from 7.10 desktop to 8.04 I got the following error from update manager:

'E:Problem parsing dependency Depends, E:Error occurred while processing hal (NewVersion1), E:Problem with MergeList /var/lib/dpkg/status, E:The package lists or status file could not be parsed or opened

The last lines of apt.log are:
Investigating ubuntu-desktop
Package ubuntu-desktop has broken dep on pulseaudio-esound-compat
  Considering pulseaudio-esound-compat 0 as a solution to ubuntu-desktop 0
  Removing ubuntu-desktop rather than change pulseaudio-esound-compat
Done
Installing pulseaudio-esound-compat as dep of ubuntu-desktop
Setting NOT as auto-installed (direct dep of pkg in APT::Never-MarkAuto-Section)

Main.log:
2008-05-22 12:04:25,415 INFO release-upgrader version '0.87.27' started
2008-05-22 12:04:26,043 DEBUG svg pixbuf loader failed (Error displaying image)
2008-05-22 12:04:26,162 DEBUG Using 'DistUpgradeViewGtk' view
2008-05-22 12:04:26,267 DEBUG enable dpkg --force-overwrite
2008-05-22 12:04:26,481 DEBUG lsb-release: 'gutsy'
2008-05-22 12:04:26,482 DEBUG _pythonSymlinkCheck run
2008-05-22 12:04:29,387 DEBUG checkViewDepends()
2008-05-22 12:04:29,388 DEBUG running doUpdate() (showErrors=False)
2008-05-22 12:04:33,477 DEBUG doPreUpgrade
2008-05-22 12:04:35,197 DEBUG Foreign:
2008-05-22 12:04:35,198 DEBUG Obsolete: gaim-data libnspr4 linux-headers-2.6.20-15-generic skype libwvstreams4.2-extras libgpod1 libdevmapper1.02 libiw28 libisc11 libgs-esp8 libjasper-1.701-1 linux-restricted-modules-2.6.20-15-generic linux-headers-2.6.20-16 linux-headers-2.6.20-15 desktop-effects libdns22 libdvdcss2 libtotem-plparser1 libpoppler1 libsnmp9 linux-restricted-modules-2.6.20-16-generic linux-image-2.6.20-15-generic libgcj7-0 libisccfg1 libisccc0 w32codecs libwvstreams4.2-base libpoppler1-glib picasa libbind9-0 libflac7 linux-image-2.6.20-16-generic linux-headers-2.6.20-16-generic liblwres9 bluez-pin
2008-05-22 12:04:35,199 DEBUG updateSourcesList()
2008-05-22 12:04:35,316 DEBUG rewriteSourcesList()
2008-05-22 12:04:35,321 DEBUG examining: 'deb http://se.archive.ubuntu.com/ubuntu/ gutsy main restricted'
2008-05-22 12:04:35,322 DEBUG entry 'deb http://se.archive.ubuntu.com/ubuntu/ hardy main restricted' updated to new dist
2008-05-22 12:04:35,322 DEBUG examining: 'deb-src http://se.archive.ubuntu.com/ubuntu/ gutsy main restricted'
2008-05-22 12:04:35,322 DEBUG entry 'deb-src http://se.archive.ubuntu.com/ubuntu/ hardy main restricted' updated to new dist
2008-05-22 12:04:35,322 DEBUG examining: 'deb http://se.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted multiverse universe'
2008-05-22 12:04:35,322 DEBUG entry 'deb http://se.archive.ubuntu.com/ubuntu/ hardy-updates main restricted multiverse universe' updated to new dist
2008-05-22 12:04:35,323 DEBUG examining: 'deb-src http://se.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted'
2008-05-22 12:04:35,323 DEBUG entry 'deb-src http://se.archive.ubuntu.com/ubuntu/ hardy-updates main restricted' updated to new dist
2008-05-22 12:04:35,323 DEBUG examining: 'deb http://se.archive.ubuntu.com/ubuntu/ gutsy universe'
2008-05-22 12:04:35,323 DEBUG entry 'deb http://se.archive.ubuntu.com/ubuntu/ hardy universe' updated to new dist
2008-05-22 12:04:35,323 DEBUG examining: 'deb-src http://se.archive.ubuntu.com/ubuntu/ gutsy universe'
2008-05-22 12:04:35,324 DEBUG entry 'deb-src http://se.archive.ubuntu.com/ubuntu/ hardy universe' updated to new dist
2008-05-22 12:04:35,324 DEBUG examining: 'deb http://se.archive.ubuntu.com/ubuntu/ gutsy multiverse'
2008-05-22 12:04:35,324 DEBUG entry 'deb http://se.archive.ubuntu.com/ubuntu/ hardy multiverse' updated to new dist
2008-05-22 12:04:35,324 DEBUG examining: 'deb-src http://se.archive.ubuntu.com/ubuntu/ gutsy multiverse'
2008-05-22 12:04:35,325 DEBUG entry 'deb-src http://se.archive.ubuntu.com/ubuntu/ hardy multiverse' updated to new dist
2008-05-22 12:04:35,325 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu gutsy-security main restricted'
2008-05-22 12:04:35,325 DEBUG entry 'deb http://security.ubuntu.com/ubuntu hardy-security main restricted' updated to new dist
2008-05-22 12:04:35,325 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted'
2008-05-22 12:04:35,326 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted' updated to new dist
2008-05-22 12:04:35,326 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu gutsy-security universe'
2008-05-22 12:04:35,326 DEBUG entry 'deb http://security.ubuntu.com/ubuntu hardy-security universe' updated to new dist
2008-05-22 12:04:35,326 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu gutsy-security universe'
2008-05-22 12:04:35,326 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu hardy-security universe' updated to new dist
2008-05-22 12:04:35,327 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu gutsy-security multiverse'
2008-05-22 12:04:35,327 DEBUG entry 'deb http://security.ubuntu.com/ubuntu hardy-security multiverse' updated to new dist
2008-05-22 12:04:35,327 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse'
2008-05-22 12:04:35,327 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse' updated to new dist
2008-05-22 12:04:35,368 DEBUG running doUpdate() (showErrors=True)
2008-05-22 12:05:02,856 DEBUG Running KeepInstalledSection rules
2008-05-22 12:05:03,004 DEBUG Removing 'xscreensaver' (ubuntu-desktop PostUpgradeRemove rule)
2008-05-22 12:05:03,195 DEBUG Removing 'gnome-cups-manager' (ubuntu-desktop PostUpgradeRemove rule)
2008-05-22 12:05:03,389 DEBUG Purging 'xorg-common' (Distro PostUpgradePurge rule)
2008-05-22 12:05:03,389 DEBUG Purging 'libgl1-mesa' (Distro PostUpgradePurge rule)
2008-05-22 12:05:03,389 DEBUG Purging 'ltsp-client' (Distro PostUpgradePurge rule)
2008-05-22 12:05:03,583 DEBUG Purging 'ltspfsd' (Distro PostUpgradePurge rule)
2008-05-22 12:05:03,779 DEBUG Purging 'python2.3' (Distro PostUpgradePurge rule)
2008-05-22 12:05:03,780 DEBUG running hardyQuirks handler
2008-05-22 12:05:03,780 DEBUG running _checkAndRemoveEvms
2008-05-22 12:05:03,913 DEBUG Kernel uname: '2.6.22-14-generic'
2008-05-22 12:05:04,359 DEBUG Marking 'ubuntu-desktop' for upgrade
2008-05-22 12:05:05,869 DEBUG About to apply the following changes
2008-05-22 12:05:06,179 DEBUG Held-back:
2008-05-22 12:05:06,180 DEBUG Remove: x11perf listres volumeid xclock xdpyinfo restricted-manager libcompizconfig-backend-gconf xsm xset xmodmap xprop xhost restricted-manager-core smproxy xmore xrgb xgamma xkbutils xrefresh xconsole xwud xman xmag xev libgnomekbdui1 appres xwininfo libgnomekbd1 xsetmode xditview python-pygtksourceview xvidtune xlsatoms viewres xlogo xsetpointer esound xeyes system-config-printer xvinfo libnl1-pre6 xfontsel xlsclients xcalc xdriinfo xcursorgen xwd xtrap kaffeine-xine xmessage xload xlsfonts xkill xrandr fstobdf iceauth xrdb oclock editres xstdcmap xbiff python-orca-brlapi xclipboard xfd sessreg gimp-print libopenexr2c2a xsetroot
2008-05-22 12:05:06,180 DEBUG Install: policykit libarchive1 pm-utils linux-headers-2.6.24-16-generic x11-session-utils sqlite libpth20 libcdio-cdda0 libmono-system-web1.0-cil pulseaudio-module-gconf libpolkit2 libdirectfb-1.0-0 libx264-57 libpt-1.10.10-plugins-v4l libtotem-plparser10 gvfs-backends libggz2 libflickrnet2.1.5-cil libicu38 im-switch libxine1-ffmpeg libsnmp15 hwtest ttf-sil-gentium xserver-xorg-video-geode libbrlapi0.5 libiso9660-5 libwildmidi0 libsoup2.4-1 libglew1.5 libgif4 scim-bridge-agent xserver-xorg-input-vmmouse libsmbios1 nautilus-share libxcb-xlib0 libbeagle1 language-support-translations-en x11-apps libx11-xcb1 system-config-printer-common seahorse libxine1-misc-plugins libpulse-browse0 uuid-runtime totem-common libpulsecore5 vlc-plugin-pulse libopencdk10 hwtest-gtk libpolkit-dbus2 acl xulrunner-1.9 libpisync1 libgtkhtml3.16-cil openoffice.org-officebean libcdio7 libsamplerate0 transmission-common jockey-gtk openoffice.org-filter-binfilter system-config-printer-gnome libwvstreams4.4-base libgweather-common linux-ubuntu-modules-2.6.24-16-generic pulseaudio gimp-gnomevfs libtimedate-perl libgnomekbdui2 iamerican totem-plugins libsgutils1 gvfs-fuse gimp-help-en ubuntu-gdm-themes libneon27 obex-data-server libgraphviz4 libgnomekbd2 linux-restricted-modules-2.6.24-16-generic mlocate dbus-x11 libcamel1.2-11 gcc-4.2 libck-connector0 python-brlapi xserver-xorg-video-openchrome libconfig-tiny-perl transmission-gtk libmagick10 libexempi3 libmono-system-data1.0-cil x11-xserver-utils libmono-sharpzip0.84-cil ibritish libnl1 scim-bridge-client-gtk libiptcdata0 linux-headers-2.6.24-16 python-4suite-xml libntfs-3g23 libfaad0 language-support-writing-en libtaglib2.0-cil gstreamer0.10-pulseaudio libpt-1.10.10-plugins-alsa libopenexr2ldbl libffi4 policykit-gnome libxklavier12 firefox-3.0-gnome-support python-gdata libgpod3 libmono-addins0.2-cil libgdata1.2-1 cpp-4.2 libnss3-1d pulseaudio-module-x11 libopenobex1 ispell libmtp7 python-imaging cupsddk-drivers libavahi-ui0 libenca0 compizconfig-backend-gconf libgpgme11 libpolkit-gnome0 python-gtksourceview2 pulseaudio-utils libcwidget3 liboobs-1-4 libpolkit-grant2 brasero mdetect libxine1-console libgmyth0 gnome-settings-daemon pulseaudio-esound-compat lzma libgtk-vnc-1.0-0 libchromexvmc1 netcat-traditional ufw libsqlite0 libuniconf4.4 jockey-common libgalago3 linux-image-2.6.24-16-generic bluez-audio xulrunner-1.9-gnome-support openoffice.org-thesaurus-en-au libmono-addins-gui0.2-cil libxine1-bin sqlite3 libldap-2.4-2 libgpod-common libmono1.0-cil libavahi1.0-cil mousetweaks cupsddk liblaunchpad-integration1 python-pysqlite2 ubuntu-wallpapers libxine1-x libclamav3 openoffice.org-help-en-gb libotr2 pidgin-otr libchromexvmcpro1 x11-utils gvfs g++-4.2 libgd2-noxpm libgvfscommon0 libggzmod4 libcdio-paranoia0 libgomp1 libdb4.6 x11-xkb-utils pulseaudio-module-hal libgweather1 gtk2-engines-murrine python-pyatspi libstdc++6-4.2-dev gimp-help-common libpixman-1-0 libxine1-plugins libgalago1.0-cil libggzcore9 libpt-1.10.10-plugins-v4l2 bash-completion openoffice.org-base-core python-reportlab libwvstreams4.4-extras libmono-data-tds1.0-cil libmono-security1.0-cil libgsl0ldbl firefox-3.0 libgdata-google1.2-1 friendly-recovery x11-xfs-utils libsvga1 vinagre libpt-1.10.10 openoffice.org-writer2latex
2008-05-22 12:05:06,181 DEBUG Upgrade: bluez-gnome libbz2-1.0 libsane gnome-terminal splix hal esound-common wvdial xfonts-base grsync python2.5-minimal xserver-xorg-video-rendition base-files libglu1-mesa xserver-xorg-video-vesa libgtk2.0-bin libid3-3.8.3c2a libgnome-mag2 xserver-xorg-video-sis hostname gnome-applets-data gparted grub udev libmono-system1.0-cil libfaad2-0 pcmciautils sound-juicer dhcdbd python-launchpad-bugs libgnome-vfs2.0-cil kdemultimedia-kio-plugins unixodbc readahead util-linux-locales gnome-applets libegroupwise1.2-13 libc6-dev libuuid1 libgksu2-0 wpasupplicant libdevmapper1.02.1 libungif4g libmono-system-web2.0-cil libmono-system2.0-cil libss2 libgnomecanvas2-0 example-content libgmp3c2 xsane-common libavutil1d libgcj7-1 totem powermanagement-interface gstreamer0.10-plugins-bad python-gtk2 openoffice.org-evolution libkpathsea4 libsasl2-2 gtk2-engines login compiz-plugins dvd+rw-tools libtrackerclient0 libgmime2.2-cil libgcrypt11 libatk1.0-0 bzip2 libglib2.0-cil librpc-xml-perl xfonts-75dpi ltrace cdparanoia hplip-data xserver-xorg-video-i740 xserver-xorg-video-s3virge gnome-media libvcdinfo0 klogd launchpad-integration ssh-askpass-gnome upstart-logd librecode0 brltty libavformat1d libvisual-0.4-0 docbook-xml hwdb-client-gnome libxrender1 libice6 kget libsqlite3-0 python-vte liblircclient0 xserver-xorg fast-user-switch-applet liblwres30 tzdata xserver-xorg-video-neomagic openoffice.org-base grep libgnome2-common libgnome2-0 libgtksourceview2.0-common libnm-util0 python-gnomecanvas libwnck22 libwnck-common apport-gtk libgphoto2-2 netcat libnss3-0d kaffeine libexpat1 bluez-utils gnome-games python-gtkhtml2 ttf-dejavu-extra gimp libgucharmap6 scim-modules-socket libusb-0.1-4 wodim gstreamer0.10-gnomevfs gnome-system-monitor linux-restricted-modules-common e2fslibs gnome-terminal-data xserver-xorg-video-siliconmotion human-theme gnome-doc-utils language-selector libaudiofile0 libgtk2-perl hpijs libscrollkeeper0 libdb4.3 libdb4.2 libdb4.5 libdb4.4 xserver-xorg-video-trident language-support-en upstart-compat-sysv xdg-user-dirs libncurses5 procps librsvg2-common gettext-base gnome-panel-data notification-daemon perl-modules libgda3-common gcc-4.2-base python-gdbm cupsys-client gstreamer0.10-plugins-good passwd xinit fontconfig libmetacity0 coreutils libgsf-1-114 ca-certificates iputils-tracepath gnome-volume-manager gconf2-common libvte-common libxml2-utils belocs-locales-bin python-sip4 libgcj-bc libbluetooth2 xserver-xorg-video-apm dselect libxi6 nautilus-sendto libglib-perl bsdmainutils libebook1.2-9 pidgin-data locales gstreamer0.10-alsa libwpg-0.1-1 libpam-modules libgpmg1 xserver-xorg-video-imstt gnome-screensaver openoffice.org-writer language-pack-gnome-en foomatic-filters libacl1 keepassx python-notify libsdl-image1.2 mysql-common libpurple0 python-glade2 discover1 libaspell15 libuser1 gnome-user-guide evolution-common update-manager libaa1 xauth cupsys-bsd libxerces2-java libpcre3 dictionaries-common xfonts-utils gnome-pilot iso-codes automake libquicktime1 xserver-xorg-video-savage discover1-data xserver-xorg-input-evdev gpgv compiz-core gsfonts liboil0.3 gij-4.1 gij-4.2 python-evolution vbetool gnome-orca dhcp3-common libglade2.0-cil apt libgnomevfs2-extra aspell odbcinst1debian1 ubuntu-artwork sysv-rc g++ libgnome-media0 libsigc++-2.0-0c2a libexif12 x11-common libx11-data doc-base wine whiptail linux-libc-dev netbase gnome-games-data gnome-utils genisoimage gstreamer0.10-plugins-bad-multiverse libxml-twig-perl gutsy-wallpapers libxcb-shm0 hwdb-client-common xserver-xorg-video-cyrix libgdiplus libbonobo2-0 libtheora0 libgutenprint2 debianutils libcairo-perl cpp libmono-cairo1.0-cil libmysqlclient15off libjline-java pidgin initramfs-tools nvidia-glx gamin xserver-xorg-video-chips libgnutls13 libparted1.7-1 xserver-xorg-video-amd gcjwebplugin sed openoffice.org-thesaurus-en-us libnewt0.52 bc xserver-xorg-video-vga unzip gstreamer0.10-esd bogofilter gcalctool debconf-i18n libbonoboui2-common python libsasl2-modules libavahi-core5 libpng12-0 libesd-alsa0 gnome-menus libx11-6 libmono-sqlite2.0-cil mono-common libndesk-dbus-glib1.0-cil acpi-support libxfont1 libqt3-mt python-xml findutils libiw29 dc openoffice.org-l10n-en-gb libdc1394-13 module-init-tools gtk2-engines-pixbuf libgs8 tcpdump libgcc1 libwxgtk2.6-0 ubufox gstreamer0.10-ffmpeg ed libcurl3 libgdl-1-common ubuntu-standard nvidia-kernel-common libbit-vector-perl libedata-book1.2-2 apport dosfstools dnsutils libmp4v2-0 totem-mozilla evolution-exchange libraw1394-8 bash gedit libgoocanvas3 libxcb-shape0 python-problem-report xserver-xorg-video-sisusb xserver-xorg-video-glint freeglut3 libdatrie0 libpcap0.8 xkb-data xterm libsoundtouch1c2 nvclock xserver-xorg-input-kbd libtasn1-3 alsa-utils sudo libasound2 libgstreamer0.10-0 klibc-utils libhal-storage1 acpid libgnome2.0-cil mono-runtime gcj-4.1-base mplayer python-apport evolution libmono-system-data2.0-cil python-vobject linux-headers-generic mono-gac xserver-xorg-video-voodoo brltty-x11 usplash-theme-ubuntu libgdl-1-0 libgnomekbd-common libebml0 gnupg update-notifier-common libavahi-common-data tracker libglibmm-2.4-1c2a libcucul0 gnome-control-center libjack0 libsmbclient libneon26 libwpd8c2a libisc32 libatspi1.0-0 lsb-release whois toshset libxmu6 flashplugin-nonfree libogg0 gnomebaker libmono-sharpzip2.84-cil cupsys-common ttf-dejavu libdbus-glib-1-2 libwww-perl libxcursor1 libdeskbar-tracker rss-glx sun-java6-jre mime-support beagle guidance-backends gnome-panel libgail-gnome-module cdrdao iputils-arping libtiff4 libssl0.9.8 xfonts-encodings cron python-minimal liba52-0.7.4 system-services gcc-4.1 ncurses-base linux-sound-base software-properties-gtk debconf at-spi libgnomeprint2.2-0 gnome-system-tools libavahi-client3 xserver-xorg-video-ark libstdc++6-4.1-dev libgtkhtml2-0 libisccfg30 xvnc4viewer python-launchpad-integration ntfs-3g m4 libpam-gnome-keyring xserver-xorg-video-tga libhsqldb-java xserver-xorg-video-newport hplip-gui libkeyutils1 libattr1 hplip apt-utils openssl-blacklist linux-restricted-modules-generic libxcb1 libusplash0 librsvg2-2 command-not-found-data xserver-xorg-video-v4l libieee1284-3 libgstreamer-plugins-base0.10-0 gstreamer0.10-x proftpd libnautilus-burn4 gnome-mag libpango1.0-0 libncursesw5 myspell-en-za gnome-session python-dbus libarts1c2a libsepol1 avahi-autoipd unattended-upgrades perl-base command-not-found libavahi-common3 libgtkhtml3.8-15 libxrandr2 libexchange-storage1.2-3 update-notifier libpaper1 alacarte bogofilter-bdb libshout3 xserver-xorg-input-elographics gnome-accessibility-themes openoffice.org-draw libx86-1 xpmutils libcairomm-1.0-1 fuse-utils mktemp libdecoration0 slocate apturl unison libgnome-speech7 classpath myspell-en-gb libgnome2-vfs-perl libdvdread3 libgnomecups1.0-1 libpisock9 scim gnome-cards-data libgtk2.0-cil ubuntu-docs libscim8c2a xbase-clients ethtool libltdl3 xserver-xorg-video-s3 liborbit2 libpostproc1d screen libnautilus-extension1 libselinux1 libgconf2-4 libgtkhtml3.14-19 libcompizconfig0 gedit-common samba-common gproftpd ssl-cert libopenal0a libxaw7 openoffice.org-java-common xserver-xorg-input-wacom dpkg ttf-arphic-uming libgnomevfs2-bin python-gnome2-desktop libgnome-desktop-2 binutils libsvg1 libpulse0 console-terminus compiz-fusion-plugins-extra libnet-dbus-perl libdbus-1-3 libgtk2.0-common libgmime-2.0-2 mesa-utils cpp-4.1 libcurl3-gnutls cups-pdf libxpm4 ucf libavahi-compat-libdnssd1 gdebi-core java-common xsltproc scim-modules-table ttf-mgopen xserver-xorg-video-tdfx xscreensaver-data gstreamer0.10-plugins-ugly libidl0 evolution-webcal libmagic1 python-gnome2 gconf2 ekiga python-gobject cupsys-driver-gutenprint poppler-utils xserver-xorg-video-via zenity libgphoto2-port0 python-cups libxtst6 openoffice.org-filter-mobiledev classpath-gtkpeer xfonts-100dpi tracker-search-tool nano capplets-data wamerican nautilus libxcb-xv0 dvd95 clamav-base xutils xdg-utils libjaxp1.3-java libgsf-1-common libcdparanoia0 openoffice.org-calc gnome-themes libgnome-window-settings1 libsdl1.2debian alsa-base ubuntu-minimal libpaper-utils xserver-xorg-video-i128 libavahi-glib1 libsensors3 gksu evolution-data-server-common compiz libpcrecpp0 libbonobo2-common libswt3.2-gtk-jni gnome-desktop-data libedit2 openoffice.org-style-human vlc-nox xserver-xorg-video-nv xdg-user-dirs-gtk libgnome-keyring0 clamav xserver-xorg-video-fbdev zlib1g libgda2-common libcomerr2 evolution-data-server foomatic-db-hpijs libgcj8-1 espeak-data xserver-xorg-video-vmware libfontconfig1 libart-2.0-2 libgcj-common util-linux libgconf2.0-cil libmodplug0c2 libcupsimage2 grip metacity-common gtkhtml3.14 libgnomevfs2-common file makedev openoffice.org-math sun-java6-bin xserver-xorg-video-all python-virtkey pciutils gpar2 mono-jit net-tools conduit desktop-file-utils python-pygoocanvas gcj-4.2-base openoffice.org-impress librarian0 libart2.0-cil gthumb libecal1.2-7 vlc libc6-i686 python2.5 linux-generic python-dateutil gnome-nettool libgtop2-7 clamtk compiz-fusion-plugins-main ttf-gentium dbus libgail18 groff-base gnome-icon-theme myspell-en-us sysvutils cupsys mcpp displayconfig-gtk libwxbase2.6-0 python-numeric compiz-gnome parted xserver-xorg-video-intel xserver-xorg-video-ati bsh f-spot libkcddb1 gij libtracker-gtk0 libslang2 xserver-xorg-video-nsc gs-esp python-libuser xorg python-gst0.10 psmisc openoffice.org-gnome fontconfig-config openoffice.org gstreamer0.10-plugins-base-apps x-ttcidfont-conf libvorbis0a xscreensaver-gl gnome-keyring mount rhythmbox liblcms1 samba linux-image-generic libgtk2.0-0 libgnomeprintui2.2-common python-bittorrent libxmuu1 xsane language-pack-gnome-en-base console-setup libmono-data-tds2.0-cil libgtop2-common gcc-4.1-base startup-tasks man-db python-libxml2 firefox-gnome-support libgtkmm-2.4-1c2a gucharmap busybox-initramfs libvorbisenc2 tomboy libservlet2.3-java libgnome-pilot2 libspeex1 mozilla-firefox-locale-en-gb libespeak1 scrollkeeper python-uno gnome-mount consolekit clamav-freshclam libcarp-clan-perl libartsc0 vim-tiny gaim nautilus-cd-burner tango-icon-theme apparmor kdf initscripts gnome-power-manager bittorrent tsclient gstreamer0.10-plugins-base libklibc libgda3-3 gzip hotkey-setup sysklogd openssh-client update-inetd libgtkspell0 gimp-python libxcomposite1 gnome-about gstreamer0.10-tools libpam-runtime libpango1.0-common libkrb53 libpar2-0 tasksel-data cli-common iproute libhunspell-1.1-0 libxvidcore4 libstdc++5 libstdc++6 manpages gdb libqt4-gui gdm libgpg-error0 liblualib50 totem-gstreamer libedataserver1.2-9 e2fsprogs openoffice.org-l10n-common system-tools-backends liblocale-gettext-perl wireless-tools python-pyorbit human-icon-theme rdesktop libeel2-2 libnspr4-0d upstart metacity bluez-cups popularity-contest laptop-mode-tools libedataserverui1.2-8 bind9-host g++-4.1 file-roller nautilus-data firefox xserver-xorg-input-mouse app-install-data-commercial libidn11 hdparm libopal-2.2 libdiscover1 libgnome-menu2 libhal1 libgda2-3 language-selector-common libxml2 vim-common less eog gtk2-engines-ubuntulooks python-gconf libxxf86dga1 python-support libavahi-qt3-1 libsdl1.2debian-alsa iputils-ping libmono-corlib1.0-cil libqt4-core libgoocanvas-common onboard libgnomecanvas2-common openoffice.org-common classpath-common usplash libgnome2-canvas-perl tasksel bogofilter-common libgksu1.2-1 bug-buddy gcc-3.3-base openoffice.org-gtk gnome-btdownload dmsetup python-software-properties libsnmp-base powernowd libblkid1 ttf-thai-tlwg libdns32 espeak autotools-dev xserver-xorg-input-all libcairo2 libgutenprintui2-1 gs-esp-x xserver-xorg-input-synaptics libgamin0 gconf-editor gnome-media-common info hal-info libbonoboui2-0 gimp-data gdebi libisccc30 lshw kdelibs4c2a libgdl-gnome-1-0 kdelibs-data ttf-dejavu-core libpoppler2 shared-mime-info feisty-gdm-themes language-pack-en libgc1c2 gnome-app-install ttf-opensymbol libmms0 xserver-xorg-video-i810 libtag1c2a libxine1 ncurses-bin network-manager libpq5 libmono2.0-cil libmono-corlib2.0-cil libgnomeprintui2.2-0 xserver-xorg-video-mga python-gnome2-extras binutils-static mtr-tiny base-passwd update-manager-core avahi-daemon libfribidi0 ghostscript perl gs-common libconsole libsysfs2 dash libavcodec1d python-libgmail libgnomeui-common libxslt1.1 ttf-arphic-ukai icedax aptitude python-xdg libgl1-mesa-glx python-central libgail-common libfuse2 libxalan2-java libfreebob0 xserver-xorg-video-dummy gnome-pilot-conduits libwps-0.1-1 vino libnss-mdns liblua50 libaudio2 xserver-xorg-core openoffice.org-core libvlc0 libc6 serpentine dhcp3-client language-pack-en-base python-gmenu lftp foomatic-db hal-cups-utils python-cairo network-manager-gnome libao2 iptables gcc libgnomevfs2-0 libmono0 synaptic libpoppler-glib2 python-qt3 libvolume-id0 strace evince apparmor-utils foo2zjs pppoeconf yelp libcupsys2 libflac8 libnm-glib0 libxft2 libpam0g libgimp2.0 adduser openprinting-ppds console-tools openssl ntpdate rar bsdutils libperl5.8 python-apt libgtksourceview2.0-0 scim-tables-additional openoffice.org-help-en-us liblpint-bonobo0 pysdm libpanel-applet2-0 evolution-plugins ubuntu-keyring libfaac0 xserver-xorg-video-cirrus libenchant1c2a eject ttf-arabeyes libvte9 lsb-base libdjvulibre15 cpio libgnomeprint2.2-data smbclient libslp1 libgnomeui-0 rsync libeel2-data libndesk-dbus1.0-cil usbutils openoffice.org-l10n-en-za libmono-security2.0-cil libglib2.0-0 defoma libvorbisfile3 lsof scim-gtk2-immodule openoffice.org-hyphenation deskbar-applet ubuntu-desktop libcaca0 libbind9-30 libgsm1 libxosd2 ghostscript-x tar xserver-xorg-video-tseng app-install-data wbritish dcraw kaudiocreator libedata-cal1.2-6 libsoup2.2-8 libgl1-mesa-dri dpkg-dev
2008-05-22 12:05:06,183 DEBUG Free space on /: 141366763520
2008-05-22 12:05:06,184 DEBUG Dir /usr mounted on /
2008-05-22 12:05:06,185 DEBUG Dir /var mounted on /
2008-05-22 12:05:06,186 DEBUG Dir /boot mounted on /
2008-05-22 12:05:06,187 DEBUG Dir /var/cache/apt/archives mounted on /
2008-05-22 12:05:06,188 DEBUG Dir /home mounted on /
2008-05-22 12:05:06,188 DEBUG fs_free contains: '{'/var': <DistUpgradeController.FreeSpace object at 0xb76d7ec>, '/home': <DistUpgradeController.FreeSpace object at 0xb76d7ec>, '/boot': <DistUpgradeController.FreeSpace object at 0xb76d7ec>, '/usr': <DistUpgradeController.FreeSpace object at 0xb76d7ec>, '/': <DistUpgradeController.FreeSpace object at 0xb76d7ec>, '/var/cache/apt/archives': <DistUpgradeController.FreeSpace object at 0xb76d7ec>}'
2008-05-22 12:05:06,209 DEBUG linux-image-2.6.20-16-generic (upgrade|installed) added with 10485760 to boot space
2008-05-22 12:05:06,318 DEBUG linux-image-2.6.22-14-generic (upgrade|installed) added with 10485760 to boot space
2008-05-22 12:05:06,389 DEBUG linux-image-2.6.24-16-generic (new-install) added with 10485760 to boot space
2008-05-22 12:05:06,455 DEBUG linux-image-2.6.20-15-generic (upgrade|installed) added with 10485760 to boot space
2008-05-22 12:05:07,364 DEBUG dir '/var/cache/apt/archives' needs '811114798.0' of '<DistUpgradeController.FreeSpace object at 0xb76d7ec>' (141366763520.000000)
2008-05-22 12:05:07,365 DEBUG dir '/usr' needs '432852992.0' of '<DistUpgradeController.FreeSpace object at 0xb76d7ec>' (140555648722.000000)
2008-05-22 12:05:07,365 DEBUG dir '/usr' needs '52428800' of '<DistUpgradeController.FreeSpace object at 0xb76d7ec>' (140122795730.000000)
2008-05-22 12:05:07,366 DEBUG dir '/boot' needs '41943040' of '<DistUpgradeController.FreeSpace object at 0xb76d7ec>' (140070366930.000000)
2008-05-22 12:05:07,366 DEBUG dir '/' needs '10485760' of '<DistUpgradeController.FreeSpace object at 0xb76d7ec>' (140028423890.000000)
2008-05-22 12:05:43,279 DEBUG setting MinAge to 10
2008-05-22 12:05:43,280 DEBUG no file '/etc/apt/apt.conf.d/25adept-archive-limits'
2008-05-22 12:15:27,706 INFO cache.commit()
2008-05-22 12:15:30,973 WARNING /usr/lib/libnvidia-tls.so.1 does not points to /usr/lib/tls
2008-05-22 12:15:30,973 INFO /usr/lib/libnvidia-tls.so.1 -> /usr/lib/tls/libnvidia-tls.so.1.0.9639 updated
2008-05-22 12:17:17,893 ERROR SystemError from cache.commit(): installArchives() failed
2008-05-22 12:17:17,893 WARNING cache.commit() raised a SystemError but pkg_failures count is 0
2008-05-22 12:17:17,894 DEBUG running apport_pkgfailure() update-manager: SystemError in cache.commit(): installArchives() failed
2008-05-22 12:57:11,230 DEBUG setting MinAge to 2
2008-05-22 12:57:11,232 DEBUG no file '/etc/apt/apt.conf.d/25adept-archive-limits'

term.log:
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ...
(Reading database ... 145375 files and directories currently installed.)
Preparing to replace xbase-clients 1:7.2-5ubuntu13 (using .../xbase-clients_1%3a7.3+10ubuntu10_all.deb) ...
Unpacking replacement xbase-clients ...
(Reading database ...
(Reading database ... 145374 files and directories currently installed.)
Removing oclock ...
Removing x11perf ...
Removing xbiff ...
Removing xcalc ...
Removing xclipboard ...
Removing xclock ...
Removing xconsole ...
(Reading database ...
(Reading database ... 145330 files and directories currently installed.)
Preparing to replace libc6-dev 2.6.1-1ubuntu10 (using .../libc6-dev_2.7-10ubuntu3_i386.deb) ...
Unpacking replacement libc6-dev ...
Preparing to replace libc6 2.6.1-1ubuntu10 (using .../libc6_2.7-10ubuntu3_i386.deb) ...
Unpacking replacement libc6 ...
dpkg: parse error, in file `/var/lib/dpkg/status' near line 10850 package `hal':
 `Depends' field, syntax error after reference to package `libdbus-1-3'
7.3+10ubuntu10_all.deb) ...
3_i386.deb) ...
Traceback (most recent call last):
  File "logging/__init__.py", line 750, in emit
    self.stream.write(fs % msg)
IOError: [Errno 9] Bad file descriptor
IOError: [Errno 9] Bad file descriptor
IOError: [Errno 9] Bad file descriptor
  File "/usr/share/apport/package_hook", line 47, in <module>
    pr['SourcePackage'] = apport.packaging.get_source(options.package)
  File "/var/lib/python-support/python2.5/apport/packaging_impl.py", line 74, in get_source
    return self._cache(package).sourcePackageName
  File "/var/lib/python-support/python2.5/apport/packaging_impl.py", line 45, in _cache
    self._apt_cache = apt.Cache()
  File "/usr/lib/python2.5/site-packages/apt/cache.py", line 49, in __init__
    self.open(progress)
  File "/usr/lib/python2.5/site-packages/apt/cache.py", line 62, in open
    self._cache = apt_pkg.GetCache(progress)
SystemError: E:Problem parsing dependency Depends, E:Error occurred while processing hal (NewVersion1), E:Problem with MergeList /var/lib/dpkg/status, E:The package lists or status file could not be parsed or opened.
dpkg-query: parse error, in file `/var/lib/dpkg/status' near line 10850 package `hal':
 `Depends' field, syntax error after reference to package `libdbus-1-3'
    self.crashdb = get_crashdb(None)
  File "/var/lib/python-support/python2.5/apport/crashdb.py", line 436, in get_crashdb
    m = __import__('apport.crashdb_impl.' + db['impl'], globals(), locals(), ['CrashDatabase'])
  File "/var/lib/python-support/python2.5/apport/crashdb_impl/launchpad.py", line 22, in <module>
    Bug = Connector.ConnectBug()
  File "/usr/lib/python2.5/site-packages/launchpadbugs/connector.py", line 53, in __init__
    LaunchpadConnector.__init__(self, "Bug", method)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/connector.py", line 38, in __init__
    self.connection = getattr(self.__mod_connection, __connections[__module]["connection"][1])()
  File "/usr/lib/python2.5/site-packages/launchpadbugs/http_connection.py", line 20, in __init__
    __version = "bughelper/%s (Python-urllib2/%s)" %(utils.find_version_number(),urllib2.__version__)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/utils.py", line 22, in find_version_number
    return output.split()[1]
IndexError: list index out of range
hardy: Fatal IO error 9 (Bad file descriptor) on X server :0.0.

Ralph Janke (txwikinger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please attach the files in /var/log/dist-upgrade to this bug report?

This will greatly aid us in tracking down your problem.

Changed in update-manager:
assignee: nobody → txwikinger
status: New → Incomplete
janwill (willekens-jan) wrote :

Here are the logfiles from /var/log/dist-upgrade.

Cheers,

Jan

Michael Vogt (mvo) wrote :

From the log:

...
Preparing to replace libc6 2.6.1-1ubuntu10 (using .../libc6_2.7-10ubuntu3_i386.deb) ...

Unpacking replacement libc6 ...

dpkg: parse error, in file `/var/lib/dpkg/status' near line 10850 package `hal':

 `Depends' field, syntax error after reference to package `libdbus-1-3'

dpkg: parse error, in file `/var/lib/dpkg/status' near line 10850 package `hal':

 `Depends' field, syntax error after reference to package `libdbus-1-3'

dpkg: parse error, in file `/var/lib/dpkg/status' near line 10850 package `hal':

 `Depends' field, syntax error after reference to package `libdbus-1-3'

dpkg: parse error, in file `/var/lib/dpkg/status' near line 10850 package `hal':

...

It looks like your /var/lib/dpkg/status file got corrupted. Could you please attach a compressed version of it?

Michael Vogt (mvo) wrote :

This might be a hardware releated problem (bad memory or corrupt file system).

Could you please run a memtester and check the filesystem?

Thanks,
 MIchael

Ralph Janke (txwikinger) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in dpkg:
status: Incomplete → Invalid
Michael Vogt (mvo) wrote :

Thanks, this looks like fs corruption or similar, could you please attach the file /var/lib/dpkg/status ?

Unpacking replacement libc6 ...
dpkg: parse error, in file `/var/lib/dpkg/status' near line 10850 package `hal':
 `Depends' field, syntax error after reference to package `libdbus-1-3'
7.3+10ubuntu10_all.deb) ...

Changed in update-manager:
status: New → Incomplete
XXXXXXX (yddraiggoch) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers