dpkg crashes if given -i directory as parameter

Bug #1577413 reported by Ville Ranki on 2016-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dpkg (Ubuntu)
Undecided
idiots
Xenial
Undecided
Unassigned

Bug Description

$ sudo dpkg -i /tmp
[sudo] password for user:
dpkg-split: error: error reading /tmp: Is a directory
dpkg:../../src/unpack.c:123:deb_reassemble: internal error: unexpected exit status 2 from dpkg-split

Aborted (core dumped)

Installing a directory is of course an error from user, but dpkg should detect it and not crash.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: dpkg 1.18.4ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: X-Cinnamon
Date: Mon May 2 17:14:01 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-02-12 (445 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: dpkg
UpgradeStatus: No upgrade log present (probably fresh install)

Ville Ranki (ville-ranki) wrote :
Adam Conrad (adconrad) wrote :

This seems to be fixed in yakkety, but I can reproduce it in xenial.

Changed in dpkg (Ubuntu):
status: New → Fix Released
idiots (idiots) on 2016-09-14
Changed in dpkg (Ubuntu):
assignee: nobody → idiots (idiots)
Adam Conrad (adconrad) wrote :

dpkg (1.18.4ubuntu1.3) xenial; urgency=medium

  * Use ohshit() instead of internerr() for unhandled dpkg-split exit
    codes. (i.e. do not abort). Closes: #812679, LP: #1601998

 -- Brian Murray <email address hidden> Fri, 20 Oct 2017 16:14:06 -0700

Changed in dpkg (Ubuntu Xenial):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers