package libdpkg-perl 1.18.2ubuntu5.1 failed to install/upgrade: package libdpkg-perl is not ready for configuration cannot configure (current status 'half-installed')

Bug #1520659 reported by Deckard on 2015-11-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dpkg (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 15.10
libdpkg-perl:
  Installeret: 1.18.2ubuntu5.1
  Kandidat: 1.18.2ubuntu5.1
  Versionstabel:
 *** 1.18.2ubuntu5.1 0
        500 http://dk.archive.ubuntu.com/ubuntu/ wily-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ wily-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.18.2ubuntu5 0
        500 http://dk.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages

Expected:
Normal install via
apt-get dist-upgrade

Instead:
The install was interrupted bu an error message from dpkg, saying that the package was broken.
I ran the suggested command (sudo dpkg -a configure something...) It didn't work, so I ran apt-get -f install, which didn't work either. Finally I ran apt-get --reinstall install libdpkg-perl, which fixed everything.

ProblemType: Package
DistroRelease: Ubuntu 15.10
Package: libdpkg-perl 1.18.2ubuntu5.1
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.1-0ubuntu5
AptOrdering:
 libdpkg-perl: Configure
 NULL: ConfigurePending
Architecture: amd64
Date: Fri Nov 27 08:04:12 2015
DpkgTerminalLog:
 dpkg: error processing package libdpkg-perl (--configure):
  package libdpkg-perl is not ready for configuration
  cannot configure (current status 'half-installed')
DuplicateSignature: package:libdpkg-perl:1.18.2ubuntu5.1:package libdpkg-perl is not ready for configuration cannot configure (current status 'half-installed')
ErrorMessage: package libdpkg-perl is not ready for configuration cannot configure (current status 'half-installed')
InstallationDate: Installed on 2014-02-09 (655 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.2ubuntu5.1
 apt 1.0.10.2ubuntu1
SourcePackage: dpkg
Title: package libdpkg-perl 1.18.2ubuntu5.1 failed to install/upgrade: package libdpkg-perl is not ready for configuration cannot configure (current status 'half-installed')
UpgradeStatus: Upgraded to wily on 2015-10-22 (35 days ago)

Deckard (frank-s) wrote :
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers