dpkg -r --auto-deconfigure does not remove dependencies upstream

Bug #1480539 reported by jean-christophe manciot on 2015-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dpkg (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Server 15.04 - dpkg 1.17.25
----------------------------------
sudo dpkg -r gir1.2-nmgtk-1.0
dpkg: dependency problems prevent removal of gir1.2-nmgtk-1.0:
 gnome-shell depends on gir1.2-nmgtk-1.0 (>= 0.9.8); however:
  Package gir1.2-nmgtk-1.0 is to be removed.

dpkg: error processing package gir1.2-nmgtk-1.0 (--remove):
 dependency problems - not removing
Errors were encountered while processing:
 gir1.2-nmgtk-1.0

Hence, there must be a possibility to tell gnome-shell to stop depending on "gir1.2-nmgtk-1.0", because I'm installing a newer version of Gnome Network Manager compiled from the latest sources (and other libnm packages should share the same fate); however, it seems to be impossible despite the --auto-deconfigure option:

sudo dpkg -r --auto-deconfigure gir1.2-nmgtk-1.0
dpkg: dependency problems prevent removal of gir1.2-nmgtk-1.0:
 gnome-shell depends on gir1.2-nmgtk-1.0 (>= 0.9.8); however:
  Package gir1.2-nmgtk-1.0 is to be removed.

dpkg: error processing package gir1.2-nmgtk-1.0 (--remove):
 dependency problems - not removing
Errors were encountered while processing:
 gir1.2-nmgtk-1.0

As you can see in the error messages, there's absolutely no difference with the previous command run without the --auto-deconfigure option. That option either has not been implemented or there's some issue with the associated code.

That's an important point because that would allow us to replace many old packages installed from the official repositories (with other packages depending on them) with new ones compiled from sources.

This bug prevents that and is an obstacle to innovation.
It is the responsability of the administrator to use this option correctly and with awareness of the consequences.

summary: - dpkg --r --auto-deconfigure does not remove dependencies upstream
+ dpkg -r --auto-deconfigure does not remove dependencies upstream
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers