Ubuntu

dpkg-triggers transitional activation did not happen

Reported by Kees Cook on 2007-08-17
4
Affects Status Importance Assigned to Milestone
dpkg (Ubuntu)
High
Ian Jackson

Bug Description

Binary package hint: dpkg

This is likely due to mass confusion I caused in dpkg by running out of disk space repeatedly during a gutsy dist-upgrade. I do not have the stdout/stderr any more (sorry), but as requested, I will attach the dpkg log. What I basically saw were triggers generated for update-initramfs, without a run of update-initramfs at the end.

Related branches

Kees Cook (kees) wrote :

Attached...

Ian Jackson (ijackson) wrote :

Following discussions with Kees, I am convinced that there is a bug here. He has managed to get his system into this state:
 * triggers/Deferred exists
 * triggers/update-initramfs does not
 * initramfs-tools interested in update-initramfs is installed

Looking at the log it seems clear that the new update-initramfs was unpacked before the new dpkg was run. Therefore the transitional activation didn't run or didn't work, or the call to dpkg-trigger from update-initramfs created Deferred (which it shouldn't, obviously).

Changed in dpkg:
assignee: nobody → ijackson
importance: Undecided → High
status: New → Confirmed
Kees Cook (kees) wrote :

And note that re-installing initramfs-tools solved the problem:

09:39 kees@gorgon$ sudo apt-get --reinstall install volumeid
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 55 not upgraded.
Need to get 73.7kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://se.archive.ubuntu.com gutsy/main volumeid 113-0ubuntu7 [73.7kB]
Fetched 73.7kB in 0s (101kB/s)
(Reading database ... 349139 files and directories currently installed.)
Preparing to replace volumeid 113-0ubuntu7 (using .../volumeid_113-0ubuntu7_amd64.deb) ...
Unpacking replacement volumeid ...
Setting up volumeid (113-0ubuntu7) ...
update-initramfs: deferring update (trigger activated)

09:39 kees@gorgon$ dpkg -s initramfs-tools | egrep '(Status|Version)'
Status: install ok installed
Version: 0.85eubuntu17
09:40 kees@gorgon$ cat /var/lib/dpkg/triggers/Deferred
09:41 kees@gorgon$ cat /var/lib/dpkg/triggers/update-initramfs
cat: /var/lib/dpkg/triggers/update-initramfs: No such file or directory
09:41 kees@gorgon$ ls /var/lib/dpkg/triggers
Deferred Lock
09:43 kees@gorgon$ sudo apt-get --reinstall install initramfs-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 55 not upgraded.
Need to get 63.5kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://se.archive.ubuntu.com gutsy/main initramfs-tools 0.85eubuntu17 [63.5kB]
Fetched 63.5kB in 0s (146kB/s)
(Reading database ... 349139 files and directories currently installed.)
Preparing to replace initramfs-tools 0.85eubuntu17 (using .../initramfs-tools_0.85eubuntu17_all.deb) ...
Unpacking replacement initramfs-tools ...
Setting up initramfs-tools (0.85eubuntu17) ...
update-initramfs: Generating /boot/initrd.img-2.6.22-9-generic

09:46 kees@gorgon$ sudo apt-get --reinstall install volumeid
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 55 not upgraded.
Need to get 0B/73.7kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 349139 files and directories currently installed.)
Preparing to replace volumeid 113-0ubuntu7 (using .../volumeid_113-0ubuntu7_amd64.deb) ...
Unpacking replacement volumeid ...
Setting up volumeid (113-0ubuntu7) ...
update-initramfs: deferring update (trigger activated)

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.22-9-generic

Johan Kiviniemi (ion) wrote :

My system seems to be in the same state. Attaching dpkg.log in case it’s of any help.

Henrik Nilsen Omma (henrik) wrote :

Moving milestone.

Ian Jackson (ijackson) wrote :

I think this was fixed in 1.14.5ubuntu10.

Changed in dpkg:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers