Ubuntu

dselect error: foreign architectures enabled but multi-arch is not supported

Reported by jth on 2012-10-15
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
dpkg (Debian)
New
Unknown
dpkg (Ubuntu)
Undecided
Unassigned

Bug Description

LANG=C ; dselect select
dselect: error: foreign architectures enabled but multi-arch is not supported

Maybe we should add "Please try another package manager for now. For example aptitude or .." to the error message.
Or should we remove package dselect completely from amd64 arch if it is not able to handle it?

Bug or feature request to add multi-arch support to dselect and what to do if you want to continue using it.

lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

apt-cache policy dselect
dselect:
  Installed: 1.16.7ubuntu6
  Candidate: 1.16.7ubuntu6
  Version table:
 *** 1.16.7ubuntu6 0
        500 http://se.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

Same from Debian dselect: no support for multi-arch
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=664893

grep -n -A2 -B4 "foreign architectures" dselect/main.cc
365-
366- // XXX: Multi-Arch is not supported, bail out.
367- for (arch = dpkg_arch_get_list(); arch; arch = arch->next)
368- if (arch->type == arch_foreign)
369: ohshit(_("foreign architectures enabled but multi-arch is not supported"));

http://anonscm.debian.org/gitweb/?p=dpkg/dpkg.git;a=commitdiff;h=62467910df606a1daaea096f66018506a3ea451e

authorGuillem Jover <email address hidden>
 Tue, 31 Jan 2012 18:57:18 +0000 (19:57 +0100)
committerGuillem Jover <email address hidden>
 Wed, 1 Feb 2012 05:31:46 +0000 (06:31 +0100)
"The selection code does not support multi-arch at all, so do not even try to run it if there's a foreign architecture configured."

OK so if I reverse the patch it is working as before in precise. mulit-arch selection is not working great but at least it can do other things like before quantal 12.10.

To rebuild..
apt-get source dselect
Reverse patch in dselect/main.cc
dpkg-buildpackage -b -us -uc
dpkg -i dpkg -i dselect_*.deb

--
Johan

Changed in dpkg (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dpkg (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.