Race condition in start-stop-daemon when using the --background and --make-pidfile options

Bug #1036899 reported by Nir Soffer on 2012-08-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dpkg (Debian)
Fix Released
Unknown
dpkg (Ubuntu)
Undecided
Unassigned

Bug Description

  When using the --background and --make-pidfile options. The parent process may
  exit before the child daemon process creates the pidfile and write the pid to
  the pidfile. This may lead to failure of --stop or --start, not finding a
  pidfile or finding an empty pidfile.

The attachment "Fix race condition in start-stop-daemon when using --background and --make-pidfile options." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dpkg (Ubuntu):
status: New → Confirmed
Changed in dpkg (Debian):
status: Unknown → New
Changed in dpkg (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.