package dphys-swapfile 20100506-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1496216 reported by Luis on 2015-09-16
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
dphys-swapfile (Ubuntu)
High
Axel Beckert

Bug Description

New RaspberryPi Ubuntu installation sufered an installation failure. Actions prior to this event included the root resize of SD card.

ProblemType: Package
DistroRelease: Ubuntu 15.04
Package: dphys-swapfile 20100506-1
ProcVersionSignature: Ubuntu 3.18.0-20.21-rpi2 3.18.11
Uname: Linux 3.18.0-20-rpi2 armv7l
ApportVersion: 2.17.2-0ubuntu1
AptOrdering:
 dphys-swapfile: Install
 dphys-swapfile: Configure
 NULL: ConfigurePending
Architecture: armhf
Date: Tue Sep 15 22:09:49 2015
Dependencies:
 dc 1.06.95-9build1
 gcc-5-base 5.1~rc1-0ubuntu1
 libc6 2.21-0ubuntu4
 libgcc1 1:5.1~rc1-0ubuntu1
 multiarch-support 2.21-0ubuntu4
DuplicateSignature: package:dphys-swapfile:20100506-1:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.17.25ubuntu1
 apt 1.0.9.7ubuntu4
SourcePackage: dphys-swapfile
Title: package dphys-swapfile 20100506-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Luis (lozano-luis) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dphys-swapfile (Ubuntu):
status: New → Confirmed
Changed in dphys-swapfile (Ubuntu):
importance: Undecided → High
polypagan (polypagan) wrote :

"sudo systemctl start dphys-swapfile.service" works and corrects timeout problem.
My guess? Slow machine (heavy OS). May need to increase timeout to accommodate.

Axel Beckert (xtaran) on 2018-08-12
Changed in dphys-swapfile (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Axel Beckert (xtaran)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dphys-swapfile - 20100506-4

---------------
dphys-swapfile (20100506-4) unstable; urgency=low

  * Add patch to restrict swap file size to (configurable) 50% of the
    remaining disk space (excluding potentially already existing
    dphys-swapfile swap files). (Closes: #596187)
  * Declare compliance with Debian Policy 4.2.0.
    + Use HTTPS for the debian copyright format URL.
    + Replace /var/run/ in CONF_SWAPFILE example in man page with nowadays
      more realistic /var/tmp/.
  * Update Vcs-* headers for move to Salsa.
  * Bump debhelper compatibility level to 11.
    + Update versioned build-dependency on debhelper accordingly.
  * Add a systemd .service file. (Closes: #857861)
    + Thanks to Christian Göttsche for the service file template.
    + Should also fix issues where systemd kills the init script when
      dphys-swapfile takes long to setup the swap file, e.g. due to slow
      SD cards, since with "Type=oneshot" that timeout is disabled.
      (LP: #1496216)
  * Set "Rules-Requires-Root: no".
  * Update copyright years in debian/copyright.
  * Add a DEP12 debian/upstream/metadata file.

 -- Axel Beckert <email address hidden> Mon, 13 Aug 2018 00:38:54 +0200

Changed in dphys-swapfile (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers