dpdk 2.2.0-0ubuntu7 source package in Ubuntu

Changelog

dpdk (2.2.0-0ubuntu7) xenial; urgency=medium

  * Increase max_map_count after setting huge pages (LP: #1507921):
    - The default config of 65530 would cause issues as soon as about 64GB or
      more are used as 2M huge pages for dpdk.
    - Increase this value to base+2*#hugepages to avoid issues on huge systems.
  * d/p/ubuntu-backport-[28-32,34-35] backports for stability (LP: #1568838):
     - these will be in the 16.04 dpdk release, delta can then be dropped.
     - 5 fixes that do not change api/behaviour but fix serious issues.
        - 01 f82f705b lpm: fix allocation of an existing object
        - 02 f9bd3342 hash: fix multi-process support
        - 03 1aadacb5 hash: fix allocation of an existing object
        - 04 5d7bfb73 hash: fix race condition at creation
        - 05 fe671356 vfio: fix resource leak
        - 06 356445f9 port: fix ring writer buffer overflow
        - 07 52f7a5ae port: fix burst size mask type
  * d/p/ubuntu-backport-33-vhost-user-add-error-handling-for-fd-1023.patch
     - this will likely be in dpdk release 16.07 and delta can then be dropped.
     - fixes a crash on using fd's >1023 (LP: #1566874)
  * d/p/ubuntu-fix-lpm-use-after-free-and-leak.patch fix lpm_free (LP: #1569375)
     - the old patches had an error freeing a pointer which had no meta data
     - that lead to a crash on any lpm_free call
     - folded into the fix that generally covers the lpm allocation and free
       weaknesses already (also there this particular mistake was added)

 -- Christian Ehrhardt <email address hidden>  Tue, 12 Apr 2016 16:13:47 +0200

Upload details

Uploaded by:
Christian Ehrhardt  on 2016-04-13
Sponsored by:
James Page
Uploaded to:
Xenial
Original maintainer:
Ubuntu Developers
Architectures:
amd64 i386 all
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Xenial release on 2016-04-13 main libs

Builds

Xenial: [FULLYBUILT] amd64 [FULLYBUILT] i386

Downloads

File Size SHA-256 Checksum
dpdk_2.2.0.orig.tar.gz 15.4 MiB 77206ad93618ec93ef6e59566e240aa80b6f660d12693febf0fa96ee23bd610d
dpdk_2.2.0-0ubuntu7.debian.tar.xz 44.1 KiB 3c4d3b8460d44a138daa603e8e641147828f22595e2afe4a0d6f3d1f73dee0ce
dpdk_2.2.0-0ubuntu7.dsc 2.2 KiB 7d490e6721ecfd32f9d86e4c104786406ab7b81883b2cc952bc908b8902238e7

Available diffs

View changes file

Binary packages built by this source

dpdk: No summary available for dpdk in ubuntu yakkety.

No description available for dpdk in ubuntu yakkety.

dpdk-dbgsym: debug symbols for package dpdk

 DPDK is a set of libraries for fast packet processing. Applications run
 in user-space and communicate directly with dedicated network interfaces.
 This package contains the runtime environment to run DPDK applications.

dpdk-dev: No summary available for dpdk-dev in ubuntu yakkety.

No description available for dpdk-dev in ubuntu yakkety.

dpdk-doc: Data Plane Development Kit (documentation)

 DPDK is a set of libraries for fast packet processing. Applications run
 in user-space and communicate directly with dedicated network interfaces.
 This package contains the complete set of documentation and guides.

libdpdk-dev: Data Plane Development Kit (basic development files)

 DPDK is a set of libraries for fast packet processing. Applications run
 in user-space and communicate directly with dedicated network interfaces.
 This package contains the basic headers and library files required to
 build external applications which will also require at least SSE3 support
 when running.

libdpdk0: Data Plane Development Kit (runtime libraries)

 DPDK is a set of libraries for fast packet processing. Applications run
 in user-space and communicate directly with dedicated network interfaces.
 This package contains the runtime libraries which require at least SSE3
 support in the CPU.

libdpdk0-dbgsym: debug symbols for package libdpdk0

 DPDK is a set of libraries for fast packet processing. Applications run
 in user-space and communicate directly with dedicated network interfaces.
 This package contains the runtime libraries which require at least SSE3
 support in the CPU.