dpdk: ppc64el autopkgtest regressed in release

Bug #1939861 reported by Graham Inggs
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dpdk (Ubuntu)
Undecided
Unassigned
Hirsute
Undecided
Unassigned

Bug Description

[Impact]

 * Some tests (just a small portion of a vast list of tests) is not really
   breaking due to real issues but just happen to be notorious timeouts
   or flaky in the Ubuntu build&test environment.

 * We have fixed that in Debian and Impish already, but the same behavior
   now also affects the MRE of 20.11.3 therefore backport the same test
   improvements to Hirsute.

[Test Plan]

 * Build time and autopkgtests are supposed to work (they are anyway for
   an SRU, but for this fix this is exactly the test that we want/need
   to do)

[Where problems could occur]

 * If the patches would be wrong they could have broken the tests, but
   that would then just not build and thereby not migrate. OTOH there is
   theoretical chance that the few disabled tests would have catched
   something down the road which they now no more do - but that isn't
   that much of a regression, more a trade-off that we want to make.

[Other Info]

 * This initially only affected impish, but later it was found that
   Hirsute is affected as well. Therefore on this MRE we want to improve
   it here as well.
 * To be clear this really is flaky, we could have just hit retry a few
   times and get through without - but I think we agree that flaky tests
   are not really helpful and can cause a lot of pain.

---

dpkg's autopkgtest on ppc64el has regressed in release [1].

This currently blocks pexpect/8.0-2ubuntu1 from migrating to -release.

[1] https://autopkgtest.ubuntu.com/packages/dpdk/impish/ppc64el

Related branches

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Gladly it was 4/4 times the same test => acl_autotest
We need to skip it as we do with others.

Changed in dpdk (Ubuntu):
status: New → Triaged
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Submitted to Debian
  https://salsa.debian.org/debian/dpdk/-/merge_requests/52
Submitted for Ubuntu
  https://code.launchpad.net/~paelzer/ubuntu/+source/dpdk/+git/dpdk/+merge/407060
PPA for testing
  https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/4647/+packages

@Ginggs - I'm on the run, could you later once built test if this works and comment on the MP about the result?

Revision history for this message
Graham Inggs (ginggs) wrote :

Will do!

In the meantime, I submitted a MP to hint the autopkgtest failure: https://code.launchpad.net/~ginggs/britney/+git/hints-ubuntu/+merge/407058

Revision history for this message
Brian Murray (brian-murray) wrote :

The hint has been merged.

Graham Inggs (ginggs)
Changed in glibc (Ubuntu):
status: New → Invalid
Changed in pexpect (Ubuntu):
status: New → Invalid
Changed in util-linux (Ubuntu):
status: New → Invalid
Changed in zlib (Ubuntu):
status: New → Invalid
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Now passing
  https://autopkgtest.ubuntu.com/results/autopkgtest-impish/impish/ppc64el/d/dpdk/20210816_082513_d8152@/log.gz

It should soon have all tests complete (so far no failures) and migrate.

Revision history for this message
Graham Inggs (ginggs) wrote :

except for being blocked by glibc...

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Yeah, only hanging on glibc indeed.
Since the reported test fail is fixed let us mark it "fix released", that way it shows only the glibc transition and not the (now fixed) update excuse bug in update-excuses.

Changed in dpdk (Ubuntu):
status: Triaged → Fix Released
description: updated
no longer affects: glibc (Ubuntu Hirsute)
no longer affects: pexpect (Ubuntu Hirsute)
no longer affects: util-linux (Ubuntu Hirsute)
no longer affects: zlib (Ubuntu Hirsute)
Changed in dpdk (Ubuntu Hirsute):
status: New → Triaged
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Test built the test-modified version and uploaded to Hirsute-unapproved

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Graham, or anyone else affected,

Accepted dpdk into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dpdk/20.11.3-0ubuntu0.21.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in dpdk (Ubuntu Hirsute):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-hirsute
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

The tests are skipped in autopkgtest as they used to (for SRU non changing behavior we kept it that way) but on build time where they before sometimes broke things via flakiness no issues are seen on this build.

Setting verified for this bug.

tags: added: verification-done verification-done-hirsute
removed: verification-needed verification-needed-hirsute
Mathew Hodson (mhodson)
no longer affects: glibc (Ubuntu)
no longer affects: pexpect (Ubuntu)
no longer affects: util-linux (Ubuntu)
no longer affects: zlib (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dpdk - 20.11.3-0ubuntu0.21.04.2

---------------
dpdk (20.11.3-0ubuntu0.21.04.2) hirsute; urgency=medium

  * Skip flaky self-tests to make the tests more reliable (LP: #1939861)
    - d/p/disable_ppc64_autopkgtest_fails.patch: skip known false-positives
    - d/p/disable_armhf_autopkgtest_fails.patch: disable arm failures that do
      not represent regressions
    - d/p/disable_autopkgtest_fails.patch: disable failures that do not
      represent regressions
    - Add disable_lcores_autotest_ppc.patch to fix ppc64el autopkgtest

dpdk (20.11.3-0ubuntu0.21.04.1) hirsute; urgency=medium

  * Merge LTS stable release 20.11.3 (LP: #1940913)
    Release notes are available at:
    https://doc.dpdk.org/guides-20.11/rel_notes/release_20_11.html#id1
    - Remove test-catch-coredumps.patch [now part of upstream]
  * d/p/u/lp-1940957-net-i40e-support-25G-AOC-ACC-cables.patch: fix issues
    with 25G AOC cables (LP: #1940957)

 -- Christian Ehrhardt <email address hidden> Wed, 08 Sep 2021 09:00:48 +0200

Changed in dpdk (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for dpdk has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

FYI: Also Fixed in jammy-release via https://launchpad.net/ubuntu/+source/dpdk/21.11-1 which has our former delta.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers