Can't install for cross-building

Bug #1585517 reported by Michał Sawicz on 2016-05-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
doxyqml (Ubuntu)
Undecided
Unassigned
Declined for Yakkety by Dimitri John Ledkov
Xenial
Undecided
Unassigned
python-setuptools (Ubuntu)
Undecided
Unassigned
Declined for Yakkety by Dimitri John Ledkov
Xenial
Undecided
Unassigned

Bug Description

# apt-get -aarmhf build-dep unity8
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 builddeps:unity8:armhf : Depends: doxyqml:armhf but it is not installable
[...]
                          Depends: python3-setuptools:armhf but it is not installable
[...]
E: Unable to correct problems, you have held broken packages.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: doxyqml 0.2.0-1
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Wed May 25 09:07:24 2016
InstallationDate: Installed on 2016-05-06 (18 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
SourcePackage: doxyqml
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Dependencies: python3-pkg-resources 20.7.0-1
DistroRelease: Ubuntu 16.04
InstallationDate: Installed on 2016-05-06 (18 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
Package: python3-setuptools 20.7.0-1
PackageArchitecture: all
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Tags: xenial
Uname: Linux 4.4.0-22-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sbuild sudo
_MarkForUpload: True

Michał Sawicz (saviq) wrote :

apport information

tags: added: apport-collected
description: updated

apport information

Dimitri John Ledkov (xnox) wrote :

I think the problem is that doxyqml is not marked "Multi-Arch: foreign".

And in unity8 build-depends "python3-setuptools" most probably should be "python3-setuptools:any".

But I'm not too sure.

Michał Sawicz (saviq) wrote :

> I think the problem is that doxyqml is not marked "Multi-Arch: foreign".

That does seem to help indeed.

> And in unity8 build-depends "python3-setuptools" most probably should be "python3-setuptools:any".

I tried that, unfortunately:

[...]
 builddeps:unity8:armhf : Depends: python3-setuptools:any but it is not installable
[...]

Michał Sawicz (saviq) wrote :

I actually had to add Multi-Arch: foreign to all binaries of python-setuptools and then it works.

Looking at the table in [1] it does seem like the correct solution?

[1] https://wiki.ubuntu.com/MultiarchCross#Utilizing_Multiarch

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package doxyqml - 0.2.0-1ubuntu1

---------------
doxyqml (0.2.0-1ubuntu1) yakkety; urgency=medium

  * Mark package Multi-Arch: foreign, for use as a cross build dependency.
    LP: #1585517.

 -- Steve Langasek <email address hidden> Tue, 28 Jun 2016 09:52:21 -0700

Changed in doxyqml (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-setuptools - 20.10.1-1.1ubuntu1

---------------
python-setuptools (20.10.1-1.1ubuntu1) yakkety; urgency=medium

  * Mark package as Multi-Arch: foreign for use as cross-builddeps.
    LP: #1585517.

 -- Steve Langasek <email address hidden> Tue, 28 Jun 2016 10:43:00 -0700

Changed in python-setuptools (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers