dovecot restart/stop&start fails due to child processes still running

Bug #873390 reported by James Page on 2011-10-13
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
dovecot (Ubuntu)
Medium
James Page

Bug Description

stop dovecot && start dovecot randomly fails due to a running child process not exiting fast enough:

Oct 13 15:04:58 ubuntu dovecot: master: Error: service(anvil): Socket already exists: /var/run/dovecot/anvil
Oct 13 15:04:58 ubuntu dovecot: master: Error: service(anvil): Socket already exists: /var/run/dovecot/anvil-auth-penalty
Oct 13 15:04:58 ubuntu dovecot: master: Fatal: Failed to start listeners
Oct 13 15:04:58 ubuntu kernel: [11132.825253] init: dovecot main process (8668) terminated with status 89

The dovecot anvil process appears to be the cause of the problem:

root 8418 8080 0 15:02 pts/0 00:00:00 stop dovecot
root 8419 1 0 15:02 ? 00:00:00 dovecot/anvil
root 8422 8420 0 15:02 ? 00:00:00 grep dovecot

This is an issue specific to Ubuntu due to the use of upstart; upstart only monitors the parent process which exits before the child processes have completed; the original Debian init script appears to make provision for this and does not suffer from the same issue.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: dovecot-common 1:2.0.13-1ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Thu Oct 13 15:40:37 2011
InstallationMedia: Ubuntu-Server 11.10 "Oneiric Ocelot" - Release i386 (20111011)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: dovecot
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.init.dovecot.conf: [deleted]

Related branches

James Page (james-page) wrote :
James Page (james-page) wrote :

Raised upstream on dovecot mailing list

Changed in dovecot (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → James Page (james-page)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dovecot - 1:2.0.15-1ubuntu2

---------------
dovecot (1:2.0.15-1ubuntu2) precise; urgency=low

  * Resolve issue with intermittent restart failures (LP: #873390):
    - d/patches/fix-racey-restart.patch: Backported patch from current
      development release which ensures all child processes terminate prior
      to the main dovecot process.
 -- James Page <email address hidden> Fri, 11 Nov 2011 14:38:41 +0000

Changed in dovecot (Ubuntu):
status: In Progress → Fix Released
Antono Vasiljev (antono) wrote :

any plans to backport it to oneiric?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers